aboutsummaryrefslogtreecommitdiffstats
path: root/converters/uudeview
diff options
context:
space:
mode:
authorhoek <hoek@FreeBSD.org>2004-03-25 12:13:31 +0800
committerhoek <hoek@FreeBSD.org>2004-03-25 12:13:31 +0800
commit36855398fad8a2e544a9129fa898bbd03ba92bbf (patch)
tree952c5b56ae6839525920b6a007c11f963cfe2f55 /converters/uudeview
parent2d48ef36c84b142b1cb292314b1dac37ab34c0b9 (diff)
downloadfreebsd-ports-gnome-36855398fad8a2e544a9129fa898bbd03ba92bbf.tar.gz
freebsd-ports-gnome-36855398fad8a2e544a9129fa898bbd03ba92bbf.tar.zst
freebsd-ports-gnome-36855398fad8a2e544a9129fa898bbd03ba92bbf.zip
If inews exists in ${PREFIX}/bin/, then use that instead of using
the copy of inews that inn installs in ${PREFIX}/news/lib/inews. The cnews port likes to put inews in ${PREFIX}/bin/. Explanation: The uudeview port generally doesn't use inews, but it has the ability to post items directly to news if the user requests it. The default inews location is hardcoded at compile time. This port does not DEPEND on any particular news software. Requested by: Daeron <daeron -a-t- optushome com au>
Diffstat (limited to 'converters/uudeview')
-rw-r--r--converters/uudeview/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/converters/uudeview/Makefile b/converters/uudeview/Makefile
index 8e324a406fc6..6862460c02e5 100644
--- a/converters/uudeview/Makefile
+++ b/converters/uudeview/Makefile
@@ -17,8 +17,18 @@ LIB_DEPENDS= uu.3:${PORTSDIR}/converters/uulib
GNU_CONFIGURE= yes
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --enable-inews=${PREFIX}/news/lib/inews \
- --disable-tcl
+CONFIGURE_ARGS= --disable-tcl
+
+.include <bsd.port.pre.mk>
+
+# Try and catch some of the different places that inn and cnews put inews
+.if exists(${PREFIX}/bin/inews)
+# cnews
+CONFIGURE_ARGS+= --enable-inews=${PREFIX}/bin/inews
+.else
+# inn by default
+CONFIGURE_ARGS+= --enable-inews=${PREFIX}/news/lib/inews
+.endif
MAN1= uudeview.1 uuenview.1
@@ -34,4 +44,4 @@ post-install:
@${ECHO_MSG} "===> Not installing available documents"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>