aboutsummaryrefslogtreecommitdiffstats
path: root/converters/uulib
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /converters/uulib
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'converters/uulib')
-rw-r--r--converters/uulib/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/converters/uulib/Makefile b/converters/uulib/Makefile
index 7c782d22ca8c..5c9dbbeff06b 100644
--- a/converters/uulib/Makefile
+++ b/converters/uulib/Makefile
@@ -3,7 +3,7 @@
# Date Created: 04 Aug 1996
# Whom: Tim Vanderhoek <ac199@freenet.hamilton.on.ca>
#
-# $Id: Makefile,v 1.15 1998/06/14 17:31:23 hoek Exp $
+# $Id: Makefile,v 1.16 1998/09/26 23:48:21 steve Exp $
#
DISTNAME= uudeview-0.5.13
@@ -20,6 +20,14 @@ MAN3= uulib.3
ALL_TARGET= libuu.a libuu.so.${VERSION}
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+VERSION= 1
+.else
+VERSION= 1.0
+.endif
+
DOCFILES= HISTORY doc/Makefile doc/README doc/binhex.fig \
doc/library.ltx doc/structure.fig doc/td-v1.c doc/td-v2.c \
doc/td-v3.c doc/test.txt
@@ -42,10 +50,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.mk>
-
-.if ${PORTOBJFORMAT} == "elf"
-VERSION= 1
-.else
-VERSION= 1.0
-.endif
+.include <bsd.port.post.mk>