aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-05 23:05:29 +0800
committeraz <az@FreeBSD.org>2013-08-05 23:05:29 +0800
commit12549b30c2eef8132a2851d6f17e8c45a3491872 (patch)
tree6094da914716107bca7d35889c1b8aab5e6097c7 /converters
parent7e71988ad884bca5467171d41d1f68fd7040697b (diff)
downloadfreebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.tar.gz
freebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.tar.zst
freebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.zip
- Convert to new perl framework
- Trim Makefile header Approved by: tobez@ (maintainer)
Diffstat (limited to 'converters')
-rw-r--r--converters/p5-Boulder/Makefile9
-rw-r--r--converters/p5-Encode-DoubleEncodedUTF8/Makefile9
-rw-r--r--converters/p5-Encode-compat/Makefile9
-rw-r--r--converters/p5-Encoding-FixLatin/Makefile9
-rw-r--r--converters/p5-Number-Nary/Makefile9
-rw-r--r--converters/p5-Number-RecordLocator/Makefile9
-rw-r--r--converters/p5-Text-Unidecode/Makefile9
7 files changed, 21 insertions, 42 deletions
diff --git a/converters/p5-Boulder/Makefile b/converters/p5-Boulder/Makefile
index b2e87c794a49..0d3031b19218 100644
--- a/converters/p5-Boulder/Makefile
+++ b/converters/p5-Boulder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Boulder
-# Date created: Di 13 Mär 2001 19:37:25 CET
-# Whom: Andreas Klemm <andreas@klemm.gtn.com>
-#
+# Created by: Andreas Klemm <andreas@klemm.gtn.com>
# $FreeBSD$
-#
PORTNAME= Boulder
PORTVERSION= 1.30
@@ -17,7 +13,8 @@ COMMENT= An API for hierarchical tag/value structures
BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= Boulder.3 \
Boulder::Blast.3 \
diff --git a/converters/p5-Encode-DoubleEncodedUTF8/Makefile b/converters/p5-Encode-DoubleEncodedUTF8/Makefile
index bb2d5461eb12..88bf22e52172 100644
--- a/converters/p5-Encode-DoubleEncodedUTF8/Makefile
+++ b/converters/p5-Encode-DoubleEncodedUTF8/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: converters/p5-Encode-DoubleEncodedUTF8
-# Date created: 01 October 2009
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Encode-DoubleEncodedUTF8
PORTVERSION= 0.05
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Fix double encoded UTF-8 bytes to the correct ones
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Encode::DoubleEncodedUTF8.3
diff --git a/converters/p5-Encode-compat/Makefile b/converters/p5-Encode-compat/Makefile
index 8e578816b3fb..c89fbb9f98ae 100644
--- a/converters/p5-Encode-compat/Makefile
+++ b/converters/p5-Encode-compat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p5-Encode-compat
-# Date created: Mon April 14th, 2003
-# Whom: Erwin Lansing <erwin@lansing.dk>
-#
+# Created by: Erwin Lansing <erwin@lansing.dk>
# $FreeBSD$
-#
PORTNAME= Encode-compat
PORTVERSION= 0.07
@@ -17,7 +13,8 @@ COMMENT= Compatibility interfaces for Encode.pm on Perl < 5.7.1
BUILD_DEPENDS= p5-Text-Iconv>=0:${PORTSDIR}/converters/p5-Text-Iconv
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Encode::compat.3 Encode::compat::Alias.3
diff --git a/converters/p5-Encoding-FixLatin/Makefile b/converters/p5-Encoding-FixLatin/Makefile
index 1689b2b52b24..3ffd4f73d52d 100644
--- a/converters/p5-Encoding-FixLatin/Makefile
+++ b/converters/p5-Encoding-FixLatin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: converters/p5-Encoding-FixLatin
-# Date created: 29 July 2009
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Encoding-FixLatin
PORTVERSION= 1.02
@@ -15,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Takes mixed encoding input and produces UTF-8 output
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= fix_latin.1
MAN3= Encoding::FixLatin.3
diff --git a/converters/p5-Number-Nary/Makefile b/converters/p5-Number-Nary/Makefile
index 6767189cf951..2f1d7e04217e 100644
--- a/converters/p5-Number-Nary/Makefile
+++ b/converters/p5-Number-Nary/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: converters/p5-Number-Nary
-# Date created: 05 January 2007
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Number-Nary
PORTVERSION= 1.100311
@@ -19,7 +15,8 @@ BUILD_DEPENDS= p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
p5-UDCode>=0:${PORTSDIR}/devel/p5-UDCode
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Number::Nary.3
diff --git a/converters/p5-Number-RecordLocator/Makefile b/converters/p5-Number-RecordLocator/Makefile
index dd6910d92a85..3eb386894490 100644
--- a/converters/p5-Number-RecordLocator/Makefile
+++ b/converters/p5-Number-RecordLocator/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: converters/p5-Number-RecordLocator
-# Date created: 24 January 2007
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Number-RecordLocator
PORTVERSION= 0.005
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Encodes integers into a short locator string
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Number::RecordLocator.3
diff --git a/converters/p5-Text-Unidecode/Makefile b/converters/p5-Text-Unidecode/Makefile
index 359417e70244..31e6782e783f 100644
--- a/converters/p5-Text-Unidecode/Makefile
+++ b/converters/p5-Text-Unidecode/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: converters/p5-Text-Unidecode
-# Date created: 15 December 2004
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Text-Unidecode
PORTVERSION= 0.04
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Text::Unidecode -- US-ASCII transliterations of Unicode text
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Text::Unidecode.3