aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-05-17 17:21:53 +0800
committerwill <will@FreeBSD.org>2000-05-17 17:21:53 +0800
commit1f5a386fc4e9486f7bd98583024f23f6f6945b80 (patch)
tree2abb81be39a4e3ade9b70556b30c6f348c6ef89b /converters
parent33eed746fc9ba073d59016a058a2eec08d18ef0c (diff)
downloadfreebsd-ports-gnome-1f5a386fc4e9486f7bd98583024f23f6f6945b80.tar.gz
freebsd-ports-gnome-1f5a386fc4e9486f7bd98583024f23f6f6945b80.tar.zst
freebsd-ports-gnome-1f5a386fc4e9486f7bd98583024f23f6f6945b80.zip
Woop doop de doop, I've managed to circumvent the kdesupport2 build
problems by disabling ODBC library building. Apparently kdenetwork2 doesn't need that support (it does need mimelib), so we're all right on that! This is the import of KDESUPPORT and KDENETWORK 1.90 (aka KDE2 beta). Repo-copies by: asami
Diffstat (limited to 'converters')
-rw-r--r--converters/kdesupport2/Makefile36
-rw-r--r--converters/kdesupport2/distinfo2
-rw-r--r--converters/kdesupport2/files/patch-ae10
-rw-r--r--converters/kdesupport2/pkg-plist20
4 files changed, 32 insertions, 36 deletions
diff --git a/converters/kdesupport2/Makefile b/converters/kdesupport2/Makefile
index 4b030b847116..65d2069103af 100644
--- a/converters/kdesupport2/Makefile
+++ b/converters/kdesupport2/Makefile
@@ -1,32 +1,28 @@
-# New ports collection makefile for: kdesupport
-# Date created: 28 October 1997
-# Whom: Stefan Eßer <se@freebsd.org>
+# New ports collection makefile for: kdesupport2
+# Date created: Sun May 14 2000 01:14:20
+# Whom: Will Andrews <will@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= kdesupport
-PORTVERSION= 1.1.2.1
+PORTVERSION= 1.90
CATEGORIES= converters kde
MASTER_SITES= $(MASTER_SITE_KDE)
-MASTER_SITE_SUBDIR= stable/1.1.2/distribution/tar/generic/source/bz2
-DISTNAME= kdesupport-1.1.2
+MASTER_SITE_SUBDIR= unstable/distribution/tar/src
-MAINTAINER= se@freebsd.org
+MAINTAINER= will@FreeBSD.org
+MOC= ${X11BASE}/bin/moc2
USE_BZIP2= yes
-
-USE_QT= yes
-USE_LIBTOOL= yes
-CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
- "--without-libjpeg" \
- "--without-libgif" \
- "--without-libgdbm" \
- "--without-libuulib"
-CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" \
- INSTALL_SCRIPT="install -c -m 555"
-
-post-install:
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+USE_QT2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-qt-dir=${X11BASE} \
+ --with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib \
+ --without-libjpeg --without-libgif \
+ --without-libgdbm --without-libuulib \
+ --without-odbc
+CONFIGURE_ENV+= MOC="${MOC}"
.include <bsd.port.mk>
diff --git a/converters/kdesupport2/distinfo b/converters/kdesupport2/distinfo
index 23d7acc7ac06..9bba7474ad3d 100644
--- a/converters/kdesupport2/distinfo
+++ b/converters/kdesupport2/distinfo
@@ -1 +1 @@
-MD5 (kdesupport-1.1.2.tar.bz2) = 6ef9b658cc8cbeb298f333f0528fd1a9
+MD5 (kdesupport-1.90.tar.bz2) = 884a602ec84fb40a840e1dc8403d5db4
diff --git a/converters/kdesupport2/files/patch-ae b/converters/kdesupport2/files/patch-ae
index aa3724a791f5..5694a2ed4dc1 100644
--- a/converters/kdesupport2/files/patch-ae
+++ b/converters/kdesupport2/files/patch-ae
@@ -1,11 +1,11 @@
---- ./mimelib/Makefile.in.org Tue Sep 7 08:24:50 1999
-+++ ./mimelib/Makefile.in Wed Feb 23 18:14:27 2000
-@@ -191,7 +191,7 @@
+--- mimelib/Makefile.in Tue May 9 19:33:18 2000
++++ mimelib/Makefile.in.new Tue May 16 18:32:11 2000
+@@ -233,7 +233,7 @@
DEFS = -D$(LIBVERSION) @DEFS@
--libmimelib_la_LDFLAGS = -version-info 1:0
-+libmimelib_la_LDFLAGS = -version-info 2:0
+-libmimelib_la_LDFLAGS = -version-info 1:1
++libmimelib_la_LDFLAGS = -version-info 3:0
mkinstalldirs = $(SHELL) $(top_srcdir)/admin/mkinstalldirs
CONFIG_HEADER = ../config.h
CONFIG_CLEAN_FILES =
diff --git a/converters/kdesupport2/pkg-plist b/converters/kdesupport2/pkg-plist
index 50ed634494c9..817835db56df 100644
--- a/converters/kdesupport2/pkg-plist
+++ b/converters/kdesupport2/pkg-plist
@@ -45,22 +45,22 @@ include/rdb/hash.h
include/rdb/rdb.h
include/rdb/uint32.h
lib/libQwSpriteField.a
-lib/libQwSpriteField.so.7
+lib/libQwSpriteField.so.8
lib/libjs.a
-lib/libjs.so.3
+lib/libjs.so.4
lib/libmimelib.a
-lib/libmimelib.so.2
+lib/libmimelib.so.3
lib/librdb.a
-lib/librdb.so.56
-@exec ln -sf libQwSpriteField.so.6 %D/lib/libQwSpriteField.so
-@exec ln -sf libjs.so.2 %D/lib/libjs.so
-@exec ln -sf libmimelib.so.1 %D/lib/libmimelib.so
-@exec ln -sf librdb.so.55 %D/lib/librdb.so
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+lib/librdb.so.57
+@exec ln -sf libQwSpriteField.so.7 %D/lib/libQwSpriteField.so
+@exec ln -sf libjs.so.4 %D/lib/libjs.so
+@exec ln -sf libmimelib.so.3 %D/lib/libmimelib.so
+@exec ln -sf librdb.so.57 %D/lib/librdb.so
+@exec /sbin/ldconfig -m %B
@dirrm include/rdb
@dirrm include/mimelib
@unexec rm -f %D/lib/libQwSpriteField.so
@unexec rm -f %D/lib/libjs.so
@unexec rm -f %D/lib/libmimelib.so
@unexec rm -f %D/lib/librdb.so
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
+@unexec /sbin/ldconfig -R