aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-08-18 05:00:40 +0800
committermiwi <miwi@FreeBSD.org>2006-08-18 05:00:40 +0800
commit017318e142dbb6303b4c53ee4e01298e315267a6 (patch)
treede8323a61075bce93479aef65217307f411a4f29 /converters
parent77be694b6eb0d941f54859ccc1975efa8419abca (diff)
downloadfreebsd-ports-gnome-017318e142dbb6303b4c53ee4e01298e315267a6.tar.gz
freebsd-ports-gnome-017318e142dbb6303b4c53ee4e01298e315267a6.tar.zst
freebsd-ports-gnome-017318e142dbb6303b4c53ee4e01298e315267a6.zip
WAP::wbxml module implements binarisation of XML file according the
specification: * WAP - Wireless Application Protocol / Binary XML Content Format Specification / Version 1.3 WBXML (15th May 2000 Approved) The binary format was designed to preserve the element structure of XML. WWW: http://search.cpan.org/dist/WAP-wbxml/ Submitted by: Timur I. Bakeyev <timur(at)com.bat.ru> Approved by: krion (mentor)
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/p5-WAP-wbxml/Makefile33
-rw-r--r--converters/p5-WAP-wbxml/distinfo3
-rw-r--r--converters/p5-WAP-wbxml/files/patch-aa13
-rw-r--r--converters/p5-WAP-wbxml/pkg-descr9
-rw-r--r--converters/p5-WAP-wbxml/pkg-plist9
6 files changed, 68 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 6030587f57dc..8c46047eac8a 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -68,6 +68,7 @@
SUBDIR += p5-Unicode-RecursiveDowngrade
SUBDIR += p5-Unicode-String
SUBDIR += p5-Unicode-UTF8simple
+ SUBDIR += p5-WAP-wbxml
SUBDIR += p5-XML-WBXML
SUBDIR += pecl-fribidi
SUBDIR += php4-iconv
diff --git a/converters/p5-WAP-wbxml/Makefile b/converters/p5-WAP-wbxml/Makefile
new file mode 100644
index 000000000000..8cd1b0ca7297
--- /dev/null
+++ b/converters/p5-WAP-wbxml/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: converters/p5-WAP-wbxml
+# Date created: 1 Aug 2006
+# Whom: Timur I. Bakeyev <bat@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WAP-wbxml
+PORTVERSION= 1.10
+CATEGORIES= converters perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WAP/PERRAD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bat@cpan.org
+COMMENT= Binarization of XML file
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/DOM.pm:${PORTSDIR}/textproc/p5-XML-DOM \
+ ${SITE_PERL}/I18N/Charset.pm:${PORTSDIR}/misc/p5-I18N-Charset \
+ ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= wbxmlc.pl.1
+MAN3= WAP::wbxml.3
+
+post-patch:
+.for file in syncml.wbrules.xml wap.wbrules.xml wbxmlc.pl wbxml.pm wv.wbrules.xml
+ @${PERL} -pi -e 's#\r$$##g' ${WRKSRC}/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/converters/p5-WAP-wbxml/distinfo b/converters/p5-WAP-wbxml/distinfo
new file mode 100644
index 000000000000..ba9b7ca59a3d
--- /dev/null
+++ b/converters/p5-WAP-wbxml/distinfo
@@ -0,0 +1,3 @@
+MD5 (WAP-wbxml-1.10.tar.gz) = 4951247b08a4781d7d5e510cbc5fade8
+SHA256 (WAP-wbxml-1.10.tar.gz) = 1e113ef6114466132e886d92fbc6a079ef2bfa9aed056b12606196bfb6984d10
+SIZE (WAP-wbxml-1.10.tar.gz) = 29153
diff --git a/converters/p5-WAP-wbxml/files/patch-aa b/converters/p5-WAP-wbxml/files/patch-aa
new file mode 100644
index 000000000000..3b1899c624ea
--- /dev/null
+++ b/converters/p5-WAP-wbxml/files/patch-aa
@@ -0,0 +1,13 @@
+--- wbxml.pm.orig Thu Aug 10 14:50:54 2006
++++ wbxml.pm Thu Aug 10 14:51:56 2006
+@@ -9,7 +9,9 @@
+
+ use vars qw($VERSION);
+ $VERSION = '1.10';
+-
++## Create global package version
++$WAP::wbxml::VERSION = $VERSION;
++
+ =head1 NAME
+
+ WAP::wbxml - Binarization of XML file
diff --git a/converters/p5-WAP-wbxml/pkg-descr b/converters/p5-WAP-wbxml/pkg-descr
new file mode 100644
index 000000000000..c6820eea9280
--- /dev/null
+++ b/converters/p5-WAP-wbxml/pkg-descr
@@ -0,0 +1,9 @@
+WAP::wbxml module implements binarisation of XML file according the
+specification:
+
+ * WAP - Wireless Application Protocol / Binary XML Content Format
+ Specification / Version 1.3 WBXML (15th May 2000 Approved)
+
+The binary format was designed to preserve the element structure of XML.
+
+WWW: http://search.cpan.org/dist/WAP-wbxml/
diff --git a/converters/p5-WAP-wbxml/pkg-plist b/converters/p5-WAP-wbxml/pkg-plist
new file mode 100644
index 000000000000..9563cffcb4e1
--- /dev/null
+++ b/converters/p5-WAP-wbxml/pkg-plist
@@ -0,0 +1,9 @@
+bin/wbxmlc.pl
+%%SITE_PERL%%/WAP/wbxml.pm
+%%SITE_PERL%%/WAP/wap.wbrules.xml
+%%SITE_PERL%%/WAP/syncml.wbrules.xml
+%%SITE_PERL%%/WAP/wv.wbrules.xml
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WAP/wbxml/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WAP/wbxml
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WAP
+@dirrmtry %%SITE_PERL%%/WAP