aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
committermat <mat@FreeBSD.org>2015-12-18 01:19:48 +0800
commit9e7703aff1c96dce4c11180df6bfd80c536b777a (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /converters
parentfbcb74cea8547a229eabdb6530aecdeb2689cf82 (diff)
downloadfreebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.gz
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.tar.zst
freebsd-ports-gnome-9e7703aff1c96dce4c11180df6bfd80c536b777a.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Diffstat (limited to 'converters')
-rw-r--r--converters/nomyso/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/converters/nomyso/Makefile b/converters/nomyso/Makefile
index 7fb2268eb3df..18409f88f803 100644
--- a/converters/nomyso/Makefile
+++ b/converters/nomyso/Makefile
@@ -10,19 +10,14 @@ DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Convert MASM/TASM files to NASM compatible sources
-USES= perl5 zip
+USES= perl5 zip dos2unix shebangfix
+SHEBANG_FILES= nomyso.pl
USE_PERL5= run
NO_WRKSUBDIR= yes
NO_BUILD= yes
PLIST_FILES= bin/${PORTNAME}.pl
-post-patch:
- @${REINPLACE_CMD} -E \
- -e 's|[[:cntrl:]]$$||' \
- -e 's|/usr/bin/perl|${PERL}|' \
- ${WRKSRC}/${PORTNAME}.pl
-
do-install:
@${INSTALL_SCRIPT} \
${WRKSRC}/${PORTNAME}.pl \