aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-23 22:37:13 +0800
committermiwi <miwi@FreeBSD.org>2009-05-23 22:37:13 +0800
commitccf357148377d43231541a79367942edf45a46fe (patch)
tree9edc2e096b5aa7dfb3030b263149fa820f11e3af /converters
parenta3f0e7f66b7008d06efc06db95b7480dee19d957 (diff)
downloadfreebsd-ports-gnome-ccf357148377d43231541a79367942edf45a46fe.tar.gz
freebsd-ports-gnome-ccf357148377d43231541a79367942edf45a46fe.tar.zst
freebsd-ports-gnome-ccf357148377d43231541a79367942edf45a46fe.zip
JSON (JavaScript Object Notation, http://json.org) is a lightweight
data-interchange format. It is easy for humans to read and write. It is easy for machines to parse and generate. It is based on a subset of the JavaScript Programming Language, Standard ECMA-262 3rd Edition - December 1999.JSON is a text format that is completely language independent but uses conventions that are familiar to programmers of the C-family of languages, including C, C++, C#, Java, JavaScript, Perl, TCL, and many others. These properties make JSON an ideal data-interchange language. This package provides a simple encoder and decoder for JSON notation. It is intended for use with client-side Javascript applications that make use of HTTPRequest to perform server communication functions - data can be encoded into JSON notation for use in a client-side javascript, or decoded from incoming Javascript requests. JSON format is native to Javascript,and can be directly eval()'ed with no further parsing overhead. WWW: http://pear.php.net/package/Services_JSON/ PR: ports/134870 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile1
-rw-r--r--converters/pear-Services_JSON/Makefile22
-rw-r--r--converters/pear-Services_JSON/distinfo3
-rw-r--r--converters/pear-Services_JSON/pkg-descr17
4 files changed, 43 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 6298fcb52918..4ec9fa2ba662 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -85,6 +85,7 @@
SUBDIR += p5-WAP-wbxml
SUBDIR += p5-XML-WBXML
SUBDIR += pdf2djvu
+ SUBDIR += pear-Services_JSON
SUBDIR += pecl-fribidi
SUBDIR += php4-iconv
SUBDIR += php4-mbstring
diff --git a/converters/pear-Services_JSON/Makefile b/converters/pear-Services_JSON/Makefile
new file mode 100644
index 000000000000..96811ff3c2e5
--- /dev/null
+++ b/converters/pear-Services_JSON/Makefile
@@ -0,0 +1,22 @@
+# Ports collection makefile for: pear-Services_JSON
+# Date created: 22 May, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Services_JSON
+PORTVERSION= 1.0.0
+CATEGORIES= converters www pear
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= PHP implementaion of json_encode/decode
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+FILES= JSON.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/converters/pear-Services_JSON/distinfo b/converters/pear-Services_JSON/distinfo
new file mode 100644
index 000000000000..68c3b262aabe
--- /dev/null
+++ b/converters/pear-Services_JSON/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Services_JSON-1.0.0.tgz) = 573ff2468330f7570c738957bc297ff4
+SHA256 (PEAR/Services_JSON-1.0.0.tgz) = 934ba37d6f16a1ef13a2e40ca4561425573f4cc768516d7ba9962ec8af9bd751
+SIZE (PEAR/Services_JSON-1.0.0.tgz) = 8375
diff --git a/converters/pear-Services_JSON/pkg-descr b/converters/pear-Services_JSON/pkg-descr
new file mode 100644
index 000000000000..22187c466f8f
--- /dev/null
+++ b/converters/pear-Services_JSON/pkg-descr
@@ -0,0 +1,17 @@
+JSON (JavaScript Object Notation, http://json.org) is a lightweight
+data-interchange format. It is easy for humans to read and write. It is
+easy for machines to parse and generate. It is based on a subset of the
+JavaScript Programming Language, Standard ECMA-262 3rd Edition - December
+1999.JSON is a text format that is completely language independent
+but uses conventions that are familiar to programmers of the C-family of
+languages, including C, C++, C#, Java, JavaScript, Perl, TCL, and many
+others. These properties make JSON an ideal data-interchange language.
+
+This package provides a simple encoder and decoder for JSON notation. It
+is intended for use with client-side Javascript applications that make
+use of HTTPRequest to perform server communication functions - data can
+be encoded into JSON notation for use in a client-side javascript, or
+decoded from incoming Javascript requests. JSON format is native to
+Javascript,and can be directly eval()'ed with no further parsing overhead.
+
+WWW: http://pear.php.net/package/Services_JSON/