aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /converters
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'converters')
-rw-r--r--converters/ascii2binary/Makefile3
-rw-r--r--converters/cocot/Makefile3
-rw-r--r--converters/enca/Makefile4
-rw-r--r--converters/fix-mime-charset/Makefile4
-rw-r--r--converters/ical2html/Makefile4
-rw-r--r--converters/pdf2djvu/Makefile4
-rw-r--r--converters/rcctools/Makefile4
-rw-r--r--converters/recode/Makefile4
-rw-r--r--converters/uudeview/Makefile2
-rw-r--r--converters/xdeview/Makefile12
-rw-r--r--converters/ytnef/Makefile1
11 files changed, 23 insertions, 22 deletions
diff --git a/converters/ascii2binary/Makefile b/converters/ascii2binary/Makefile
index 43f4efb714da..09c284f8bcac 100644
--- a/converters/ascii2binary/Makefile
+++ b/converters/ascii2binary/Makefile
@@ -19,7 +19,8 @@ USE_GETTEXT= yes
LICENSE= GPLv3
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= bin/ascii2binary bin/binary2ascii
diff --git a/converters/cocot/Makefile b/converters/cocot/Makefile
index a9c8dda15318..de9372ee05ac 100644
--- a/converters/cocot/Makefile
+++ b/converters/cocot/Makefile
@@ -17,7 +17,8 @@ USE_BZIP2= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
DOCS_EN= COPYING ChangeLog
DOCS_JA= ChangeLog.ja README.ja
diff --git a/converters/enca/Makefile b/converters/enca/Makefile
index db884d4f4cdb..9ffc78353c86 100644
--- a/converters/enca/Makefile
+++ b/converters/enca/Makefile
@@ -29,8 +29,8 @@ USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --with-html-dir=${DOCSDIR}
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
- LDFLAGS=-L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= enca.1
MLINKS= enca.1 enconv.1
diff --git a/converters/fix-mime-charset/Makefile b/converters/fix-mime-charset/Makefile
index ebf2ce660d0f..fd9b6feaba2b 100644
--- a/converters/fix-mime-charset/Makefile
+++ b/converters/fix-mime-charset/Makefile
@@ -21,8 +21,8 @@ PORTDOCS= README.koi8r README
GNU_CONFIGURE= yes
USE_PERL5_BUILD= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
MAN1= fix-mime-charset.1
PLIST_FILES= bin/fix-mime-charset
diff --git a/converters/ical2html/Makefile b/converters/ical2html/Makefile
index 9e81b85d7c2e..0cd10821eb0a 100644
--- a/converters/ical2html/Makefile
+++ b/converters/ical2html/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= ical.44:${PORTSDIR}/devel/libical
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/libical -I${LOCALBASE}/include" \
- LDFLAGS=-L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include/libical -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.mk>
diff --git a/converters/pdf2djvu/Makefile b/converters/pdf2djvu/Makefile
index 2074d9499e33..24d178448d54 100644
--- a/converters/pdf2djvu/Makefile
+++ b/converters/pdf2djvu/Makefile
@@ -20,8 +20,8 @@ LIB_DEPENDS= poppler.13:${PORTSDIR}/graphics/poppler
LIB_DEPENDS+= djvulibre.24:${PORTSDIR}/graphics/djvulibre-nox11
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS=${PTHREAD_LIBS} \
- CPPFLAGS=-I${LOCALBASE}/include
+CONFIGURE_ENV= LIBS=${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
USE_GMAKE= yes
PLIST_FILES= bin/pdf2djvu
diff --git a/converters/rcctools/Makefile b/converters/rcctools/Makefile
index 92c2e74176c2..15a59c2fff88 100644
--- a/converters/rcctools/Makefile
+++ b/converters/rcctools/Makefile
@@ -19,8 +19,8 @@ LIB_DEPENDS= rcc.2:${PORTSDIR}/devel/librcc
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
PLIST_FILES= bin/rcc-recode
diff --git a/converters/recode/Makefile b/converters/recode/Makefile
index 18a205d72d6a..b369c5178957 100644
--- a/converters/recode/Makefile
+++ b/converters/recode/Makefile
@@ -20,8 +20,8 @@ USE_AUTOTOOLS= libtool
USE_PERL5= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --without-included-gettext
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -fPIC
MAN1= recode.1
diff --git a/converters/uudeview/Makefile b/converters/uudeview/Makefile
index 2eb39d36d2c0..46d9d0804649 100644
--- a/converters/uudeview/Makefile
+++ b/converters/uudeview/Makefile
@@ -16,7 +16,7 @@ COMMENT= A program for uu/xx/Base64/BinHex/yEnc de-/encoding
LIB_DEPENDS= uu.3:${PORTSDIR}/converters/uulib
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-tcl
.include <bsd.port.pre.mk>
diff --git a/converters/xdeview/Makefile b/converters/xdeview/Makefile
index a5b3a96c9962..c067f444a69a 100644
--- a/converters/xdeview/Makefile
+++ b/converters/xdeview/Makefile
@@ -32,12 +32,12 @@ DOCFILES= ${FILESDIR}/porting.notes
USE_TK= 82+
.include <bsd.port.pre.mk>
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib \
- -lX11 -ltcl${TCL_VER:S/.//} \
- -ltk${TCL_VER:S/.//} -lm" \
- CPPFLAGS="-I${TCL_INCLUDEDIR} -DHAVE_TCL \
- -I${TK_INCLUDEDIR} -DHAVE_TK \
- -I${LOCALBASE}/include"
+CPPFLAGS+= -I${TCL_INCLUDEDIR} -DHAVE_TCL \
+ -I${TK_INCLUDEDIR} -DHAVE_TK \
+ -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib \
+ -lX11 -ltcl${TCL_VER:S/.//} \
+ -ltk${TCL_VER:S/.//} -lm
post-install:
${STRIP_CMD} ${PREFIX}/bin/uuwish
diff --git a/converters/ytnef/Makefile b/converters/ytnef/Makefile
index 12e8005e0634..0632de62e3c5 100644
--- a/converters/ytnef/Makefile
+++ b/converters/ytnef/Makefile
@@ -22,7 +22,6 @@ GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
PLIST_FILES= bin/ytnef bin/ytnefprocess.pl bin/ytnefprint
PORTDOCS= AUTHORS NEWS README