aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2017-06-19 02:09:16 +0800
committerdbn <dbn@FreeBSD.org>2017-06-19 02:09:16 +0800
commit0ea2ef16cb1b39b82ff6b534b8389aa2953e4ea8 (patch)
tree237480885bd130394dbcbc56f765540bba4416e2 /converters
parent11eeef0a6a4a782ac0360e0d09460c3186dc0fde (diff)
downloadfreebsd-ports-gnome-0ea2ef16cb1b39b82ff6b534b8389aa2953e4ea8.tar.gz
freebsd-ports-gnome-0ea2ef16cb1b39b82ff6b534b8389aa2953e4ea8.tar.zst
freebsd-ports-gnome-0ea2ef16cb1b39b82ff6b534b8389aa2953e4ea8.zip
qa: add check for NO_ARCH
If NO_ARCH is set then check that no FreeBSD elf(5) files are in $STAGEDIR. If an elf(5) file is bundles as part of the package, but is not meant to be run directly (i.e. the elf(5) file is a payload, and not compiled) then those files can be added to NO_ARCH_IGNORE to avoid the check from failing, Changes to ports: - Ports that have NO_ARCH set, but actually compile files have had NO_ARCH removed. - Ports that have elf(5) payloads have had those files added to NO_ARCH_IGNORE. - R-cran ports that do not set USES=cran:compiles have NO_ARCH set, PR: 218976 Reviewed by: antoine, mat Approved by: portmgr
Diffstat (limited to 'converters')
-rw-r--r--converters/R-cran-RJSONIO/Makefile3
-rw-r--r--converters/R-cran-rjson/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/converters/R-cran-RJSONIO/Makefile b/converters/R-cran-RJSONIO/Makefile
index 0416fcc548b9..d735550ea96c 100644
--- a/converters/R-cran-RJSONIO/Makefile
+++ b/converters/R-cran-RJSONIO/Makefile
@@ -2,6 +2,7 @@
# $FreeBSD$
PORTNAME= RJSONIO
+PORTREVISION= 1
DISTVERSION= 1.3-0
CATEGORIES= converters
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -11,6 +12,6 @@ COMMENT= Serialize R objects to JSON, JavaScript Object Notation
LICENSE= BSD3CLAUSE
-USES= cran:auto-plist
+USES= cran:auto-plist,compiles
.include <bsd.port.mk>
diff --git a/converters/R-cran-rjson/Makefile b/converters/R-cran-rjson/Makefile
index eca59eda045b..06dd1bd861eb 100644
--- a/converters/R-cran-rjson/Makefile
+++ b/converters/R-cran-rjson/Makefile
@@ -3,6 +3,7 @@
PORTNAME= rjson
PORTVERSION= 0.2.15
+PORTREVISION= 1
CATEGORIES= converters
DISTNAME= ${PORTNAME}_${PORTVERSION}
@@ -11,6 +12,6 @@ COMMENT= JSON for R
LICENSE= GPLv2
-USES= cran:auto-plist
+USES= cran:auto-plist,compiles
.include <bsd.port.mk>