aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authorcs <cs@FreeBSD.org>2013-12-08 05:20:25 +0800
committercs <cs@FreeBSD.org>2013-12-08 05:20:25 +0800
commit2f2372805cfe1e3f223e5906fff6fae4ad26d048 (patch)
treec75bb6165e7937f3a23e2697baf51bb0c0da9b5f /converters
parent3713bb6c9903607253309944068cbb4d3ab9454c (diff)
downloadfreebsd-ports-gnome-2f2372805cfe1e3f223e5906fff6fae4ad26d048.tar.gz
freebsd-ports-gnome-2f2372805cfe1e3f223e5906fff6fae4ad26d048.tar.zst
freebsd-ports-gnome-2f2372805cfe1e3f223e5906fff6fae4ad26d048.zip
- Support staging
- USES=gmake
Diffstat (limited to 'converters')
-rw-r--r--converters/showkey/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/converters/showkey/Makefile b/converters/showkey/Makefile
index 1ab6f0461d0f..29414b5a4893 100644
--- a/converters/showkey/Makefile
+++ b/converters/showkey/Makefile
@@ -12,16 +12,14 @@ COMMENT= Prints its input, with escapes such as "<NUL>"
LICENSE= MIT
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS= CC="${CC} ${CFLAGS}"
ALL_TARGET= showkey
-MAN1= showkey.1
-PLIST_FILES= bin/showkey
+PLIST_FILES= bin/showkey man/man1/showkey.1.gz
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/showkey ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/showkey.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/showkey ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/showkey.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>