aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
committerale <ale@FreeBSD.org>2013-06-24 22:32:11 +0800
commit48d5fb51023dbbe8f2a70121c289e1849e7e14eb (patch)
treefd816d2c8b34ef7db2d6bcabe7358eaa7fb2d04f /converters
parent19160cd533a64299fc9d3710c4d21307ce72df91 (diff)
downloadfreebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.gz
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.tar.zst
freebsd-ports-gnome-48d5fb51023dbbe8f2a70121c289e1849e7e14eb.zip
Welcome PHP 5.5!
Future steps: - rename current php5 ports to php54 - make php55 the default one after an exp-run
Diffstat (limited to 'converters')
-rw-r--r--converters/Makefile3
-rw-r--r--converters/php55-iconv/Makefile10
-rw-r--r--converters/php55-mbstring/Makefile10
-rw-r--r--converters/php55-mbstring/files/patch-config.m451
-rw-r--r--converters/php55-recode/Makefile10
5 files changed, 84 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index d272eb310ba8..3d5b7fedd25f 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -134,6 +134,9 @@
SUBDIR += php53-iconv
SUBDIR += php53-mbstring
SUBDIR += php53-recode
+ SUBDIR += php55-iconv
+ SUBDIR += php55-mbstring
+ SUBDIR += php55-recode
SUBDIR += psiconv
SUBDIR += py-bsdconv
SUBDIR += py-iconv
diff --git a/converters/php55-iconv/Makefile b/converters/php55-iconv/Makefile
new file mode 100644
index 000000000000..1727279f21e3
--- /dev/null
+++ b/converters/php55-iconv/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -iconv
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php55-mbstring/Makefile b/converters/php55-mbstring/Makefile
new file mode 100644
index 000000000000..0cc3d45751b5
--- /dev/null
+++ b/converters/php55-mbstring/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -mbstring
+
+.include "${MASTERDIR}/Makefile"
diff --git a/converters/php55-mbstring/files/patch-config.m4 b/converters/php55-mbstring/files/patch-config.m4
new file mode 100644
index 000000000000..026798f26a5a
--- /dev/null
+++ b/converters/php55-mbstring/files/patch-config.m4
@@ -0,0 +1,51 @@
+--- config.m4.orig 2009-11-25 02:30:06.000000000 +0100
++++ config.m4 2010-04-12 09:59:54.000000000 +0200
+@@ -43,6 +43,30 @@
+ PHP_ADD_INCLUDE([$ext_builddir/$dir])
+ done
+
++ dnl This is PECL build, check if bundled PCRE library is used
++ old_CPPFLAGS=$CPPFLAGS
++ CPPFLAGS=$INCLUDES
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_BUNDLED_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=yes
++ ],[
++ AC_EGREP_CPP(yes,[
++#include <main/php_config.h>
++#if defined(HAVE_PCRE) && !defined(COMPILE_DL_PCRE)
++yes
++#endif
++ ],[
++ PHP_PCRE_REGEX=pecl
++ PHP_ADD_INCLUDE($PHP_PCRE_DIR/include)
++ ],[
++ PHP_PCRE_REGEX=no
++ ])
++ ])
++
+ if test "$ext_shared" = "no"; then
+ PHP_ADD_SOURCES(PHP_EXT_DIR(mbstring), $PHP_MBSTRING_BASE_SOURCES)
+ out="php_config.h"
+@@ -80,7 +104,6 @@
+ int foo(int x, ...) {
+ va_list va;
+ va_start(va, x);
+- va_arg(va, int);
+ va_arg(va, char *);
+ va_arg(va, double);
+ return 0;
+@@ -347,6 +370,9 @@
+ [ --with-onig[=DIR] MBSTRING: Use external oniguruma. DIR is the oniguruma install prefix.
+ If DIR is not set, the bundled oniguruma will be used], no, no)
+
++PHP_ARG_WITH(pcre-dir, pcre install prefix,
++[ --with-pcre-dir MBSTRING: pcre install prefix], no, no)
++
+ if test "$PHP_MBSTRING" != "no"; then
+ AC_DEFINE([HAVE_MBSTRING],1,[whether to have multibyte string support])
+
diff --git a/converters/php55-recode/Makefile b/converters/php55-recode/Makefile
new file mode 100644
index 000000000000..131bf9fd4bce
--- /dev/null
+++ b/converters/php55-recode/Makefile
@@ -0,0 +1,10 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+CATEGORIES= converters
+
+MASTERDIR= ${.CURDIR}/../../lang/php55
+
+PKGNAMESUFFIX= -recode
+
+.include "${MASTERDIR}/Makefile"