aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-09-17 15:35:57 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-09-17 15:35:57 +0800
commit3eda53eb7b677a048e78cbe00df2f6f2a0ef6b54 (patch)
tree8ad70e8bc8f351c0a92ba33b32d929d17822b57d /converters
parentd288e3c6689060fd96738d063ace78053b1a4b14 (diff)
downloadfreebsd-ports-gnome-3eda53eb7b677a048e78cbe00df2f6f2a0ef6b54.tar.gz
freebsd-ports-gnome-3eda53eb7b677a048e78cbe00df2f6f2a0ef6b54.tar.zst
freebsd-ports-gnome-3eda53eb7b677a048e78cbe00df2f6f2a0ef6b54.zip
- Rename bin/json_pp to bin/p5json_pp to avoid CONFLICTS with lang/perl5.14
- Bump PORTREVISION for PLIST change Reported by: kwm Obtained from: lth (devel/p5-Module-CoreList)
Diffstat (limited to 'converters')
-rw-r--r--converters/p5-JSON-PP/Makefile22
-rw-r--r--converters/p5-JSON-PP/files/pkg-install.in9
-rw-r--r--converters/p5-JSON-PP/pkg-plist3
3 files changed, 31 insertions, 3 deletions
diff --git a/converters/p5-JSON-PP/Makefile b/converters/p5-JSON-PP/Makefile
index 16ec0e5be650..5db514d519cc 100644
--- a/converters/p5-JSON-PP/Makefile
+++ b/converters/p5-JSON-PP/Makefile
@@ -7,6 +7,7 @@
PORTNAME= JSON-PP
PORTVERSION= 2.27200
+PORTREVISION= 1
CATEGORIES= converters perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:MAKAMAKA
@@ -17,8 +18,25 @@ COMMENT= A JSON::XS compatible pure-Perl module
PERL_CONFIGURE= yes
-MAN1= json_pp.1
+MAN1= p5json_pp.1
MAN3= JSON::PP.3 \
JSON::PP::Boolean.3
-.include <bsd.port.mk>
+SUB_FILES= pkg-install
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+PLIST_SUB= BIN_JSON_PP=""
+.else
+PLIST_SUB= BIN_JSON_PP="@comment "
+.endif
+
+pre-patch:
+ @${MV} ${WRKSRC}/bin/json_pp ${WRKSRC}/bin/p5json_pp
+ @${REINPLACE_CMD} -e 's|bin/json_pp|bin/p5json_pp|' ${WRKSRC}/MANIFEST ${WRKSRC}/Makefile.PL
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.post.mk>
diff --git a/converters/p5-JSON-PP/files/pkg-install.in b/converters/p5-JSON-PP/files/pkg-install.in
new file mode 100644
index 000000000000..75c3ab625642
--- /dev/null
+++ b/converters/p5-JSON-PP/files/pkg-install.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+case $2 in
+POST-INSTALL)
+ if ! test -f %%PREFIX%%/bin/json_pp; then
+ echo "===> Reinstalling missing %%PREFIX%%/bin/json_pp"
+ cp -p %%PREFIX%%/bin/p5json_pp %%PREFIX%%/bin/json_pp
+ fi
+esac
diff --git a/converters/p5-JSON-PP/pkg-plist b/converters/p5-JSON-PP/pkg-plist
index 7dbbc933174b..b72eff78a580 100644
--- a/converters/p5-JSON-PP/pkg-plist
+++ b/converters/p5-JSON-PP/pkg-plist
@@ -1,4 +1,5 @@
-bin/json_pp
+%%BIN_JSON_PP%%bin/json_pp
+bin/p5json_pp
%%SITE_PERL%%/JSON/PP.pm
%%SITE_PERL%%/JSON/PP/Boolean.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/JSON/PP/.packlist