aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2016-11-26 18:33:32 +0800
committersunpoet <sunpoet@FreeBSD.org>2016-11-26 18:33:32 +0800
commite5fd48efd250de38c33bd5b1408831771f6e92d7 (patch)
tree336c5d2d7432e5a808c41e669995dd728a052924 /converters
parentb882ed17a04b46f5cd309c5512f090ae6530b071 (diff)
downloadfreebsd-ports-gnome-e5fd48efd250de38c33bd5b1408831771f6e92d7.tar.gz
freebsd-ports-gnome-e5fd48efd250de38c33bd5b1408831771f6e92d7.tar.zst
freebsd-ports-gnome-e5fd48efd250de38c33bd5b1408831771f6e92d7.zip
- Fix installation of igbinary.h and php_igbinary.h
- Bump PORTREVISION for package change
Diffstat (limited to 'converters')
-rw-r--r--converters/pecl-igbinary/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/converters/pecl-igbinary/Makefile b/converters/pecl-igbinary/Makefile
index 9c84315a7c03..fbdfe0ddd5e1 100644
--- a/converters/pecl-igbinary/Makefile
+++ b/converters/pecl-igbinary/Makefile
@@ -3,6 +3,7 @@
PORTNAME= igbinary
PORTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= converters
MASTER_SITES= http://pecl.php.net/get/ \
LOCAL/sunpoet
@@ -17,4 +18,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
USES= php:ext tar:tgz
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+.if ${PHP_VER} >= 70
+ ${CP} ${WRKSRC}/src/php7/igbinary.h ${WRKSRC}/igbinary.h
+ ${CP} ${WRKSRC}/src/php7/php_igbinary.h ${WRKSRC}/php_igbinary.h
+.else
+ ${CP} ${WRKSRC}/src/php5/igbinary.h ${WRKSRC}/igbinary.h
+ ${CP} ${WRKSRC}/src/php5/php_igbinary.h ${WRKSRC}/php_igbinary.h
+.endif
+
+.include <bsd.port.post.mk>