aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2013-12-29 05:03:54 +0800
committerjohans <johans@FreeBSD.org>2013-12-29 05:03:54 +0800
commit1a7a79ee2106c5dd7f548b1f1c2e427112aca694 (patch)
treebd132f4ef4ff3640b588141aa870291f27e949c3 /converters
parent8e1a8502fc34330f2babf94325d47f678f804e78 (diff)
downloadfreebsd-ports-gnome-1a7a79ee2106c5dd7f548b1f1c2e427112aca694.tar.gz
freebsd-ports-gnome-1a7a79ee2106c5dd7f548b1f1c2e427112aca694.tar.zst
freebsd-ports-gnome-1a7a79ee2106c5dd7f548b1f1c2e427112aca694.zip
Enable stage support
Diffstat (limited to 'converters')
-rw-r--r--converters/mmencode/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/converters/mmencode/Makefile b/converters/mmencode/Makefile
index ef8945e11494..48e45e649f56 100644
--- a/converters/mmencode/Makefile
+++ b/converters/mmencode/Makefile
@@ -14,17 +14,17 @@ COMMENT= Translate to and from mail-oriented encoding formats
WRKSRC= ${WRKDIR}/${DISTNAME}/src/metamail
-PLIST_FILES= bin/mmencode bin/mimencode
-MAN1= mmencode.1
-MLINKS= mmencode.1 mimencode.1
+PLIST_FILES= bin/mmencode bin/mimencode \
+ man/man1/mmencode.1.gz man/man1/mimencode.1.gz
ALL_TARGET= mmencode
MAKE_ARGS= CFLAGS="${CFLAGS}"
-NO_STAGE= yes
do-install:
- @cd ${WRKSRC} && ${INSTALL_PROGRAM} mmencode ${PREFIX}/bin
- @cd ${WRKSRC}/../man && ${INSTALL_MAN} mmencode.1 ${PREFIX}/man/man1
- @cd ${PREFIX}/bin && ${LN} -s mmencode mimencode
+ @${INSTALL_PROGRAM} ${WRKSRC}/mmencode ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/../man/mmencode.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1/
+ @cd ${STAGEDIR}${MAN1PREFIX}/man/man1 && ${LN} -s mmencode.1 mimencode.1
+ @cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s mmencode mimencode
.include <bsd.port.mk>