aboutsummaryrefslogtreecommitdiffstats
path: root/converters
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
committermarcus <marcus@FreeBSD.org>2004-07-10 01:43:11 +0800
commit5cc9328814fb9b8e64ff3588af7e6031c1d3514b (patch)
treedf0b6bb8e4e84920da9881d421090dc67f70c629 /converters
parente058c31decaf84a24b7ab7306f65221b33ada080 (diff)
downloadfreebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.gz
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.tar.zst
freebsd-ports-gnome-5cc9328814fb9b8e64ff3588af7e6031c1d3514b.zip
Apply a big libtool patch to allow porters to use the libtool installed by
the libtoolX ports instead of the one included with each port. Ports that set USE_LIBTOOL_VER=X will now use the ports version of libtool instead of the included version. To restore previous behavior, use the new macro, USE_INC_LIBTOOL_VER. Both macros accept the same argument: a libtool version. For example, to use the ports version of libtool-1.5, add the following to your Makefile: USE_LIBTOOL_VER= 15 To use the included version of libtool with extra hacks provided by libtool-1.5, add the following to your Makefile: USE_INC_LIBTOOL_VER= 15 With this change, ports that had to add additional libtool hacks to prevent .la files from being installed or to fix certain threading issues can now delete those hacks (after appropriate testing, of course). PR: 63944 Based on work by:eik and marcus Approved by: ade (autotools maintainer) Tested by: kris on pointyhat Bound to be hidden problems: You bet
Diffstat (limited to 'converters')
-rw-r--r--converters/enca/Makefile2
-rw-r--r--converters/fribidi/Makefile2
-rw-r--r--converters/libiconv/Makefile2
-rw-r--r--converters/mimelib/Makefile2
-rw-r--r--converters/recode/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/converters/enca/Makefile b/converters/enca/Makefile
index f233e322b80b..db730f987e17 100644
--- a/converters/enca/Makefile
+++ b/converters/enca/Makefile
@@ -17,7 +17,7 @@ USE_GNOME= pkgconfig
USE_ICONV= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
diff --git a/converters/fribidi/Makefile b/converters/fribidi/Makefile
index 28d1506c2107..73a0e57e3bdd 100644
--- a/converters/fribidi/Makefile
+++ b/converters/fribidi/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gnome@FreeBSD.org
COMMENT= A Free Implementation of the Unicode Bidirectional Algorithm
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
USE_GNOME= gnomehack pkgconfig
INSTALLS_SHLIB= yes
diff --git a/converters/libiconv/Makefile b/converters/libiconv/Makefile
index dd34b0097d2e..25e1e5607c4b 100644
--- a/converters/libiconv/Makefile
+++ b/converters/libiconv/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= A character set conversion library
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
USE_GNOME= gnometarget
LIBTOOLFILES= configure libcharset/configure
CONFIGURE_ARGS= --enable-static \
diff --git a/converters/mimelib/Makefile b/converters/mimelib/Makefile
index cfb65aee2959..d582bbb0b054 100644
--- a/converters/mimelib/Makefile
+++ b/converters/mimelib/Makefile
@@ -16,7 +16,7 @@ COMMENT= C++ class library for manipulating messages in MIME format
CONFLICTS= kdenetwork-3.1.*
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/converters/recode/Makefile b/converters/recode/Makefile
index a09397ab7447..433b0a43a835 100644
--- a/converters/recode/Makefile
+++ b/converters/recode/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= demon@FreeBSD.org
COMMENT= Converts files between character sets and usages
USE_GETTEXT= yes
-USE_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 13
USE_PERL5= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --without-included-gettext