aboutsummaryrefslogtreecommitdiffstats
path: root/databases/Makefile
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-12-07 09:47:56 +0800
committerwen <wen@FreeBSD.org>2010-12-07 09:47:56 +0800
commit5e354949a8bbf892dbe3dae7984508874f2bf469 (patch)
tree4cb4b367a1ba0893bbbdd7f510922cb265a1c4d8 /databases/Makefile
parent73373caa0bcb4e8c81c2313d9ab3fa2f6f1f6b32 (diff)
downloadfreebsd-ports-gnome-5e354949a8bbf892dbe3dae7984508874f2bf469.tar.gz
freebsd-ports-gnome-5e354949a8bbf892dbe3dae7984508874f2bf469.tar.zst
freebsd-ports-gnome-5e354949a8bbf892dbe3dae7984508874f2bf469.zip
DBIx::NoSQL is a layer over DBI that presents a NoSQLish way to store and
retrieve data. It does this by using a table called __Store__. Once connected to a database, it will detect if this table is missing and create it if necessary. When writing data to the store, the data (a HASH reference) is first serialized using JSON and then inserted/updated via DBIx::Class to (currently) an SQLite backend. Retrieving data from the store is done by key lookup or by searching an SQL-based index. Once found, the data is deserialized via JSON and returned. WWW: http://search.cpan.org/dist/DBIx-NoSQL/
Diffstat (limited to 'databases/Makefile')
-rw-r--r--databases/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 9d8727a361a4..ccadbab3c62f 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -364,6 +364,7 @@
SUBDIR += p5-DBIx-HA
SUBDIR += p5-DBIx-Log4perl
SUBDIR += p5-DBIx-MySQLSequence
+ SUBDIR += p5-DBIx-NoSQL
SUBDIR += p5-DBIx-Password
SUBDIR += p5-DBIx-Perlish
SUBDIR += p5-DBIx-Recordset