aboutsummaryrefslogtreecommitdiffstats
path: root/databases/adabase/Makefile
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-05-09 19:05:00 +0800
committermarino <marino@FreeBSD.org>2016-05-09 19:05:00 +0800
commitc39a195818ea0135a101f3662fd60904f5816516 (patch)
tree582e541b0e50a87e97cb591c90ac17e504722022 /databases/adabase/Makefile
parentdcabae236c1532f3c68f264dfaca127f27ee6c4e (diff)
downloadfreebsd-ports-gnome-c39a195818ea0135a101f3662fd60904f5816516.tar.gz
freebsd-ports-gnome-c39a195818ea0135a101f3662fd60904f5816516.tar.zst
freebsd-ports-gnome-c39a195818ea0135a101f3662fd60904f5816516.zip
Add new port database/adabase
Thick database bindings for MySQL, PostgreSQL and SQLite written in Ada. This is the first release of AdaBase, an abstraction library that provides a consistent interface to multiple database servers. Currently only one driver for MySQL is provided, but additional ones for SQLite and PostgreSQL are planned for the near term. It's extensible, so support for others such as Firebird, Oracle and MSSQL would be easily possible. AdaBase offers unique features over similar frameworks. For starters, it's limited to database support rather than including many other unwanted components in a "kitchen sink" fashion, and unneeded drivers can be excluded from the library as desired. It's got a developer and commerce friend license (ICS), it comes with good documentation and working examples, and the bindings are thick enough where database server backends can be interchangeable. AdaBase may seem familiar to some users as it was partially inspired by PHP's PDO database framework and is a sequel of sorts to an earlier project by the same author, Pascal Data Objects. WWW: http://jrmarino.github.io/AdaBase/
Diffstat (limited to 'databases/adabase/Makefile')
-rw-r--r--databases/adabase/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/databases/adabase/Makefile b/databases/adabase/Makefile
new file mode 100644
index 000000000000..464b46a62aaa
--- /dev/null
+++ b/databases/adabase/Makefile
@@ -0,0 +1,40 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= adabase
+PORTVERSION= 1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= databases
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= Thick database bindings for Ada
+
+LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/License.txt
+
+BUILD_DEPENDS= gprbuild:devel/gprbuild
+
+USES= ada
+USE_GITHUB= yes
+GH_ACCOUNT= jrmarino
+GH_PROJECT= AdaBase
+
+MAKE_ENV+= OS_VERSION=unix
+
+post-extract:
+ ${RM} ${WRKSRC}/src/drivers/adabase-driver-base-firebird.ad?
+
+do-build:
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ gprbuild -p -P adabase ${BUILD_ARGS})
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/adabase \
+ ${STAGEDIR}${PREFIX}/lib/adabase \
+ ${STAGEDIR}${PREFIX}/lib/gnat
+ ${INSTALL_DATA} ${WRKSRC}/lib/* ${STAGEDIR}${PREFIX}/lib/adabase
+ ${INSTALL_DATA} ${WRKSRC}/src/*/*.ad[bs] ${WRKSRC}/src/adabase.ads \
+ ${STAGEDIR}${PREFIX}/include/adabase
+ ${INSTALL_DATA} ${FILESDIR}/adabase.gpr ${STAGEDIR}${PREFIX}/lib/gnat
+
+.include <bsd.port.mk>