aboutsummaryrefslogtreecommitdiffstats
path: root/databases/clip/Makefile
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-11-04 23:34:45 +0800
committerijliao <ijliao@FreeBSD.org>2003-11-04 23:34:45 +0800
commit040dd6322eef6e89ef99a4b6771c5f3bbf556848 (patch)
tree3606e2f80ae8069c9a0e96c1e69c19e134ba3483 /databases/clip/Makefile
parent8a129bd0553f107b9260efe20bf63ae47f4b5924 (diff)
downloadfreebsd-ports-gnome-040dd6322eef6e89ef99a4b6771c5f3bbf556848.tar.gz
freebsd-ports-gnome-040dd6322eef6e89ef99a4b6771c5f3bbf556848.tar.zst
freebsd-ports-gnome-040dd6322eef6e89ef99a4b6771c5f3bbf556848.zip
unbreak by upgrading to 1.1.5.1
Diffstat (limited to 'databases/clip/Makefile')
-rw-r--r--databases/clip/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/databases/clip/Makefile b/databases/clip/Makefile
index 16bffeb7d4e5..599518122c86 100644
--- a/databases/clip/Makefile
+++ b/databases/clip/Makefile
@@ -6,19 +6,17 @@
#
PORTNAME= clip
-PORTVERSION= 1.1.0
+PORTVERSION= 1.1.5.1
CATEGORIES= databases lang
MASTER_SITES= ftp://ftp.linux.ru.net/mirrors/clip/ \
ftp://ftp.lastik.ru/clip/ \
ftp://ftp.itk.ru/pub/clip/
-DISTNAME= ${PORTNAME}-prg-${PORTVERSION:S/.5/-5/}
+DISTNAME= ${PORTNAME}-prg-${PORTVERSION:R}-${PORTVERSION:E}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= xBase and Clipper language compatible compiler
-BROKEN= "Does not install, will be removed after Feb 2"
-
.include <bsd.port.pre.mk>
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
@@ -26,13 +24,13 @@ BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2 \
- gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
gtkextra.17:${PORTSDIR}/x11-toolkits/gtkextra \
gd.4:${PORTSDIR}/graphics/gd \
intl.5:${PORTSDIR}/devel/gettext \
iconv.3:${PORTSDIR}/converters/libiconv
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
wget:${PORTSDIR}/ftp/wget
+
.if !defined(WITHOUT_IODBC)
LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
PLIST_SUB= ODBC=""
@@ -42,18 +40,21 @@ PLIST_SUB= ODBC=""
.else
PLIST_SUB= ODBC="@comment "
.endif
+
.if !defined(WITHOUT_MYSQL) || exists(${LOCALBASE}/include/mysql/mysql.h)
USE_MYSQL= yes
PLIST_SUB+= MYSQL=""
.else
PLIST_SUB+= MYSQL="@comment "
.endif
+
.if defined(WITH_PGSQL) || exists(${LOCALBASE}/include/libpq-fe.h)
LIB_DEPENDS+= pq.3:${PORTSDIR}/${PGSQL_PORT}
PLIST_SUB+= PGSQL=""
.else
PLIST_SUB+= PGSQL="@comment "
.endif
+
.if defined(WITH_FIREBIRD) || exists(${LOCALBASE}/firebird/include/ibase.h)
LIB_DEPENDS+= gds.1:${PORTSDIR}/${FIREBIRD_PORT}
PLIST_SUB+= IBASE=""
@@ -67,6 +68,7 @@ USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
USE_XLIB= yes
USE_XPM= yes
+USE_GNOME= gtk12
HAS_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/clip
ALL_TARGET= local