aboutsummaryrefslogtreecommitdiffstats
path: root/databases/clip/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2003-09-23 16:06:25 +0800
committerkrion <krion@FreeBSD.org>2003-09-23 16:06:25 +0800
commit8230c026152a4f8cfa39c1179e6b307b0c70e712 (patch)
tree746b1ee46365cdddabbf225632f358c6dca7cbd8 /databases/clip/Makefile
parent14074d5b536eb060eb1e81562f5e05680cc973b7 (diff)
downloadfreebsd-ports-gnome-8230c026152a4f8cfa39c1179e6b307b0c70e712.tar.gz
freebsd-ports-gnome-8230c026152a4f8cfa39c1179e6b307b0c70e712.tar.zst
freebsd-ports-gnome-8230c026152a4f8cfa39c1179e6b307b0c70e712.zip
- Unbreak and upgrade to 1.1.0 (fix bento error)
http://bento.freebsd.org/errorlogs/i386-4-full/clip-0.99_1.log PR: 57068 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'databases/clip/Makefile')
-rw-r--r--databases/clip/Makefile122
1 files changed, 91 insertions, 31 deletions
diff --git a/databases/clip/Makefile b/databases/clip/Makefile
index 5dec8e57d0fb..27967b4e8aa4 100644
--- a/databases/clip/Makefile
+++ b/databases/clip/Makefile
@@ -1,4 +1,3 @@
-# ex:ts=8
# New ports collection makefile for: clip
# Date created: Dec 23, 2001
# Whom: ijliao
@@ -7,41 +6,102 @@
#
PORTNAME= clip
-PORTVERSION= 0.99
-PORTREVISION= 1
-CATEGORIES= databases
-MASTER_SITES= ftp://ftp.lastik.ru/clip/ \
- ftp://ftp.linux.ru.net/mirrors/clip/
-DISTNAME= ${PORTNAME}-prg-${PORTVERSION}-3
+PORTVERSION= 1.1.0
+CATEGORIES= databases lang
+MASTER_SITES= ftp://ftp.linux.ru.net/mirrors/clip/ \
+ ftp://ftp.lastik.ru/clip/ \
+ ftp://ftp.itk.ru/pub/clip/
+DISTNAME= ${PORTNAME}-prg-${PORTVERSION:S/.5/-5/}
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= xBase and Clipper language compatible compiler
-BROKEN= Does not fetch
-
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- freetype.9:${PORTSDIR}/print/freetype2 \
- gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
- gtkextra.17:${PORTSDIR}/x11-toolkits/gtkextra \
- gd.2:${PORTSDIR}/graphics/gd \
- intl.5:${PORTSDIR}/devel/gettext
-
-USE_BISON= yes
-USE_GMAKE= yes
-USE_REINPLACE= yes
-USE_XLIB= yes
-USE_XPM= yes
-ALL_TARGET= local
-MAKE_ENV= HOME=${WRKDIR}
-
-post-patch:
- @${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
- -e "s|%%X11BASE%%|${X11BASE}|g" \
- ${WRKSRC}/cliplibs/clip-gd/gd/configure
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ wget:${PORTSDIR}/ftp/wget
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ gtkextra.17:${PORTSDIR}/x11-toolkits/gtkextra \
+ gd.4:${PORTSDIR}/graphics/gd \
+ intl.5:${PORTSDIR}/devel/gettext \
+ iconv.3:${PORTSDIR}/converters/libiconv
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ wget:${PORTSDIR}/ftp/wget
+.if !defined(WITHOUT_IODBC)
+LIB_DEPENDS+= iodbc.3:${PORTSDIR}/databases/libiodbc
+PLIST_SUB= ODBC=""
+.elseif !defined(WITHOUT_UNIXODBC)
+LIB_DEPENDS+= odbc.1:${PORTSDIR}/databases/unixODBC
+PLIST_SUB= ODBC=""
+.else
+PLIST_SUB= ODBC="@comment "
+.endif
+.if !defined(WITHOUT_MYSQL) || exists(${LOCALBASE}/include/mysql/mysql.h)
+USE_MYSQL= yes
+PLIST_SUB+= MYSQL=""
+.else
+PLIST_SUB+= MYSQL="@comment "
+.endif
+.if defined(WITH_PGSQL) || exists(${LOCALBASE}/include/libpq-fe.h)
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${PGSQL_PORT}
+PLIST_SUB+= PGSQL=""
+.else
+PLIST_SUB+= PGSQL="@comment "
+.endif
+.if defined(WITH_FIREBIRD) || exists(${LOCALBASE}/firebird/include/ibase.h)
+LIB_DEPENDS+= gds.1:${PORTSDIR}/${FIREBIRD_PORT}
+PLIST_SUB+= IBASE=""
+.else
+PLIST_SUB+= IBASE="@comment "
+.endif
+
+USE_BISON= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
+USE_XLIB= yes
+USE_XPM= yes
+HAS_CONFIGURE= yes
+CONFIGURE_WRKSRC= ${WRKSRC}/clip
+ALL_TARGET= local
+MAKE_ENV= HOME=${WRKDIR} LANG=C
+
+PGSQL_PORT?= databases/postgresql7
+FIREBIRD_PORT?= databases/firebird
+
+BIN2STRIP= bdbf clip clip_bl clip_blank clip_cld clip_conv clip_dbf2txt \
+ clip_dbg clip_fl clip_hashextract clip_hindex clip_hseek \
+ clip_hv clip_prg clip_run clip_trans clip_we clipar cliphash \
+ codb_ab codb_abx codb_addobj codb_make codb_pack ctosgml dbc \
+ ftosgml gen_tbl po_compat po_extr po_subst pp_ron sqlrun \
+ wcl2prg www_clip xclip
+
+pre-configure:
+ @${FIND} ${WRKSRC} -name "Makefile*" -or -name Imakefile | \
+ ${XARGS} ${REINPLACE_CMD} \
+ -e "s|-Wall -g|${CFLAGS}|;s|-g -Wall|${CFLAGS}|;s|-Wall|${CFLAGS}|" \
+ -e "s|gcc|${CC}|;s|-O2||;s|-O ||;"
+ @${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|-Wall -g|${CFLAGS}|;s|-g -Wall|${CFLAGS}|;s|-Wall|${CFLAGS}|" \
+ -e "s|-O2||"
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} \
+ -e "s|#include.*<malloc.h>|#include <stdlib.h>|" \
+ -e "s|#!/bin/sh|#!${LOCALBASE}/bin/bash|" \
+ -e "s|/usr/local|${LOCALBASE}|g" \
+ -e "s|/usr/X11R6|${X11BASE}|g"
do-install:
- ${CP} -R ${WRKDIR}/cliproot ${LOCALBASE}/clip
+ ${CP} -R ${WRKDIR}/cliproot ${PREFIX}/clip
+.for FILE in ${BIN2STRIP}
+ @${STRIP_CMD} ${PREFIX}/clip/bin/${FILE}
+.endfor
+ @for f in `ls ${PREFIX}/clip/lib/*.so` ; \
+ do \
+ ${STRIP_CMD} $$f ; \
+ done
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>