aboutsummaryrefslogtreecommitdiffstats
path: root/databases/clip
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-04-25 03:34:55 +0800
committerthierry <thierry@FreeBSD.org>2004-04-25 03:34:55 +0800
commita06591655002e90ab0b28a7576de110215005261 (patch)
tree71900f67497788d62075ad56750c32067b6ce585 /databases/clip
parent7ec07cae4b0f2a06a7cecd9488a6903d1a7855e8 (diff)
downloadfreebsd-ports-gnome-a06591655002e90ab0b28a7576de110215005261.tar.gz
freebsd-ports-gnome-a06591655002e90ab0b28a7576de110215005261.tar.zst
freebsd-ports-gnome-a06591655002e90ab0b28a7576de110215005261.zip
Unbreak package building.
On FreeBSD-STABLE, it seems impossible to link with -liodbc.3 without giving PTHREAD_LIBS (and PTHREAD_CFLAGS), then the ODBC driver was not built. Approved by: portmgr (marcus).
Diffstat (limited to 'databases/clip')
-rw-r--r--databases/clip/Makefile3
-rw-r--r--databases/clip/files/patch-cliplibs::clip-odbc::configure10
2 files changed, 8 insertions, 5 deletions
diff --git a/databases/clip/Makefile b/databases/clip/Makefile
index d70bcea90a95..4280b0568ab9 100644
--- a/databases/clip/Makefile
+++ b/databases/clip/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clip
PORTVERSION= 1.1.9.1
+PORTREVISION= 1
CATEGORIES= databases lang
MASTER_SITES= ftp://ftp.linux.ru.net/mirrors/clip/ \
ftp://ftp.lastik.ru/clip/ \
@@ -104,6 +105,8 @@ pre-configure:
-e "s|#!/bin/sh|#!${LOCALBASE}/bin/bash|" \
-e "s|/usr/local|${LOCALBASE}|g" \
-e "s|/usr/X11R6|${X11BASE}|g"
+ @${REINPLACE_CMD} -e "s|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|" \
+ -e "s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|" ${WRKSRC}/cliplibs/clip-odbc/configure
do-install:
${CP} -R ${WRKDIR}/cliproot ${PREFIX}/clip
diff --git a/databases/clip/files/patch-cliplibs::clip-odbc::configure b/databases/clip/files/patch-cliplibs::clip-odbc::configure
index f43975530101..bf61aaca3838 100644
--- a/databases/clip/files/patch-cliplibs::clip-odbc::configure
+++ b/databases/clip/files/patch-cliplibs::clip-odbc::configure
@@ -1,11 +1,11 @@
---- cliplibs/clip-odbc/configure.orig Mon May 27 12:25:29 2002
-+++ cliplibs/clip-odbc/configure Sat Sep 20 23:46:44 2003
-@@ -21,11 +21,11 @@
+--- cliplibs/clip-odbc/configure.orig Fri Dec 26 11:34:59 2003
++++ cliplibs/clip-odbc/configure Sat Apr 24 15:52:06 2004
+@@ -22,11 +22,11 @@
LIBODBC=''
LIBOOB=''
-gcc -o test_odbc test_odbc.c -liodbc >/dev/null 2>&1 && LIBODBC='-liodbc' && echo 'iODBC driver manager were found'
-+gcc -o test_odbc test_odbc.c -I/usr/local/include -L/usr/local/lib -liodbc >/dev/null 2>&1 && LIBODBC='-liodbc' && echo 'iODBC driver manager were found'
++gcc -o test_odbc test_odbc.c %%PTHREAD_CFLAGS%% -I/usr/local/include -L/usr/local/lib %%PTHREAD_LIBS%% -liodbc >/dev/null 2>&1 && LIBODBC='-liodbc' && echo 'iODBC driver manager were found'
if [ -z "$LIBODBC" ]
then
@@ -14,7 +14,7 @@
fi
if [ -z "$LIBODBC" ]
-@@ -36,6 +36,6 @@
+@@ -37,6 +37,6 @@
gcc -o test_odbc test_odbc.c -L/usr/local/easysoft/oob/client -lesoobclient >/dev/null 2>&1 && LIBOOB='-L\/usr\/local\/easysoft\/oob\/client -lesoobclient' && echo 'ODBC-ODBC bridge client were found'