aboutsummaryrefslogtreecommitdiffstats
path: root/databases/cyrus-imspd/Makefile
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2002-03-30 18:23:57 +0800
committerdinoex <dinoex@FreeBSD.org>2002-03-30 18:23:57 +0800
commitb9811509fa4d4df99c3fbc8604d174a019aff27e (patch)
tree8af067b41a321853dd84d21e58bb2b6dbee2b50a /databases/cyrus-imspd/Makefile
parentb0751a3b694884feeace45233d70297d5a497742 (diff)
downloadfreebsd-ports-gnome-b9811509fa4d4df99c3fbc8604d174a019aff27e.tar.gz
freebsd-ports-gnome-b9811509fa4d4df99c3fbc8604d174a019aff27e.tar.zst
freebsd-ports-gnome-b9811509fa4d4df99c3fbc8604d174a019aff27e.zip
The Internet Message Support Protocol (IMSP) is designed to support the
provision of mail in a medium to large scale operation. It is intended to be used as a companion to the IMAP4 protocol [IMAP4], providing services which are either outside the scope of mail access or which pertain to environments which must run more than one IMAP4 server in the same mail domain. The services that IMSP provides are extended mailbox management, configuration options, and address books. http://asg.web.cmu.edu/cyrus/ PR: 31026 Submitted by: damien@tougas.net
Diffstat (limited to 'databases/cyrus-imspd/Makefile')
-rw-r--r--databases/cyrus-imspd/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/databases/cyrus-imspd/Makefile b/databases/cyrus-imspd/Makefile
new file mode 100644
index 000000000000..60d44333900b
--- /dev/null
+++ b/databases/cyrus-imspd/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: cyrus-imspd
+# Date created: Jan 4th 2001
+# Whom: damien@tougas.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= cyrus-imspd
+PORTVERSION= v1.6a3
+CATEGORIES= databases mail
+MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/ \
+ ftp://ftp.hanse.de/sites/transit/mirror/ftp.andrew.cmu.edu/pub/cyrus-mail/
+
+MAINTAINER= ports@freebsd.org
+
+LIB_DEPENDS= sasl.8:${PORTSDIR}/security/cyrus-sasl
+BUILD_DEPENDS= ${LOCALBASE}/sbin/pwcheck:${PORTSDIR}/security/cyrus-sasl
+
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS= --prefix=${PREFIX} \
+ --with-sasldir=${LOCALBASE} \
+ --with-auth=unix
+
+post-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/imspd.sh \
+ ${PREFIX}/etc/rc.d/imspd.sh
+ ${INSTALL_DATA} ${FILESDIR}/imspd.conf \
+ ${PREFIX}/lib/sasl/imspd.conf
+ ${MKDIR} /var/imsp
+ ${INSTALL_DATA} ${WRKSRC}/imsp/options.sample \
+ /var/imsp/options.dist
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/imspd
+ ${INSTALL_DATA} ${WRKSRC}/notes/Setup-instructions \
+ ${PREFIX}/share/doc/imspd
+ ${INSTALL_DATA} ${WRKSRC}/notes/option.registry \
+ ${PREFIX}/share/doc/imspd
+ ${INSTALL_DATA} ${WRKSRC}/notes/Changes-Todo \
+ ${PREFIX}/share/doc/imspd
+ ${INSTALL_DATA} ${WRKSRC}/notes/imsp.implementation \
+ ${PREFIX}/share/doc/imspd
+ ${INSTALL_DATA} ${WRKSRC}/notes/imsp.implementation.updates \
+ ${PREFIX}/share/doc/imspd
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>