aboutsummaryrefslogtreecommitdiffstats
path: root/databases/db48
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2014-07-03 04:59:24 +0800
committermandree <mandree@FreeBSD.org>2014-07-03 04:59:24 +0800
commit540c47636977532f4c1f40e6cf678ec34dc6e302 (patch)
tree00261bdf5aab940a2e46d131571b05082b25dad9 /databases/db48
parent2bb418a63291bbe73fc05ca54c1d6249b299eb4f (diff)
downloadfreebsd-ports-gnome-540c47636977532f4c1f40e6cf678ec34dc6e302.tar.gz
freebsd-ports-gnome-540c47636977532f4c1f40e6cf678ec34dc6e302.tar.zst
freebsd-ports-gnome-540c47636977532f4c1f40e6cf678ec34dc6e302.zip
Fix mutex code on powerpc64.
PR: 191453 Submitted by: jhibbits@
Diffstat (limited to 'databases/db48')
-rw-r--r--databases/db48/Makefile2
-rw-r--r--databases/db48/files/patch-dbinc_mutex_int.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/databases/db48/Makefile b/databases/db48/Makefile
index b1f04502b9c9..9603985f2492 100644
--- a/databases/db48/Makefile
+++ b/databases/db48/Makefile
@@ -3,7 +3,7 @@
PORTNAME= db48
PORTVERSION= 4.8.30.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://download.oracle.com/berkeley-db/
PKGNAMEPREFIX?=
diff --git a/databases/db48/files/patch-dbinc_mutex_int.h b/databases/db48/files/patch-dbinc_mutex_int.h
new file mode 100644
index 000000000000..9e6b5a2819fd
--- /dev/null
+++ b/databases/db48/files/patch-dbinc_mutex_int.h
@@ -0,0 +1,11 @@
+--- ../dbinc/mutex_int.h.orig 2010-04-12 13:25:22.000000000 -0700
++++ ../dbinc/mutex_int.h 2014-06-28 01:16:48.321255725 -0700
+@@ -596,7 +596,7 @@
+ : "=&r" (__r), "+r" (tsl)
+ :
+ : "cr0", "memory");
+- return (int)tsl;
++ return (tsl != 0);
+ }
+
+ static inline int