aboutsummaryrefslogtreecommitdiffstats
path: root/databases/db48
diff options
context:
space:
mode:
authorsbruno <sbruno@FreeBSD.org>2015-05-08 01:35:33 +0800
committersbruno <sbruno@FreeBSD.org>2015-05-08 01:35:33 +0800
commitba80e0eaa5ecd919c8745f6bbc321234d6e44812 (patch)
treeb0db791152b13eb98cea2ce3157696d136d24a19 /databases/db48
parentfb7d06f301b7da7487a7b830cb4def72ee509b86 (diff)
downloadfreebsd-ports-gnome-ba80e0eaa5ecd919c8745f6bbc321234d6e44812.tar.gz
freebsd-ports-gnome-ba80e0eaa5ecd919c8745f6bbc321234d6e44812.tar.zst
freebsd-ports-gnome-ba80e0eaa5ecd919c8745f6bbc321234d6e44812.zip
enable posix-mutexes by default for armv6 targets as db will crash and burn
when using the internal mutex implementation via unsupported instructions. PR: 197227 Submitted by: andrew@ Approved by: mandree@
Diffstat (limited to 'databases/db48')
-rw-r--r--databases/db48/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/databases/db48/Makefile b/databases/db48/Makefile
index 7be2b1d846fa..b33b26a878ee 100644
--- a/databases/db48/Makefile
+++ b/databases/db48/Makefile
@@ -33,6 +33,13 @@ INSTALL_TARGET= install_include install_lib install_utilities
WRKSRC= ${WRKDIR}/${DISTNAME}/build_unix
USE_LDCONFIG= yes
+.include <bsd.port.options.mk>
+
+.if ${ARCH} == "armv6"
+# db48 uses a deprecated instruction for mutexes on ARM, fbsd bug#197227
+CONFIGURE_ARGS+= --enable-posixmutexes
+.endif
+
post-patch:
${REINPLACE_CMD} -Ee 's|--mode=install cp -p|--mode=install ${INSTALL} -s|;' ${WRKSRC}/${CONFIGURE_SCRIPT}