aboutsummaryrefslogtreecommitdiffstats
path: root/databases/flamerobin
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-04-16 19:08:11 +0800
committerantoine <antoine@FreeBSD.org>2015-04-16 19:08:11 +0800
commitf58b050f64235cd0afc32070587e5789abdaf7e5 (patch)
tree5bcf6bf96b05fba5558b4dcfd1e668ada7b43648 /databases/flamerobin
parent28d05e35cce037addbaf54fde0ce8246e5cac3a1 (diff)
downloadfreebsd-ports-gnome-f58b050f64235cd0afc32070587e5789abdaf7e5.tar.gz
freebsd-ports-gnome-f58b050f64235cd0afc32070587e5789abdaf7e5.tar.zst
freebsd-ports-gnome-f58b050f64235cd0afc32070587e5789abdaf7e5.zip
Fix build with GCC on recent head kernel by disabling PCH for GCC
With hat: portmgr
Diffstat (limited to 'databases/flamerobin')
-rw-r--r--databases/flamerobin/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/databases/flamerobin/Makefile b/databases/flamerobin/Makefile
index d031a94c77ec..2ae3677794ab 100644
--- a/databases/flamerobin/Makefile
+++ b/databases/flamerobin/Makefile
@@ -16,6 +16,7 @@ LICENSE_NAME= FlameRobin Expat
LICENSE_FILE= ${WRKSRC}/docs/fr_license.html
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+USES= compiler
USE_FIREBIRD= yes
USE_WX= 2.8+
WX_COMPS= wx contrib
@@ -28,4 +29,11 @@ LDFLAGS+= -L${LOCALBASE}/lib
SUB_FILES= pkg-message
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# GCC is broken with PCH: https://lists.freebsd.org/pipermail/svn-src-all/2015-March/101722.html
+.if ${COMPILER_TYPE} == gcc
+CONFIGURE_ARGS= --disable-precomp-headers
+.endif
+
+.include <bsd.port.post.mk>