aboutsummaryrefslogtreecommitdiffstats
path: root/databases/galera
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2017-05-25 21:38:07 +0800
committervd <vd@FreeBSD.org>2017-05-25 21:38:07 +0800
commit76399e0f6f3795af1a831394d46cdca2bbf2f643 (patch)
tree1eb0e8d23dbb017d158e162e71b850444b356b5b /databases/galera
parente380c16398af17d3ae3d306c568b992731964783 (diff)
downloadfreebsd-ports-gnome-76399e0f6f3795af1a831394d46cdca2bbf2f643.tar.gz
freebsd-ports-gnome-76399e0f6f3795af1a831394d46cdca2bbf2f643.tar.zst
freebsd-ports-gnome-76399e0f6f3795af1a831394d46cdca2bbf2f643.zip
Disable databases/galera on i386
It uses 64 bit atomics, e.g. __atomic_add_fetch() with 64 bit arguments and clang fails to generate those on i386.
Diffstat (limited to 'databases/galera')
-rw-r--r--databases/galera/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/databases/galera/Makefile b/databases/galera/Makefile
index ec3a407da589..c6192b6f9450 100644
--- a/databases/galera/Makefile
+++ b/databases/galera/Makefile
@@ -15,6 +15,17 @@ BUILD_DEPENDS= checkmk:devel/check \
${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs
+NOT_FOR_ARCHS= i386
+# On i386 older versions of clang produce:
+# cannot compile this atomic library call yet ... __atomic_add_fetch
+# whereas newer ones generate a call to __atomic_add_fetch which ends up with
+# undefined reference at link time:
+# undefined reference to `__atomic_fetch_add_8'
+# https://bugs.llvm.org//show_bug.cgi?id=23262
+# https://bugs.llvm.org//show_bug.cgi?id=24908
+# https://tracker.crystax.net/issues/1263
+NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386
+
USES= execinfo python:build scons ssl
USE_LDCONFIG= yes