aboutsummaryrefslogtreecommitdiffstats
path: root/databases/gdbm
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-08-08 16:11:09 +0800
committererwin <erwin@FreeBSD.org>2006-08-08 16:11:09 +0800
commit952771af7a291ec9cf6429683121b4be94366e8a (patch)
tree917dbc1fa782e36b9a671d6fa7a45f9f1d3813fe /databases/gdbm
parent3db18f98c62492c1230fad90461d95e829325e9b (diff)
downloadfreebsd-ports-gnome-952771af7a291ec9cf6429683121b4be94366e8a.tar.gz
freebsd-ports-gnome-952771af7a291ec9cf6429683121b4be94366e8a.tar.zst
freebsd-ports-gnome-952771af7a291ec9cf6429683121b4be94366e8a.zip
- Eliminate a patch
- Respect DESTDIR PR: 101567 Submitted by: gabor (maintainer)
Diffstat (limited to 'databases/gdbm')
-rw-r--r--databases/gdbm/Makefile7
-rw-r--r--databases/gdbm/files/patch-ab20
2 files changed, 7 insertions, 20 deletions
diff --git a/databases/gdbm/Makefile b/databases/gdbm/Makefile
index 90ae49ebe453..e8d6f97bd5c3 100644
--- a/databases/gdbm/Makefile
+++ b/databases/gdbm/Makefile
@@ -38,4 +38,11 @@ pre-everything::
@${ECHO_MSG}
.endif
+post-patch:
+ @${REINPLACE_CMD} "s|prefix = @prefix@|prefix = ${TARGETDIR}|" \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e "s|LIBS = @LIBS@ -lc|LIBS = @LIBS@|" \
+ -e "s|libgdbm.la libgdbm_compat.la|libgdbm.la libgdbm_compat.la gdbm.info|" \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>
diff --git a/databases/gdbm/files/patch-ab b/databases/gdbm/files/patch-ab
deleted file mode 100644
index 5d19eaf34fa7..000000000000
--- a/databases/gdbm/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- Makefile.in.orig Wed Oct 9 01:09:12 2002
-+++ Makefile.in Tue Oct 22 22:19:59 2002
-@@ -24,7 +24,7 @@
- DEFS =
-
- # Where the system [n]dbm routines are...
--LIBS = @LIBS@ -lc
-+LIBS = @LIBS@
-
- CFLAGS = @CFLAGS@
- LDFLAGS = @LDFLAGS@
-@@ -122,7 +122,7 @@
-
- DISTFILES = $(SRCS) $(HDRS) $(MSCFILES)
-
--all: libgdbm.la libgdbm_compat.la
-+all: libgdbm.la libgdbm_compat.la gdbm.info
-
- progs: $(PROGS)
-