aboutsummaryrefslogtreecommitdiffstats
path: root/databases/gomysql
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-12-06 12:08:24 +0800
committerwen <wen@FreeBSD.org>2010-12-06 12:08:24 +0800
commitd18f04f2a1f229fa58ddce403c9e2f7a45230d9d (patch)
tree701e2718a92138790bc28e5f156bb96971ab40d5 /databases/gomysql
parent43995f7b2767ea833cf3d32a44d26f2f608eb21a (diff)
downloadfreebsd-ports-gnome-d18f04f2a1f229fa58ddce403c9e2f7a45230d9d.tar.gz
freebsd-ports-gnome-d18f04f2a1f229fa58ddce403c9e2f7a45230d9d.tar.zst
freebsd-ports-gnome-d18f04f2a1f229fa58ddce403c9e2f7a45230d9d.zip
A MySQL client library written in Go. The aim of this project is to
provide a library with a high level of usability, good interal error handling and to emulate similar libraries available for other languages to provide an easy migration of MySQL based systems into the Go language. WWW: https://github.com/Philio/GoMySQL
Diffstat (limited to 'databases/gomysql')
-rw-r--r--databases/gomysql/Makefile24
-rw-r--r--databases/gomysql/distinfo2
-rw-r--r--databases/gomysql/pkg-descr6
3 files changed, 32 insertions, 0 deletions
diff --git a/databases/gomysql/Makefile b/databases/gomysql/Makefile
new file mode 100644
index 000000000000..908cf0a0c9d2
--- /dev/null
+++ b/databases/gomysql/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: gomysql
+# Date created: Dec 06, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gomysql
+PORTVERSION= 0.2.1
+CATEGORIES= databases
+MASTER_SITES= LOCAL/wen
+DISTNAME= Philio-GoMySQL-${PORTVERSION}-0-g61eeb6a
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= A MySQL client library written in Go
+
+WRKSRC= ${WRKDIR}/Philio-GoMySQL-862a45c
+PLIST_FILES= ${GO_LIBDIR}/mysql.a
+
+USE_GO= yes
+
+.include <bsd.port.pre.mk>
+.include "../../lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/gomysql/distinfo b/databases/gomysql/distinfo
new file mode 100644
index 000000000000..824208242c73
--- /dev/null
+++ b/databases/gomysql/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Philio-GoMySQL-0.2.1-0-g61eeb6a.tar.gz) = 132b2f85ae2297fcb6f50fe1473726b8e69e0203b63663aad3ee05a603cbf259
+SIZE (Philio-GoMySQL-0.2.1-0-g61eeb6a.tar.gz) = 19699
diff --git a/databases/gomysql/pkg-descr b/databases/gomysql/pkg-descr
new file mode 100644
index 000000000000..d2071b792c95
--- /dev/null
+++ b/databases/gomysql/pkg-descr
@@ -0,0 +1,6 @@
+A MySQL client library written in Go. The aim of this project is to
+provide a library with a high level of usability, good interal error
+handling and to emulate similar libraries available for other languages
+to provide an easy migration of MySQL based systems into the Go language.
+
+WWW: https://github.com/Philio/GoMySQL