aboutsummaryrefslogtreecommitdiffstats
path: root/databases/hk_classes
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-03-04 13:45:37 +0800
committermiwi <miwi@FreeBSD.org>2012-03-04 13:45:37 +0800
commitf35b9e52c1ba0e8e8bb8eeaa803abbf5491e9d78 (patch)
tree1c4206ee3bbe96d7907b317e020bcfb764de3adb /databases/hk_classes
parent855e8e3a76302d358a2b0c6c631a052a6c1c1fb4 (diff)
downloadfreebsd-ports-gnome-f35b9e52c1ba0e8e8bb8eeaa803abbf5491e9d78.tar.gz
freebsd-ports-gnome-f35b9e52c1ba0e8e8bb8eeaa803abbf5491e9d78.tar.zst
freebsd-ports-gnome-f35b9e52c1ba0e8e8bb8eeaa803abbf5491e9d78.zip
- Update 0.8.3
PR: 165572 Submitted by: Armin Pirkovitsch <armin@frozen-zone.org>
Diffstat (limited to 'databases/hk_classes')
-rw-r--r--databases/hk_classes/Makefile29
-rw-r--r--databases/hk_classes/distinfo4
-rw-r--r--databases/hk_classes/files/patch-configure15
-rw-r--r--databases/hk_classes/files/patch-hk_classes_hk_database.h (renamed from databases/hk_classes/files/patch-hk_classes::hk_database.h)0
-rw-r--r--databases/hk_classes/files/patch-utilities_Makefile.in (renamed from databases/hk_classes/files/patch-utilities::Makefile.in)8
-rw-r--r--databases/hk_classes/pkg-plist14
6 files changed, 36 insertions, 34 deletions
diff --git a/databases/hk_classes/Makefile b/databases/hk_classes/Makefile
index a25c4cde7de8..5b7e48033d7f 100644
--- a/databases/hk_classes/Makefile
+++ b/databases/hk_classes/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= hk_classes
-PORTVERSION= 0.8.1
-PORTREVISION= 6
+PORTVERSION= 0.8.3
CATEGORIES= databases
MASTER_SITES= SF/hk-classes/${PORTNAME}/${PORTVERSION}
@@ -14,7 +13,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= C++ Library for rapid development of database applications
BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
-LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig \
+ xml2.5:${PORTSDIR}/textproc/libxml2
USE_BZIP2= yes
USE_ICONV= yes
@@ -43,11 +43,8 @@ OPTIONS= MYSQL "Build MySQL driver" on \
ODBC "Build unixODBC driver" off \
PARADOX "Build Paradox driver" off \
SQLITE2 "Build with sqlite2 driver" off \
- SQLITE3 "Build with sqlite3 driver" off
-
-MAN1= hk_report.1man hk_actionquery.1man hk_exportxml.1man \
- hk_exporthtml.1man hk_exportcsv.1man hk_importcsv.1man \
- hk_dbcopy.1man
+ SQLITE3 "Build with sqlite3 driver" off \
+ DBASE "Build with dbase driver" off
.include <bsd.port.pre.mk>
@@ -64,6 +61,13 @@ CONFIGURE_ARGS+= --without-mysql
PLIST_SUB+= MYSQL="@comment "
.endif
+.if !defined(WITH_DBASE)
+CONFIGURE_ARGS+= --without-dbase
+PLIST_SUB+= DBASE="@comment "
+.else
+PLIST_SUB+= DBASE=""
+.endif
+
.if defined(WITH_POSTGRESQL)
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgres-incdir=${LOCALBASE}/include/ \
@@ -130,6 +134,15 @@ CONFIGURE_ARGS+= --without-sqlite3
PLIST_SUB+= SQLITE3="@comment "
.endif
+post-patch:
+ ${REINPLACE_CMD} -e "s|INCLUDES = -I../hk_classes \
+ -I./pxlib|INCLUDES = -I../hk_classes -I./pxlib \
+ -I${LOCALBASE}/include|g" \
+ ${WRKSRC}/hk_paradoxclasses/Makefile.in
+
+post-configure:
+ ${REINPLACE_CMD} -e "s| -I|','|g" ${WRKSRC}/python/setup.py
+
post-install:
@${SED} -e 's#%%PREFIX%%#${PREFIX}#' ${FILESDIR}/hk_classes.sh > \
${PREFIX}/etc/rc.d/hk_classes.sh; \
diff --git a/databases/hk_classes/distinfo b/databases/hk_classes/distinfo
index 5cac9bcd64d4..c509e3118074 100644
--- a/databases/hk_classes/distinfo
+++ b/databases/hk_classes/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hk_classes-0.8.1.tar.bz2) = 9e403fe153962770676099c2346a74b96953eba790a289303c49fe448c958603
-SIZE (hk_classes-0.8.1.tar.bz2) = 1413828
+SHA256 (hk_classes-0.8.3.tar.bz2) = d57a8a2f3c2fb534e01ee5d7b6c5bb650536f20cb7e88a721ec9da7b5befb593
+SIZE (hk_classes-0.8.3.tar.bz2) = 1532249
diff --git a/databases/hk_classes/files/patch-configure b/databases/hk_classes/files/patch-configure
index 65d24c0fc8eb..0bf44059a194 100644
--- a/databases/hk_classes/files/patch-configure
+++ b/databases/hk_classes/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sat Jul 22 12:08:15 2006
-+++ configure Sat Jul 22 12:08:43 2006
-@@ -20549,7 +20549,7 @@
+--- configure.orig 2006-12-17 15:27:45.000000000 +0100
++++ configure 2012-02-19 20:23:04.014494956 +0100
+@@ -20681,7 +20681,7 @@
py_version=`$PYTHON -c "from distutils.sysconfig import *; \
from string import join; \
print join(get_config_vars('VERSION'))"`
@@ -9,12 +9,3 @@
if test -n "$PYTHON_VERSION"; then
py_version=$PYTHON_VERSION
else
-@@ -20815,7 +20815,7 @@
- fi
-
- if test "x$with_fontconfig_libdir" != "x"; then
-- FONTCONFIGLIBDIR=$with_fontconifg_libdir
-+ FONTCONFIGLIBDIR=$with_fontconfig_libdir
- fi
-
- ac_save_LIBS="$LIBS"
diff --git a/databases/hk_classes/files/patch-hk_classes::hk_database.h b/databases/hk_classes/files/patch-hk_classes_hk_database.h
index cd537d133b9b..cd537d133b9b 100644
--- a/databases/hk_classes/files/patch-hk_classes::hk_database.h
+++ b/databases/hk_classes/files/patch-hk_classes_hk_database.h
diff --git a/databases/hk_classes/files/patch-utilities::Makefile.in b/databases/hk_classes/files/patch-utilities_Makefile.in
index b631f7705da1..2c77b7e8d89d 100644
--- a/databases/hk_classes/files/patch-utilities::Makefile.in
+++ b/databases/hk_classes/files/patch-utilities_Makefile.in
@@ -1,9 +1,9 @@
---- utilities/Makefile.in.orig Sat Jul 22 12:09:44 2006
-+++ utilities/Makefile.in Sat Jul 22 12:11:59 2006
-@@ -237,22 +237,22 @@
+--- utilities/Makefile.in.orig 2006-12-17 15:27:52.000000000 +0100
++++ utilities/Makefile.in 2012-02-19 19:21:04.761495232 +0100
+@@ -248,22 +248,22 @@
target_alias = @target_alias@
INCLUDES = -I../hk_classes
- AM_CXXFLAGS = -Wall -W -Wconversion -Wshadow -Wcast-qual -Wwrite-strings
+ AM_CXXFLAGS = -Wall -W -Wconversion -Wshadow -Wcast-qual -Wwrite-strings -I@XMLINCLUDE@ @BITARCHITECTURE@
-hk_report_LDADD = ../hk_classes/libhk_classes.la -ldl
+hk_report_LDADD = ../hk_classes/libhk_classes.la -largp ${LIBPTHREAD}
hk_report_SOURCES = hk_reportutility.cpp
diff --git a/databases/hk_classes/pkg-plist b/databases/hk_classes/pkg-plist
index ad0a3596c2d9..293ec93dea67 100644
--- a/databases/hk_classes/pkg-plist
+++ b/databases/hk_classes/pkg-plist
@@ -1,11 +1,4 @@
etc/rc.d/hk_classes.sh
-bin/hk_actionquery
-bin/hk_dbcopy
-bin/hk_exportcsv
-bin/hk_exporthtml
-bin/hk_exportxml
-bin/hk_importcsv
-bin/hk_report
include/hk_classes/hk_actionquery.h
include/hk_classes/hk_button.h
include/hk_classes/hk_class.h
@@ -41,6 +34,7 @@ include/hk_classes/hk_interpreter.h
include/hk_classes/hk_key.h
include/hk_classes/hk_label.h
include/hk_classes/hk_mimetype.h
+include/hk_classes/hk_module.h
include/hk_classes/hk_presentation.h
include/hk_classes/hk_qbe.h
include/hk_classes/hk_referentialintegrity.h
@@ -60,6 +54,10 @@ include/hk_classes/hk_visible.h
%%MYSQL%%lib/hk_classes/drivers/libhk_mysqldriver.la
%%MYSQL%%lib/hk_classes/drivers/libhk_mysqldriver.so
%%MYSQL%%lib/hk_classes/drivers/libhk_mysqldriver.so.3
+%%DBASE%%lib/hk_classes/drivers/libhk_dbasedriver.a
+%%DBASE%%lib/hk_classes/drivers/libhk_dbasedriver.la
+%%DBASE%%lib/hk_classes/drivers/libhk_dbasedriver.so
+%%DBASE%%lib/hk_classes/drivers/libhk_dbasedriver.so.0
%%ODBC%%lib/hk_classes/drivers/libhk_odbcdriver.a
%%ODBC%%lib/hk_classes/drivers/libhk_odbcdriver.la
%%ODBC%%lib/hk_classes/drivers/libhk_odbcdriver.so
@@ -86,7 +84,7 @@ include/hk_classes/hk_visible.h
lib/hk_classes/libhk_classes.a
lib/hk_classes/libhk_classes.la
lib/hk_classes/libhk_classes.so
-lib/hk_classes/libhk_classes.so.13
+lib/hk_classes/libhk_classes.so.15
@dirrm lib/hk_classes/drivers
@dirrm lib/hk_classes
@dirrm include/hk_classes