aboutsummaryrefslogtreecommitdiffstats
path: root/databases/hs-mysql
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2011-07-04 06:00:49 +0800
committerashish <ashish@FreeBSD.org>2011-07-04 06:00:49 +0800
commitb26156d7c15ae37008f4320d798cc455dd75504a (patch)
tree9da9e0f02d96bac0741047238815c52787252ce7 /databases/hs-mysql
parent465831243211d3a5856e2ee34a4d238384d01c5b (diff)
downloadfreebsd-ports-gnome-b26156d7c15ae37008f4320d798cc455dd75504a.tar.gz
freebsd-ports-gnome-b26156d7c15ae37008f4320d798cc455dd75504a.tar.zst
freebsd-ports-gnome-b26156d7c15ae37008f4320d798cc455dd75504a.zip
This library is a Haskell binding to the MySQL mysqlclient client library.
It is a fairly faithful, low level library that implements most of the MySQL client API. WWW: https://github.com/mailrank/mysql PR: ports/157264 Submitted by: Jyun-Yan You <jyyou@cs.nctu.edu.tw>
Diffstat (limited to 'databases/hs-mysql')
-rw-r--r--databases/hs-mysql/Makefile20
-rw-r--r--databases/hs-mysql/distinfo2
-rw-r--r--databases/hs-mysql/pkg-descr5
3 files changed, 27 insertions, 0 deletions
diff --git a/databases/hs-mysql/Makefile b/databases/hs-mysql/Makefile
new file mode 100644
index 000000000000..fb6764da5bdd
--- /dev/null
+++ b/databases/hs-mysql/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-mysql
+# Date created: 2011-05-23
+# Whom: jyyou@cs.nctu.edu.tw
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysql
+PORTVERSION= 0.1.1.1
+CATEGORIES= databases haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A low-level client library for the MySQL database
+
+LICENSE= BSD
+
+USE_MYSQL= yes
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/databases/hs-mysql/distinfo b/databases/hs-mysql/distinfo
new file mode 100644
index 000000000000..4d2d9a4a929e
--- /dev/null
+++ b/databases/hs-mysql/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/mysql-0.1.1.1.tar.gz) = bd8958f87bf3951ce9bf367cdbbd3a6d587b766ec206bb4ede40852f6156ea1f
+SIZE (cabal/mysql-0.1.1.1.tar.gz) = 13562
diff --git a/databases/hs-mysql/pkg-descr b/databases/hs-mysql/pkg-descr
new file mode 100644
index 000000000000..4fe794280aec
--- /dev/null
+++ b/databases/hs-mysql/pkg-descr
@@ -0,0 +1,5 @@
+This library is a Haskell binding to the MySQL mysqlclient client library.
+It is a fairly faithful, low level library that implements
+most of the MySQL client API.
+
+WWW: https://github.com/mailrank/mysql