aboutsummaryrefslogtreecommitdiffstats
path: root/databases/hypertable
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2010-08-20 19:13:23 +0800
committerskv <skv@FreeBSD.org>2010-08-20 19:13:23 +0800
commite9a4830486260c5261ed1ff2d18092897973cb54 (patch)
treefad08ce60c3089205fe9a46f8e1b81c097a1c34f /databases/hypertable
parent738b4bb99527fa0a8af2c84f19f77070e8456a5a (diff)
downloadfreebsd-ports-gnome-e9a4830486260c5261ed1ff2d18092897973cb54.tar.gz
freebsd-ports-gnome-e9a4830486260c5261ed1ff2d18092897973cb54.tar.zst
freebsd-ports-gnome-e9a4830486260c5261ed1ff2d18092897973cb54.zip
Add hypertable , high performance distributed data storage system.
Diffstat (limited to 'databases/hypertable')
-rw-r--r--databases/hypertable/Makefile135
-rw-r--r--databases/hypertable/distinfo3
-rw-r--r--databases/hypertable/files/patch-FindRRDtool.cmake13
-rw-r--r--databases/hypertable/files/patch-ht-env.sh12
-rw-r--r--databases/hypertable/files/patch-injail10
-rw-r--r--databases/hypertable/pkg-descr14
-rw-r--r--databases/hypertable/pkg-plist440
7 files changed, 627 insertions, 0 deletions
diff --git a/databases/hypertable/Makefile b/databases/hypertable/Makefile
new file mode 100644
index 000000000000..0e38ab002a1f
--- /dev/null
+++ b/databases/hypertable/Makefile
@@ -0,0 +1,135 @@
+# New ports collection makefile for: hypertable
+# Date created: 20 Aug 2010
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hypertable
+DISTVERSION= 0.9.3.4-alpha
+CATEGORIES= databases
+MASTER_SITES= GOOGLE_CODE
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= High performance distributed data storage system
+
+RUN_DEPENDS= bash>=3.0:${PORTSDIR}/shells/bash
+LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2 \
+ thrift.0:${PORTSDIR}/devel/thrift \
+ event:${PORTSDIR}/devel/libevent \
+ log4cpp:${PORTSDIR}/devel/log4cpp \
+ boost_thread:${PORTSDIR}/devel/boost-libs \
+ rrd:${PORTSDIR}/databases/rrdtool \
+ art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl \
+ sigar:${PORTSDIR}/sysutils/hyperic-sigar
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ant:${PORTSDIR}/devel/apache-ant
+
+OPTIONS= TCMALLOC "Use Tcmalloc" on \
+ HOARD "Use Hoard" off \
+ PYTHONLIBS "Add Python binding" off \
+ THRIFT_PERL "Thrift binding for Perl" off \
+ THRIFT_PYTHON "Thrift binding for Python" off \
+ THRIFT_RUBY "Thrift binding for Ruby" off
+
+USE_BDB= yes
+WANT_BDB_VER= 48
+
+USE_CMAKE= yes
+CMAKE_BUILD_TYPE= RelWithDebinfo
+CMAKE_INSTALL_PREFIX= ${PREFIX}/hypertable
+CMAKE_SOURCE_PATH= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+CMAKE_ARGS+= -DINSTALL_EXCLUDE_DEPENDENT_LIBS=1
+
+PATCH_WRKSRC= ${CMAKE_SOURCE_PATH}
+
+WRKSRC= ${WRKDIR}/build
+
+USE_GMAKE= yes
+
+USE_LDCONFIG= ${PREFIX}/hypertable/lib
+
+DONT_DETECT= Doxygen Kfs Ceph Ant JNI PHP5Thrift
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_TCMALLOC)
+LIB_DEPENDS+= tcmalloc.0:${PORTSDIR}/devel/google-perftools
+PLIST_SUB+= TCMALLOC=""
+.else
+DONT_DETECT+= Tcmalloc
+PLIST_SUB+= TCMALLOC="@comment "
+.endif
+
+.if defined(WITH_HOARD)
+LIB_DEPENDS+= hoard.so.1:${PORTSDIR}/devel/libhoard
+PLIST_SUB+= HOARD=""
+.else
+DONT_DETECT+= Hoard
+PLIST_SUB+= HOARD="@comment "
+.endif
+
+.if defined(WITH_PYTHONLIBS)
+USE_PYTHON= yes
+LIB_DEPENDS+= boost_python:${PORTSDIR}/devel/boost-python-libs
+.else
+DONT_DETECT+= PythonLibs
+.endif
+
+.if defined(WITH_THRIFT_PERL)
+BUILD_DEPENDS+= p5-Thrift>=0:${PORTSDIR}/devel/p5-Thrift
+.else
+DONT_DETECT+= PerlThrift
+.endif
+
+.if defined(WITH_THRIFT_PYTHON)
+USE_PYTHON= yes
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}thrift>=0:${PORTSDIR}/devel/py-thrift
+.else
+DONT_DETECT+= PythonThrift
+.endif
+
+.if defined(WITH_THRIFT_RUBY)
+BUILD_DEPENDS+= ruby-thrift>=0:${PORTSDIR}/devel/ruby-thrift
+.else
+DONT_DETECT+= RubyThrift
+.endif
+
+pre-everything::
+.if defined(WITH_THRIFT_PERL) && !defined(WITH_THRIFT)
+ @${ECHO_CMD} "please enable THRIFT option to use THRIFT_PERL"
+ @${FALSE}
+.endif
+.if defined(WITH_THRIFT_PYTHON) && !defined(WITH_THRIFT)
+ @${ECHO_CMD} "please enable THRIFT option to use THRIFT_PYTHON"
+ @${FALSE}
+.endif
+.if defined(WITH_THRIFT_RUBY) && !defined(WITH_THRIFT)
+ @${ECHO_CMD} "please enable THRIFT option to use THRIFT_RUBY"
+ @${FALSE}
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -i '' -e 's=/opt/local=${LOCALBASE}=' \
+ ${PATCH_WRKSRC}/cmake/*.cmake
+ @${REINPLACE_CMD} -i '' -e 's=/usr/local/BerkeleyDB.4.8/include=${BDB_INCLUDE_DIR}=; \
+ s=/usr/local/BerkeleyDB.4.8/lib=${BDB_LIB_DIR}=' \
+ ${PATCH_WRKSRC}/cmake/FindBerkeleyDB.cmake
+ @${REINPLACE_CMD} -i '' -E '/^set\(CMAKE_INSTALL_PREFIX/d' \
+ ${PATCH_WRKSRC}/CMakeLists.txt
+ @${FIND} ${PATCH_WRKSRC} -name "*.orig" -delete
+
+pre-configure:
+ @${MKDIR} ${WRKSRC}
+.for _D in ${DONT_DETECT}
+ @${REINPLACE_CMD} -i '' -E '/^find_package\(${_D}\)/d' \
+ ${PATCH_WRKSRC}/CMakeLists.txt
+.endfor
+
+test: build
+ (cd ${WRKSRC} && ${GMAKE} alltests)
+
+.include <bsd.port.post.mk>
diff --git a/databases/hypertable/distinfo b/databases/hypertable/distinfo
new file mode 100644
index 000000000000..509d410629d2
--- /dev/null
+++ b/databases/hypertable/distinfo
@@ -0,0 +1,3 @@
+MD5 (hypertable-0.9.3.4-alpha-src.tar.gz) = bff265a8d0e204e780f46c19173bf61b
+SHA256 (hypertable-0.9.3.4-alpha-src.tar.gz) = 4eab83a2de13ba3054d618129a234fb5a5f28e72a6c71b12da244b12837ecad6
+SIZE (hypertable-0.9.3.4-alpha-src.tar.gz) = 24245034
diff --git a/databases/hypertable/files/patch-FindRRDtool.cmake b/databases/hypertable/files/patch-FindRRDtool.cmake
new file mode 100644
index 000000000000..b6672d4f726d
--- /dev/null
+++ b/databases/hypertable/files/patch-FindRRDtool.cmake
@@ -0,0 +1,13 @@
+--- cmake/FindRRDtool.cmake.orig 2010-08-10 16:56:32.000000000 +0000
++++ cmake/FindRRDtool.cmake 2010-08-10 16:56:53.000000000 +0000
+@@ -50,8 +50,8 @@
+
+ message(STATUS "${RRD_LIBRARY} ${RRD_INCLUDE_DIR} ${FREETYPE_LIBRARY} ${PNG12_LIBRARY} ${ART_LGPL_2_LIBRARY}")
+
+-if (RRD_LIBRARY AND RRD_INCLUDE_DIR AND FREETYPE_LIBRARY AND PNG12_LIBRARY AND ART_LGPL_2_LIBRARY)
+- set(RRD_LIBRARIES ${RRD_LIBRARY} ${FREETYPE_LIBRARY} ${PNG12_LIBRARY} ${ART_LGPL_2_LIBRARY})
++if (RRD_LIBRARY AND RRD_INCLUDE_DIR)
++ set(RRD_LIBRARIES ${RRD_LIBRARY})
+ set(RRD_FOUND "YES")
+ message(STATUS "Found RRDtool: ${RRD_LIBRARIES}")
+ else ()
diff --git a/databases/hypertable/files/patch-ht-env.sh b/databases/hypertable/files/patch-ht-env.sh
new file mode 100644
index 000000000000..836d37362c7c
--- /dev/null
+++ b/databases/hypertable/files/patch-ht-env.sh
@@ -0,0 +1,12 @@
+--- bin/ht-env.sh 2010-05-06 12:24:43.000000000 +0000
++++ bin/ht-env.sh 2010-05-06 12:25:00.000000000 +0000
+@@ -179,9 +179,6 @@
+
+ # Sanity check
+ [ "$HYPERTABLE_HOME" ] || die "ERROR: HYPERTABLE_HOME is not set"
+-versionre='/([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+(\.[a-fA-F0-9]+)?|current)$'
+-[[ $HYPERTABLE_HOME =~ $versionre ]] ||
+- die "ERROR: Invalid HYPERTABLE_HOME: $HYPERTABLE_HOME"
+
+ # Make sure log and run directories exist
+ [ -d $HYPERTABLE_HOME/run ] || mkdir $HYPERTABLE_HOME/run
diff --git a/databases/hypertable/files/patch-injail b/databases/hypertable/files/patch-injail
new file mode 100644
index 000000000000..f1206ad4f912
--- /dev/null
+++ b/databases/hypertable/files/patch-injail
@@ -0,0 +1,10 @@
+--- src/cc/AsyncComm/IOHandlerDatagram.h 2010-04-14 17:43:30.000000000 +0000
++++ src/cc/AsyncComm/IOHandlerDatagram.h 2010-05-04 13:52:53.000000000 +0000
+@@ -45,6 +45,7 @@
+
+ IOHandlerDatagram(int sd, const InetAddr &addr, DispatchHandlerPtr &dhp)
+ : IOHandler(sd, addr, dhp), m_send_queue() {
++ m_local_addr.sin_addr.s_addr = addr.sin_addr.s_addr;
+ m_message = new uint8_t [65536];
+ }
+
diff --git a/databases/hypertable/pkg-descr b/databases/hypertable/pkg-descr
new file mode 100644
index 000000000000..409fefdf303a
--- /dev/null
+++ b/databases/hypertable/pkg-descr
@@ -0,0 +1,14 @@
+Hypertable is a high performance distributed data storage system
+designed to support applications requiring maximum performance,
+scalability, and reliability.
+
+Hypertable will be particularly invaluable to any organization that
+needs to manage rapidly evolving data to support demanding real-time
+applications. Modeled after Google's well known Bigtable project,
+Hypertable is designed to manage the storage and processing of
+information on a large cluster of commodity servers, providing
+resilience to machine and component failures. Hypertable seeks to set
+the open source standard for highly available, petabyte scale, database
+systems.
+
+WWW: http://hypertable.org/
diff --git a/databases/hypertable/pkg-plist b/databases/hypertable/pkg-plist
new file mode 100644
index 000000000000..bbe2446954f5
--- /dev/null
+++ b/databases/hypertable/pkg-plist
@@ -0,0 +1,440 @@
+hypertable/bin/Hyperspace.Master
+hypertable/bin/Hypertable.Master
+hypertable/bin/Hypertable.RangeServer
+hypertable/bin/ThriftBroker
+hypertable/bin/clean-database.sh
+hypertable/bin/clean-hyperspace.sh
+hypertable/bin/count_stored
+hypertable/bin/csdump
+hypertable/bin/dfsclient
+hypertable/bin/dump_metalog
+hypertable/bin/dumplog
+hypertable/bin/fhsize.sh
+hypertable/bin/generate_test_data
+hypertable/bin/ht
+hypertable/bin/ht-env.sh
+hypertable/bin/ht_checksum
+hypertable/bin/ht_load_generator
+hypertable/bin/ht_rsclient
+hypertable/bin/ht_write_test
+hypertable/bin/htbt.sh
+hypertable/bin/htgc
+hypertable/bin/hyperspace
+hypertable/bin/hypertable
+hypertable/bin/java-thrift.sh
+hypertable/bin/jrun
+hypertable/bin/ldd.sh
+hypertable/bin/localBroker
+hypertable/bin/merge_diff
+hypertable/bin/prerm.sh
+hypertable/bin/prune_tsv
+hypertable/bin/random-wait.sh
+hypertable/bin/random_read_test
+hypertable/bin/random_write_test
+hypertable/bin/rsstat
+hypertable/bin/serverup
+hypertable/bin/soname.sh
+hypertable/bin/start-all-servers.sh
+hypertable/bin/start-dfsbroker.sh
+hypertable/bin/start-hyperspace.sh
+hypertable/bin/start-master.sh
+hypertable/bin/start-monitoring.sh
+hypertable/bin/start-rangeserver.sh
+hypertable/bin/start-test-client.sh
+hypertable/bin/start-test-servers.sh
+hypertable/bin/start-thriftbroker.sh
+hypertable/bin/stop-hyperspace.sh
+hypertable/bin/stop-monitoring.sh
+hypertable/bin/stop-servers.sh
+hypertable/bin/system_info
+hypertable/conf/Capfile.cluster
+hypertable/conf/Capfile.localhost
+hypertable/conf/METADATA.xml
+hypertable/conf/hypertable.cfg
+hypertable/examples/apache_log/CMakeLists.txt
+hypertable/examples/apache_log/Makefile
+hypertable/examples/apache_log/README.txt
+hypertable/examples/apache_log/access.log.gz
+hypertable/examples/apache_log/apache_log_load.cc
+hypertable/examples/apache_log/apache_log_query.cc
+hypertable/examples/apache_log/create-table.hql
+hypertable/examples/freebase/CMakeLists.txt
+hypertable/examples/freebase/aircraft_model.tsv.gz
+hypertable/examples/freebase/create-table-freebase.hql
+hypertable/examples/freebase/freebase_load.cc
+hypertable/examples/freebase/freebase_parser.cc
+hypertable/examples/freebase/freebase_parser.h
+hypertable/examples/hql_tutorial/Pages-create.hql
+hypertable/include/AsyncComm/ApplicationHandler.h
+hypertable/include/AsyncComm/ApplicationQueue.h
+hypertable/include/AsyncComm/Comm.h
+hypertable/include/AsyncComm/CommAddress.h
+hypertable/include/AsyncComm/CommBuf.h
+hypertable/include/AsyncComm/CommHeader.h
+hypertable/include/AsyncComm/Config.h
+hypertable/include/AsyncComm/ConnectionHandlerFactory.h
+hypertable/include/AsyncComm/ConnectionManager.h
+hypertable/include/AsyncComm/DispatchHandler.h
+hypertable/include/AsyncComm/DispatchHandlerSynchronizer.h
+hypertable/include/AsyncComm/Event.h
+hypertable/include/AsyncComm/ExpireTimer.h
+hypertable/include/AsyncComm/HandlerMap.h
+hypertable/include/AsyncComm/IOHandler.h
+hypertable/include/AsyncComm/IOHandlerAccept.h
+hypertable/include/AsyncComm/IOHandlerData.h
+hypertable/include/AsyncComm/IOHandlerDatagram.h
+hypertable/include/AsyncComm/PollTimeout.h
+hypertable/include/AsyncComm/Protocol.h
+hypertable/include/AsyncComm/ProxyMap.h
+hypertable/include/AsyncComm/Reactor.h
+hypertable/include/AsyncComm/ReactorFactory.h
+hypertable/include/AsyncComm/ReactorRunner.h
+hypertable/include/AsyncComm/RequestCache.h
+hypertable/include/AsyncComm/ResponseCallback.h
+hypertable/include/Common/Abi.h
+hypertable/include/Common/Allocator.h
+hypertable/include/Common/Barrier.h
+hypertable/include/Common/BlobHashSet.h
+hypertable/include/Common/BlobHashTraits.h
+hypertable/include/Common/BloomFilter.h
+hypertable/include/Common/BloomFilterWithChecksum.h
+hypertable/include/Common/ByteString.h
+hypertable/include/Common/Checksum.h
+hypertable/include/Common/Compat.h
+hypertable/include/Common/Config.h
+hypertable/include/Common/CstrHashMap.h
+hypertable/include/Common/CstrHashTraits.h
+hypertable/include/Common/DiscreteRandomGenerator.h
+hypertable/include/Common/DiscreteRandomGeneratorFactory.h
+hypertable/include/Common/DiscreteRandomGeneratorUniform.h
+hypertable/include/Common/DiscreteRandomGeneratorZipf.h
+hypertable/include/Common/DynamicBuffer.h
+hypertable/include/Common/Error.h
+hypertable/include/Common/FailureInducer.h
+hypertable/include/Common/FileUtils.h
+hypertable/include/Common/Filesystem.h
+hypertable/include/Common/FixedStream.h
+hypertable/include/Common/FlyweightString.h
+hypertable/include/Common/HashMap.h
+hypertable/include/Common/InetAddr.h
+hypertable/include/Common/Init.h
+hypertable/include/Common/InteractiveCommand.h
+hypertable/include/Common/Logger.h
+hypertable/include/Common/Lookup3.h
+hypertable/include/Common/Math.h
+hypertable/include/Common/Meta.h
+hypertable/include/Common/MurmurHash.h
+hypertable/include/Common/Mutex.h
+hypertable/include/Common/NumberStream.h
+hypertable/include/Common/PageArena.h
+hypertable/include/Common/PageArenaAllocator.h
+hypertable/include/Common/Path.h
+hypertable/include/Common/Properties.h
+hypertable/include/Common/Random.h
+hypertable/include/Common/ReferenceCount.h
+hypertable/include/Common/Runnable.h
+hypertable/include/Common/ScopeGuard.h
+hypertable/include/Common/Serialization.h
+hypertable/include/Common/ServerLauncher.h
+hypertable/include/Common/ServerStats.h
+hypertable/include/Common/SockAddrMap.h
+hypertable/include/Common/StaticBuffer.h
+hypertable/include/Common/StlHash.h
+hypertable/include/Common/Stopwatch.h
+hypertable/include/Common/String.h
+hypertable/include/Common/StringExt.h
+hypertable/include/Common/SuperFastHash.h
+hypertable/include/Common/Sweetener.h
+hypertable/include/Common/System.h
+hypertable/include/Common/SystemInfo.h
+hypertable/include/Common/TclHash.h
+hypertable/include/Common/TestHarness.h
+hypertable/include/Common/TestUtils.h
+hypertable/include/Common/Thread.h
+hypertable/include/Common/Time.h
+hypertable/include/Common/TimeInline.h
+hypertable/include/Common/Timer.h
+hypertable/include/Common/Usage.h
+hypertable/include/Common/Version.h
+hypertable/include/Common/atomic.h
+hypertable/include/Common/compat-c.h
+hypertable/include/Common/endian-c.h
+hypertable/include/Common/md5.h
+hypertable/include/Common/serialization-c.h
+hypertable/include/DfsBroker/Lib/Broker.h
+hypertable/include/DfsBroker/Lib/Client.h
+hypertable/include/DfsBroker/Lib/ClientBufferedReaderHandler.h
+hypertable/include/DfsBroker/Lib/Config.h
+hypertable/include/DfsBroker/Lib/ConnectionHandler.h
+hypertable/include/DfsBroker/Lib/ConnectionHandlerFactory.h
+hypertable/include/DfsBroker/Lib/FileDevice.h
+hypertable/include/DfsBroker/Lib/OpenFileMap.h
+hypertable/include/DfsBroker/Lib/Protocol.h
+hypertable/include/DfsBroker/Lib/RequestHandlerAppend.h
+hypertable/include/DfsBroker/Lib/RequestHandlerClose.h
+hypertable/include/DfsBroker/Lib/RequestHandlerCreate.h
+hypertable/include/DfsBroker/Lib/RequestHandlerDebug.h
+hypertable/include/DfsBroker/Lib/RequestHandlerExists.h
+hypertable/include/DfsBroker/Lib/RequestHandlerFlush.h
+hypertable/include/DfsBroker/Lib/RequestHandlerLength.h
+hypertable/include/DfsBroker/Lib/RequestHandlerMkdirs.h
+hypertable/include/DfsBroker/Lib/RequestHandlerOpen.h
+hypertable/include/DfsBroker/Lib/RequestHandlerPread.h
+hypertable/include/DfsBroker/Lib/RequestHandlerRead.h
+hypertable/include/DfsBroker/Lib/RequestHandlerReaddir.h
+hypertable/include/DfsBroker/Lib/RequestHandlerRemove.h
+hypertable/include/DfsBroker/Lib/RequestHandlerRename.h
+hypertable/include/DfsBroker/Lib/RequestHandlerRmdir.h
+hypertable/include/DfsBroker/Lib/RequestHandlerSeek.h
+hypertable/include/DfsBroker/Lib/RequestHandlerStatus.h
+hypertable/include/DfsBroker/Lib/ResponseCallbackAppend.h
+hypertable/include/DfsBroker/Lib/ResponseCallbackExists.h
+hypertable/include/DfsBroker/Lib/ResponseCallbackLength.h
+hypertable/include/DfsBroker/Lib/ResponseCallbackOpen.h
+hypertable/include/DfsBroker/Lib/ResponseCallbackRead.h
+hypertable/include/DfsBroker/Lib/ResponseCallbackReaddir.h
+hypertable/include/Hyperspace/BerkeleyDbFilesystem.h
+hypertable/include/Hyperspace/ClientConnectionHandler.h
+hypertable/include/Hyperspace/ClientHandleState.h
+hypertable/include/Hyperspace/ClientKeepaliveHandler.h
+hypertable/include/Hyperspace/Config.h
+hypertable/include/Hyperspace/DbtManaged.h
+hypertable/include/Hyperspace/DirEntry.h
+hypertable/include/Hyperspace/DirEntryAttr.h
+hypertable/include/Hyperspace/Event.h
+hypertable/include/Hyperspace/FileHandleCallback.h
+hypertable/include/Hyperspace/HandleCallback.h
+hypertable/include/Hyperspace/HsClientState.h
+hypertable/include/Hyperspace/HsCommandInterpreter.h
+hypertable/include/Hyperspace/HsHelpText.h
+hypertable/include/Hyperspace/HsParser.h
+hypertable/include/Hyperspace/LockSequencer.h
+hypertable/include/Hyperspace/Master.h
+hypertable/include/Hyperspace/Notification.h
+hypertable/include/Hyperspace/Protocol.h
+hypertable/include/Hyperspace/RequestHandlerAttrDel.h
+hypertable/include/Hyperspace/RequestHandlerAttrExists.h
+hypertable/include/Hyperspace/RequestHandlerAttrGet.h
+hypertable/include/Hyperspace/RequestHandlerAttrList.h
+hypertable/include/Hyperspace/RequestHandlerAttrSet.h
+hypertable/include/Hyperspace/RequestHandlerClose.h
+hypertable/include/Hyperspace/RequestHandlerDelete.h
+hypertable/include/Hyperspace/RequestHandlerExists.h
+hypertable/include/Hyperspace/RequestHandlerExpireSessions.h
+hypertable/include/Hyperspace/RequestHandlerHandshake.h
+hypertable/include/Hyperspace/RequestHandlerLock.h
+hypertable/include/Hyperspace/RequestHandlerMkdir.h
+hypertable/include/Hyperspace/RequestHandlerOpen.h
+hypertable/include/Hyperspace/RequestHandlerReaddir.h
+hypertable/include/Hyperspace/RequestHandlerReaddirAttr.h
+hypertable/include/Hyperspace/RequestHandlerRelease.h
+hypertable/include/Hyperspace/RequestHandlerRenewSession.h
+hypertable/include/Hyperspace/RequestHandlerStatus.h
+hypertable/include/Hyperspace/ResponseCallbackAttrExists.h
+hypertable/include/Hyperspace/ResponseCallbackAttrGet.h
+hypertable/include/Hyperspace/ResponseCallbackAttrList.h
+hypertable/include/Hyperspace/ResponseCallbackExists.h
+hypertable/include/Hyperspace/ResponseCallbackLock.h
+hypertable/include/Hyperspace/ResponseCallbackOpen.h
+hypertable/include/Hyperspace/ResponseCallbackReaddir.h
+hypertable/include/Hyperspace/ResponseCallbackReaddirAttr.h
+hypertable/include/Hyperspace/ServerConnectionHandler.h
+hypertable/include/Hyperspace/ServerKeepaliveHandler.h
+hypertable/include/Hyperspace/Session.h
+hypertable/include/Hyperspace/SessionData.h
+hypertable/include/Hyperspace/StateDbKeys.h
+hypertable/include/Hypertable/Lib/ApacheLogParser.h
+hypertable/include/Hypertable/Lib/BlockCompressionCodec.h
+hypertable/include/Hypertable/Lib/BlockCompressionCodecBmz.h
+hypertable/include/Hypertable/Lib/BlockCompressionCodecLzo.h
+hypertable/include/Hypertable/Lib/BlockCompressionCodecNone.h
+hypertable/include/Hypertable/Lib/BlockCompressionCodecQuicklz.h
+hypertable/include/Hypertable/Lib/BlockCompressionCodecZlib.h
+hypertable/include/Hypertable/Lib/BlockCompressionHeader.h
+hypertable/include/Hypertable/Lib/BlockCompressionHeaderCommitLog.h
+hypertable/include/Hypertable/Lib/Cell.h
+hypertable/include/Hypertable/Lib/Cells.h
+hypertable/include/Hypertable/Lib/Client.h
+hypertable/include/Hypertable/Lib/CommitLog.h
+hypertable/include/Hypertable/Lib/CommitLogBase.h
+hypertable/include/Hypertable/Lib/CommitLogBlockStream.h
+hypertable/include/Hypertable/Lib/CommitLogReader.h
+hypertable/include/Hypertable/Lib/CompressorFactory.h
+hypertable/include/Hypertable/Lib/Config.h
+hypertable/include/Hypertable/Lib/DataGenerator.h
+hypertable/include/Hypertable/Lib/DataGeneratorColumn.h
+hypertable/include/Hypertable/Lib/DataGeneratorQualifier.h
+hypertable/include/Hypertable/Lib/DataGeneratorRowComponent.h
+hypertable/include/Hypertable/Lib/DataSource.h
+hypertable/include/Hypertable/Lib/EventHandlerMasterChange.h
+hypertable/include/Hypertable/Lib/FixedRandomStringGenerator.h
+hypertable/include/Hypertable/Lib/HqlCommandInterpreter.h
+hypertable/include/Hypertable/Lib/HqlHelpText.h
+hypertable/include/Hypertable/Lib/HqlInterpreter.h
+hypertable/include/Hypertable/Lib/HqlParser.h
+hypertable/include/Hypertable/Lib/IntervalScanner.h
+hypertable/include/Hypertable/Lib/Key.h
+hypertable/include/Hypertable/Lib/KeySpec.h
+hypertable/include/Hypertable/Lib/LoadDataEscape.h
+hypertable/include/Hypertable/Lib/LoadDataFlags.h
+hypertable/include/Hypertable/Lib/LoadDataSource.h
+hypertable/include/Hypertable/Lib/LoadDataSourceFactory.h
+hypertable/include/Hypertable/Lib/LoadDataSourceFileDfs.h
+hypertable/include/Hypertable/Lib/LoadDataSourceFileLocal.h
+hypertable/include/Hypertable/Lib/LoadDataSourceStdin.h
+hypertable/include/Hypertable/Lib/LocationCache.h
+hypertable/include/Hypertable/Lib/MasterClient.h
+hypertable/include/Hypertable/Lib/MasterFileHandler.h
+hypertable/include/Hypertable/Lib/MasterMetaLog.h
+hypertable/include/Hypertable/Lib/MasterMetaLogEntryFactory.h
+hypertable/include/Hypertable/Lib/MasterMetaLogReader.h
+hypertable/include/Hypertable/Lib/MasterProtocol.h
+hypertable/include/Hypertable/Lib/MetaLog.h
+hypertable/include/Hypertable/Lib/MetaLogDfsBase.h
+hypertable/include/Hypertable/Lib/MetaLogEntryBase.h
+hypertable/include/Hypertable/Lib/MetaLogReader.h
+hypertable/include/Hypertable/Lib/MetaLogReaderDfsBase.h
+hypertable/include/Hypertable/Lib/MetaLogVersion.h
+hypertable/include/Hypertable/Lib/RangeLocationInfo.h
+hypertable/include/Hypertable/Lib/RangeLocator.h
+hypertable/include/Hypertable/Lib/RangeServerClient.h
+hypertable/include/Hypertable/Lib/RangeServerMetaLog.h
+hypertable/include/Hypertable/Lib/RangeServerMetaLogEntries.h
+hypertable/include/Hypertable/Lib/RangeServerMetaLogEntryFactory.h
+hypertable/include/Hypertable/Lib/RangeServerMetaLogReader.h
+hypertable/include/Hypertable/Lib/RangeServerProtocol.h
+hypertable/include/Hypertable/Lib/RangeState.h
+hypertable/include/Hypertable/Lib/RootFileHandler.h
+hypertable/include/Hypertable/Lib/ScanBlock.h
+hypertable/include/Hypertable/Lib/ScanSpec.h
+hypertable/include/Hypertable/Lib/Schema.h
+hypertable/include/Hypertable/Lib/SerializedKey.h
+hypertable/include/Hypertable/Lib/Stats.h
+hypertable/include/Hypertable/Lib/StatsV0.h
+hypertable/include/Hypertable/Lib/Table.h
+hypertable/include/Hypertable/Lib/TableDumper.h
+hypertable/include/Hypertable/Lib/TableMutator.h
+hypertable/include/Hypertable/Lib/TableMutatorCompletionCounter.h
+hypertable/include/Hypertable/Lib/TableMutatorDispatchHandler.h
+hypertable/include/Hypertable/Lib/TableMutatorFlushHandler.h
+hypertable/include/Hypertable/Lib/TableMutatorIntervalHandler.h
+hypertable/include/Hypertable/Lib/TableMutatorScatterBuffer.h
+hypertable/include/Hypertable/Lib/TableMutatorSendBuffer.h
+hypertable/include/Hypertable/Lib/TableMutatorShared.h
+hypertable/include/Hypertable/Lib/TableMutatorSyncDispatchHandler.h
+hypertable/include/Hypertable/Lib/TableScanner.h
+hypertable/include/Hypertable/Lib/TableSplit.h
+hypertable/include/Hypertable/Lib/TestData.h
+hypertable/include/Hypertable/Lib/TestSource.h
+hypertable/include/Hypertable/Lib/Timestamp.h
+hypertable/include/Hypertable/Lib/Types.h
+hypertable/include/ThriftBroker/Client.h
+hypertable/include/ThriftBroker/Client.thrift
+hypertable/include/ThriftBroker/Hql.thrift
+hypertable/include/ThriftBroker/ThriftHelper.h
+hypertable/include/Tools/Lib/CommandInterpreter.h
+hypertable/include/Tools/Lib/CommandShell.h
+hypertable/include/Tools/Lib/Notifier.h
+hypertable/lib/java/commons-cli-1.2.jar
+hypertable/lib/java/commons-logging-1.0.4.jar
+hypertable/lib/java/hadoop-core-0.20.2+320.LICENSE.txt
+hypertable/lib/java/hadoop-core-0.20.2+320.jar
+hypertable/lib/java/hbase-0.20.4.jar
+hypertable/lib/java/hive-exec-0.6.0.jar
+hypertable/lib/java/hive-metastore-0.6.0.jar
+hypertable/lib/java/hive-serde-0.6.0.jar
+hypertable/lib/java/hypertable-0.9.3.4-examples.jar
+hypertable/lib/java/hypertable-0.9.3.4.jar
+hypertable/lib/java/junit-4.3.1.LICENSE.txt
+hypertable/lib/java/junit-4.3.1.jar
+hypertable/lib/java/libthrift-0.3.0.jar
+hypertable/lib/java/log4j-1.2.13.jar
+hypertable/lib/java/slf4j-api-1.5.8.jar
+hypertable/lib/java/slf4j-log4j12-1.5.8.jar
+hypertable/lib/java/zookeeper-3.2.2.jar
+hypertable/lib/libHyperComm.a
+hypertable/lib/libHyperCommon.a
+hypertable/lib/libHyperDfsBroker.a
+hypertable/lib/libHyperDfsCmds.a
+hypertable/lib/libHyperRanger.a
+hypertable/lib/libHyperThrift.a
+hypertable/lib/libHyperThriftConfig.a
+hypertable/lib/libHyperTools.a
+hypertable/lib/libHyperspace.a
+hypertable/lib/libHypertable.a
+hypertable/lib/perl/Hypertable/ThriftClient.pm
+hypertable/lib/perl/client_test.pl
+hypertable/lib/perl/gen-perl/Hypertable/ThriftGen/ClientService.pm
+hypertable/lib/perl/gen-perl/Hypertable/ThriftGen/Constants.pm
+hypertable/lib/perl/gen-perl/Hypertable/ThriftGen/Types.pm
+hypertable/lib/perl/gen-perl/Hypertable/ThriftGen2/Constants.pm
+hypertable/lib/perl/gen-perl/Hypertable/ThriftGen2/HqlService.pm
+hypertable/lib/perl/gen-perl/Hypertable/ThriftGen2/Types.pm
+hypertable/lib/php/ThriftClient.php
+hypertable/lib/php/client_test.php
+hypertable/lib/php/gen-php/Client/ClientService.php
+hypertable/lib/php/gen-php/Client/Client_types.php
+hypertable/lib/php/gen-php/Hql/HqlService.php
+hypertable/lib/php/gen-php/Hql/Hql_types.php
+hypertable/lib/py/client_test.py
+hypertable/lib/py/gen-py/__init__.py
+hypertable/lib/py/gen-py/hyperthrift/__init__.py
+hypertable/lib/py/gen-py/hyperthrift/gen/ClientService-remote
+hypertable/lib/py/gen-py/hyperthrift/gen/ClientService.py
+hypertable/lib/py/gen-py/hyperthrift/gen/__init__.py
+hypertable/lib/py/gen-py/hyperthrift/gen/constants.py
+hypertable/lib/py/gen-py/hyperthrift/gen/ttypes.py
+hypertable/lib/py/gen-py/hyperthrift/gen2/HqlService-remote
+hypertable/lib/py/gen-py/hyperthrift/gen2/HqlService.py
+hypertable/lib/py/gen-py/hyperthrift/gen2/__init__.py
+hypertable/lib/py/gen-py/hyperthrift/gen2/constants.py
+hypertable/lib/py/gen-py/hyperthrift/gen2/ttypes.py
+hypertable/lib/py/hypertable/__init__.py
+hypertable/lib/py/hypertable/thriftclient.py
+hypertable/lib/rb/client_test.rb
+hypertable/lib/rb/hypertable/gen-rb/client_constants.rb
+hypertable/lib/rb/hypertable/gen-rb/client_service.rb
+hypertable/lib/rb/hypertable/gen-rb/client_types.rb
+hypertable/lib/rb/hypertable/gen-rb/hql_constants.rb
+hypertable/lib/rb/hypertable/gen-rb/hql_service.rb
+hypertable/lib/rb/hypertable/gen-rb/hql_types.rb
+hypertable/lib/rb/hypertable/thrift_client.rb
+@dirrm hypertable/lib/rb/hypertable/gen-rb
+@dirrm hypertable/lib/rb/hypertable
+@dirrm hypertable/lib/rb
+@dirrm hypertable/lib/py/hypertable
+@dirrm hypertable/lib/py/gen-py/hyperthrift/gen2
+@dirrm hypertable/lib/py/gen-py/hyperthrift/gen
+@dirrm hypertable/lib/py/gen-py/hyperthrift
+@dirrm hypertable/lib/py/gen-py
+@dirrm hypertable/lib/py
+@dirrm hypertable/lib/php/gen-php/Hql
+@dirrm hypertable/lib/php/gen-php/Client
+@dirrm hypertable/lib/php/gen-php
+@dirrm hypertable/lib/php
+@dirrm hypertable/lib/perl/gen-perl/Hypertable/ThriftGen2
+@dirrm hypertable/lib/perl/gen-perl/Hypertable/ThriftGen
+@dirrm hypertable/lib/perl/gen-perl/Hypertable
+@dirrm hypertable/lib/perl/gen-perl
+@dirrm hypertable/lib/perl/Hypertable
+@dirrm hypertable/lib/perl
+@dirrm hypertable/lib/java
+@dirrm hypertable/lib
+@dirrm hypertable/include/Tools/Lib
+@dirrm hypertable/include/Tools
+@dirrm hypertable/include/ThriftBroker
+@dirrm hypertable/include/Hypertable/Lib
+@dirrm hypertable/include/Hypertable
+@dirrm hypertable/include/Hyperspace
+@dirrm hypertable/include/DfsBroker/Lib
+@dirrm hypertable/include/DfsBroker
+@dirrm hypertable/include/Common
+@dirrm hypertable/include/AsyncComm
+@dirrm hypertable/include
+@dirrm hypertable/examples/hql_tutorial
+@dirrm hypertable/examples/freebase
+@dirrm hypertable/examples/apache_log
+@dirrm hypertable/examples
+@dirrm hypertable/conf
+@dirrm hypertable/bin
+@dirrm hypertable