aboutsummaryrefslogtreecommitdiffstats
path: root/databases/influxdb/Makefile
diff options
context:
space:
mode:
authoreugen <eugen@FreeBSD.org>2017-09-14 19:17:52 +0800
committereugen <eugen@FreeBSD.org>2017-09-14 19:17:52 +0800
commit32fb333957ac1cc819702ae88f8e6efaed17aa13 (patch)
treec7a0624af16390636265bf85aa855b1c11bae0bb /databases/influxdb/Makefile
parent9a5b4ff2662f08fce0481f01c153cb2212f84e05 (diff)
downloadfreebsd-ports-gnome-32fb333957ac1cc819702ae88f8e6efaed17aa13.tar.gz
freebsd-ports-gnome-32fb333957ac1cc819702ae88f8e6efaed17aa13.tar.zst
freebsd-ports-gnome-32fb333957ac1cc819702ae88f8e6efaed17aa13.zip
Redirect all output to syslog by means of daemon(8) having syslog support
in recent FreeBSD versions and by means of piping it to logger(1) for previous FreeBSD versions: add influxd_facility and influxd_priority variables (defaults to daemon.info). Bump PORTREVISION. PR: 221960 Submitted by: Sascha Holzleiter Approved by: cheffo (maintainer)
Diffstat (limited to 'databases/influxdb/Makefile')
-rw-r--r--databases/influxdb/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/databases/influxdb/Makefile b/databases/influxdb/Makefile
index 9c89655c52d2..d5c90cfc4725 100644
--- a/databases/influxdb/Makefile
+++ b/databases/influxdb/Makefile
@@ -3,6 +3,7 @@
PORTNAME= influxdb
PORTVERSION= 1.3.3
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= databases net-mgmt
MAINTAINER= cheffo@freebsd-bg.org
@@ -72,6 +73,15 @@ INFLUXD_DBDIR= /var/db/${PORTNAME}/
INFLUXD_LOGDIR= /var/log/${PORTNAME}/
INFLUXD_PIDDIR= /var/run/${PORTNAME}/
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == "FreeBSD" && ((${OSVERSION} >= 1100513 && ${OSVERSION} < 1200000) || \
+ ${OSVERSION} >= 1200015)
+SUB_LIST+= INFLUXD_LOGCMD="daemon"
+.else
+SUB_LIST+= INFLUXD_LOGCMD="logger"
+.endif
+
post-patch:
@${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT_DEFAULT}/${PORTNAME}
@cd ${WRKSRC} && \
@@ -115,4 +125,4 @@ do-install-MANPAGES-on:
${INSTALL_MAN} ${WRKSRC}/src/github.com/influxdata/influxdb/man/$i ${STAGEDIR}${MAN8PREFIX}/man/man1
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>