aboutsummaryrefslogtreecommitdiffstats
path: root/databases/influxdb
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2016-04-22 06:27:38 +0800
committergirgen <girgen@FreeBSD.org>2016-04-22 06:27:38 +0800
commiteaab3eaa8de5b983ee26223928f0d28dcf7d8142 (patch)
treeb2a335ab84e9606ea62abffdbaf5e3d61442049e /databases/influxdb
parent750f5a8353dacfb168c7971756b9dcd2a1737c3a (diff)
downloadfreebsd-ports-gnome-eaab3eaa8de5b983ee26223928f0d28dcf7d8142.tar.gz
freebsd-ports-gnome-eaab3eaa8de5b983ee26223928f0d28dcf7d8142.tar.zst
freebsd-ports-gnome-eaab3eaa8de5b983ee26223928f0d28dcf7d8142.zip
The load_rc_config need to happen before the : ${influx_flags:=xxx} since these
variables are used in for example command_args=xxx. the colon construct only sets the variable if it is not set. Approved-by: maintainer
Diffstat (limited to 'databases/influxdb')
-rw-r--r--databases/influxdb/Makefile1
-rw-r--r--databases/influxdb/files/influxd.in4
2 files changed, 3 insertions, 2 deletions
diff --git a/databases/influxdb/Makefile b/databases/influxdb/Makefile
index 8d18696b7cd7..d819548c2c2d 100644
--- a/databases/influxdb/Makefile
+++ b/databases/influxdb/Makefile
@@ -2,6 +2,7 @@
PORTNAME= influxdb
PORTVERSION= 0.12.1
+PORTREVISION= 1
DISTVERSIONPREFIX= v
CATEGORIES= databases net-mgmt
diff --git a/databases/influxdb/files/influxd.in b/databases/influxdb/files/influxd.in
index 1e76d9f47028..f5d51bf8fef7 100644
--- a/databases/influxdb/files/influxd.in
+++ b/databases/influxdb/files/influxd.in
@@ -23,6 +23,7 @@
name="influxd"
rcvar=influxd_enable
+load_rc_config $name
: ${influxd_enable:="NO"}
: ${influxd_user:="%%INFLUXD_USER%%"}
@@ -35,7 +36,7 @@ rcvar=influxd_enable
influxd_pidfile="%%INFLUXD_PIDDIR%%${name}.pid"
procname="%%PREFIX%%/bin/${name}"
command=/usr/sbin/daemon
-command_args=" -c -p ${influxd_pidfile} ${procname} ${influxd_options}"
+command_args="-c -p ${influxd_pidfile} ${procname} ${influxd_options}"
start_precmd="influxd_precmd"
influxd_precmd()
@@ -43,5 +44,4 @@ influxd_precmd()
install -o ${influxd_user} /dev/null ${influxd_pidfile}
}
-load_rc_config $name
run_rc_command "$1"