aboutsummaryrefslogtreecommitdiffstats
path: root/databases/kyotocabinet/Makefile
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-01-19 06:48:39 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-01-19 06:48:39 +0800
commit7625812bae5f3403981fb6ab461d88b01f3933ac (patch)
tree2f03ba3354b6c35f15d4610bf9c3884cd92374c8 /databases/kyotocabinet/Makefile
parent292953452d87727a07f96d60af700012ca949e3d (diff)
downloadfreebsd-ports-gnome-7625812bae5f3403981fb6ab461d88b01f3933ac.tar.gz
freebsd-ports-gnome-7625812bae5f3403981fb6ab461d88b01f3933ac.tar.zst
freebsd-ports-gnome-7625812bae5f3403981fb6ab461d88b01f3933ac.zip
- Use INSTALL_TARGET=install-strip instead of STRIP_CMD
Diffstat (limited to 'databases/kyotocabinet/Makefile')
-rw-r--r--databases/kyotocabinet/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/databases/kyotocabinet/Makefile b/databases/kyotocabinet/Makefile
index f41be42519e2..096476b0951b 100644
--- a/databases/kyotocabinet/Makefile
+++ b/databases/kyotocabinet/Makefile
@@ -17,6 +17,7 @@ OPTIONS_DEFINE= DOCS
CPPFLAGS+= -fPIC
GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
MAKE_ARGS= PCDIR=${PREFIX}/libdata/pkgconfig
REINPLACE_ARGS= -i ''
USE_LDCONFIG= yes
@@ -29,7 +30,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|-lstdc++ ||g' ${WRKSRC}/configure ${WRKSRC}/doc/spex.html ${WRKSRC}/example/Makefile ${WRKSRC}/lab/kcdict/Makefile
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/libkyotocabinet.so.16.13.0
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libkyotocabinet.so.16.13.0
${FIND} ${STAGEDIR}${DOCSDIR}/ -type d -exec ${CHMOD} ${BINMODE} '{}' \;
${FIND} ${STAGEDIR}${DOCSDIR}/ -type f -exec ${CHMOD} ${DOCMODE} '{}' \;