aboutsummaryrefslogtreecommitdiffstats
path: root/databases/kyototycoon
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-01-13 04:02:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-01-13 04:02:12 +0800
commit8533e471053a0facf04c07244922cf262c0838f2 (patch)
tree98b43b3ea7c64722f7c2745d1c5c3b2d3fd03188 /databases/kyototycoon
parentecda877bbc351087c4538e49f4b9b9ff3af419e8 (diff)
downloadfreebsd-ports-gnome-8533e471053a0facf04c07244922cf262c0838f2.tar.gz
freebsd-ports-gnome-8533e471053a0facf04c07244922cf262c0838f2.tar.zst
freebsd-ports-gnome-8533e471053a0facf04c07244922cf262c0838f2.zip
Add LZO option
- Add LICENSE_FILE - Use PORTDOCS - Convert to options target helper - Bump PORTREVISION for dependency change
Diffstat (limited to 'databases/kyototycoon')
-rw-r--r--databases/kyototycoon/Makefile13
-rw-r--r--databases/kyototycoon/pkg-plist181
2 files changed, 11 insertions, 183 deletions
diff --git a/databases/kyototycoon/Makefile b/databases/kyototycoon/Makefile
index 47f446f08ce6..43f4db831c2b 100644
--- a/databases/kyototycoon/Makefile
+++ b/databases/kyototycoon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kyototycoon
PORTVERSION= 0.9.56
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= databases
MASTER_SITES= http://fallabs.com/${PORTNAME}/pkg/ \
LOCAL/sunpoet
@@ -12,10 +12,11 @@ MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Handy cache/storage server
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libkyotocabinet.so:databases/kyotocabinet
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS LZO
CONFIGURE_ARGS= --enable-uyield
CPPFLAGS+= -fPIC
@@ -27,11 +28,19 @@ TEST_TARGET= check
USE_LDCONFIG= yes
USES= gmake pkgconfig
+PORTDOCS= *
+
+LZO_CONFIGURE_OFF= ac_cv_lib_lzo2_main=no
+LZO_CONFIGURE_ON= ac_cv_lib_lzo2_main=yes
+LZO_LIB_DEPENDS= liblzo2.so:archivers/lzo2
+
post-patch:
@${REINPLACE_CMD} -e 's|-lstdc++ ||g' ${WRKSRC}/configure ${WRKSRC}/doc/spex.html ${WRKSRC}/example/Makefile
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libkyototycoon.so.2.19.0 ${STAGEDIR}${PREFIX}/libexec/*.so
+
+post-install-DOCS-on:
${FIND} ${STAGEDIR}${DOCSDIR}/ -type d -exec ${CHMOD} ${BINMODE} {} \;
${FIND} ${STAGEDIR}${DOCSDIR}/ -type f -exec ${CHMOD} ${DOCMODE} {} \;
diff --git a/databases/kyototycoon/pkg-plist b/databases/kyototycoon/pkg-plist
index f887962f8abb..1ec7a92d384b 100644
--- a/databases/kyototycoon/pkg-plist
+++ b/databases/kyototycoon/pkg-plist
@@ -34,184 +34,3 @@ man/man1/kttimedtest.1.gz
man/man1/ktutilmgr.1.gz
man/man1/ktutilserv.1.gz
man/man1/ktutiltest.1.gz
-%%PORTDOCS%%%%DOCSDIR%%/COPYING
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/annotated.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/bc_s.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classes.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPClient-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPClient.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Logger-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Logger.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Session-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Session.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Session_1_1Data-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Session_1_1Data.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Worker-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1HTTPServer_1_1Worker.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce_1_1ReduceTaskQueue_1_1ReduceTask-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce_1_1ReduceTaskQueue_1_1ReduceTask.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce_1_1ValueIterator-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1MapReduce_1_1ValueIterator.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1PluggableDB-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1PluggableDB.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1PluggableServer-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1PluggableServer.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Pollable-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Pollable.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Poller-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Poller.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCClient-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCClient.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Logger-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Logger.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Session-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Session.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Session_1_1Data-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Session_1_1Data.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Worker-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RPCServer_1_1Worker.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB_1_1Cursor-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB_1_1Cursor.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB_1_1Error-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1RemoteDB_1_1Error.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ReplicationClient-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ReplicationClient.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ServerSocket-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ServerSocket.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1SharedLibrary-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1SharedLibrary.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Socket-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1Socket.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Logger-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Logger.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Session-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Session.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Session_1_1Data-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Session_1_1Data.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Worker-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1ThreadedServer_1_1Worker.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1Cursor-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1Cursor.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1UpdateTrigger-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1UpdateTrigger.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1Visitor-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1TimedDB_1_1Visitor.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1URL-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1URL.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1UpdateLogger-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1UpdateLogger.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1UpdateLogger_1_1Reader-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/classkyototycoon_1_1UpdateLogger_1_1Reader.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/closed.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/doxygen.css
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/doxygen.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/files.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x62.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x63.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x64.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x65.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x66.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x67.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x68.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x69.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6a.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6b.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6c.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6d.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6e.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x6f.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x70.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x71.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x72.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x73.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x74.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x75.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x76.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x77.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x78.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_0x7e.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_enum.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_eval.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x62.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x63.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x64.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x65.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x66.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x67.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x68.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x69.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6a.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6c.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6d.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6e.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x6f.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x70.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x71.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x72.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x73.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x74.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x75.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x76.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x77.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_func_0x7e.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/functions_vars.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/globals.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/globals_defs.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/hierarchy.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/index.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktcommon_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktdbext_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/kthttp_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktplugdb_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktplugserv_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktremotedb_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktrpc_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktshlib_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktsocket_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktthserv_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/kttimeddb_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktulog_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/ktutil_8h.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacekyototycoon.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers_func.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers_type.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespacemembers_vars.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/namespaces.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/nav_f.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/nav_h.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/open.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/structkyototycoon_1_1RemoteDB_1_1BulkRecord-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/structkyototycoon_1_1RemoteDB_1_1BulkRecord.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/structkyototycoon_1_1UpdateLogger_1_1FileStatus-members.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/structkyototycoon_1_1UpdateLogger_1_1FileStatus.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_a.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_b.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_h.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/tab_s.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/api/tabs.css
-%%PORTDOCS%%%%DOCSDIR%%/doc/command.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/common.css
-%%PORTDOCS%%%%DOCSDIR%%/doc/icon16.png
-%%PORTDOCS%%%%DOCSDIR%%/doc/index.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/index.ja.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/luadoc/index.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/luadoc/luadoc.css
-%%PORTDOCS%%%%DOCSDIR%%/doc/luadoc/modules/kyototycoon.html
-%%PORTDOCS%%%%DOCSDIR%%/doc/spex.html
-%%PORTDOCS%%%%DOCSDIR%%/kyototycoon.idl