aboutsummaryrefslogtreecommitdiffstats
path: root/databases/ldb/Makefile
diff options
context:
space:
mode:
authortimur <timur@FreeBSD.org>2018-02-21 07:17:49 +0800
committertimur <timur@FreeBSD.org>2018-02-21 07:17:49 +0800
commitf33b6cd0153eb445dedb56038fd01f21d9cbe339 (patch)
tree2fabf740e561c19f0117481a1e3f78a32d90d928 /databases/ldb/Makefile
parent88a957db9f041204e901cce3823ebd887c46db9f (diff)
downloadfreebsd-ports-gnome-f33b6cd0153eb445dedb56038fd01f21d9cbe339.tar.gz
freebsd-ports-gnome-f33b6cd0153eb445dedb56038fd01f21d9cbe339.tar.zst
freebsd-ports-gnome-f33b6cd0153eb445dedb56038fd01f21d9cbe339.zip
Update supplimentary Samba libs to the latest versions.
Sponsored by: iXsystems Inc.
Diffstat (limited to 'databases/ldb/Makefile')
-rw-r--r--databases/ldb/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/databases/ldb/Makefile b/databases/ldb/Makefile
index 74abac080e49..a5be3f96640f 100644
--- a/databases/ldb/Makefile
+++ b/databases/ldb/Makefile
@@ -22,7 +22,12 @@ LDB_DEPENDS= talloc>=2.1.8:devel/talloc \
tdb>=1.3.12,1:databases/tdb \
popt>=0:devel/popt
-CONFLICTS= ldb1[23]-1.*
+CONFLICTS_INSTALL= ldb1[23]-1.*
+
+#FLAVORS= default nopython
+#nopython_PKGNAMESUFFIX= -nopython
+#nopython_CONFLICTS= ldb
+#default_CONFLICTS= ldb-nopython
USES= compiler pkgconfig waf
USE_LDCONFIG= yes
@@ -38,7 +43,7 @@ CONFIGURE_ARGS+= --bundled-libraries=!talloc,!tevent,!tdb,!popt \
--with-privatelibdir=${PREFIX}/lib/ldb
CONFIGURE_ARGS+= --mandir=${MANPREFIX}/man \
- --infodir=${PREFIX}/${INFO_PATH}/${INFO_SUBDIR} \
+ --with-openldap=${LOCALBASE} \
--disable-rpath \
--without-gettext
@@ -143,13 +148,13 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpyldb-util.so
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/ldb.so
.else
-.for file in include/pyldb.h \
+.for f in include/pyldb.h \
lib/libpyldb-util.so \
lib/libpyldb-util.so.1 \
lib/ldb/libpytalloc-util.so.2
${RM} ${STAGEDIR}${PREFIX}/${file}
.endfor
-.for file in ${PYTHON_SITELIBDIR}/ldb.so \
+.for f in ${PYTHON_SITELIBDIR}/ldb.so \
${PYTHON_SITELIBDIR}/_ldb_text.py \
${PYTHON_SITELIBDIR}/_tdb_text.py \
${PYTHON_SITELIBDIR}/_tevent.so \