aboutsummaryrefslogtreecommitdiffstats
path: root/databases/ldb
diff options
context:
space:
mode:
authortimur <timur@FreeBSD.org>2017-11-22 01:00:12 +0800
committertimur <timur@FreeBSD.org>2017-11-22 01:00:12 +0800
commit463ea4aab295370fe01ae7ef55c28166845d1d24 (patch)
tree979630746e3f1fe921888b0b77638de4d25443f0 /databases/ldb
parent84330c3633a909c25455cca49803d96ac9159c1e (diff)
downloadfreebsd-ports-gnome-463ea4aab295370fe01ae7ef55c28166845d1d24.tar.gz
freebsd-ports-gnome-463ea4aab295370fe01ae7ef55c28166845d1d24.tar.zst
freebsd-ports-gnome-463ea4aab295370fe01ae7ef55c28166845d1d24.zip
Make sure that you can compile all supplimentary ports without Python bindings
Diffstat (limited to 'databases/ldb')
-rw-r--r--databases/ldb/Makefile22
1 files changed, 21 insertions, 1 deletions
diff --git a/databases/ldb/Makefile b/databases/ldb/Makefile
index c7fbc5e30a87..74abac080e49 100644
--- a/databases/ldb/Makefile
+++ b/databases/ldb/Makefile
@@ -77,7 +77,8 @@ PLIST_FILES= include/ldb_version.h \
%%PKGCONFIGDIR%%/ldb.pc
.if defined(NO_PYTHON)
-CONFIGURE_ARGS+= --disable-python
+USES+= python:2.7,build
+#CONFIGURE_ARGS+= --disable-python
.else
USES+= python:2.7
@@ -141,6 +142,25 @@ post-install:
.if !defined(NO_PYTHON)
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpyldb-util.so
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/ldb.so
+.else
+.for file in include/pyldb.h \
+ lib/libpyldb-util.so \
+ lib/libpyldb-util.so.1 \
+ lib/ldb/libpytalloc-util.so.2
+ ${RM} ${STAGEDIR}${PREFIX}/${file}
+.endfor
+.for file in ${PYTHON_SITELIBDIR}/ldb.so \
+ ${PYTHON_SITELIBDIR}/_ldb_text.py \
+ ${PYTHON_SITELIBDIR}/_tdb_text.py \
+ ${PYTHON_SITELIBDIR}/_tevent.so \
+ ${PYTHON_SITELIBDIR}/talloc.so \
+ ${PYTHON_SITELIBDIR}/tdb.so \
+ ${PYTHON_SITELIBDIR}/tevent.py \
+ ${PKGCONFIGDIR}/pyldb-util.pc
+ ${RM} ${STAGEDIR}/${file}
+.endfor
+ ${RMDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
+ ${RMDIR} ${STAGEDIR}${PYTHON_LIBDIR}
.endif
.include <bsd.port.post.mk>