aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libdbi-drivers/Makefile
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-10-02 22:30:41 +0800
committermnag <mnag@FreeBSD.org>2005-10-02 22:30:41 +0800
commit3f549b864335c68caf7345cd4f731c0f1b1fbe86 (patch)
treeb8a1bfaf47ce9d440ee329a2ecc5e4454ff854c6 /databases/libdbi-drivers/Makefile
parentbcf3b2a773718296c6b3d63ca89d781da8f5dc1d (diff)
downloadfreebsd-ports-gnome-3f549b864335c68caf7345cd4f731c0f1b1fbe86.tar.gz
freebsd-ports-gnome-3f549b864335c68caf7345cd4f731c0f1b1fbe86.tar.zst
freebsd-ports-gnome-3f549b864335c68caf7345cd4f731c0f1b1fbe86.zip
Update to 0.8.1
Add support to FreeTDS Approved by: delphij (maintainer via email), pav (mentor)
Diffstat (limited to 'databases/libdbi-drivers/Makefile')
-rw-r--r--databases/libdbi-drivers/Makefile33
1 files changed, 21 insertions, 12 deletions
diff --git a/databases/libdbi-drivers/Makefile b/databases/libdbi-drivers/Makefile
index 1cc251b92e1c..f485f44defb6 100644
--- a/databases/libdbi-drivers/Makefile
+++ b/databases/libdbi-drivers/Makefile
@@ -1,13 +1,12 @@
-# ex:ts=8
# Ports collection makefile for: libdbi-drivers
-# Date created: Oct 30, 2003
-# Whom: ijliao
+# Date created: Oct 30, 2003
+# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= libdbi-drivers
-PORTVERSION= 0.8.0
+PORTVERSION= 0.8.1
CATEGORIES= databases devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -24,21 +23,23 @@ CONFIGURE_ARGS= --disable-static \
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
-OPTIONS= MYSQL "With MySQL Driver" on \
+OPTIONS= MYSQL "With MySQL Driver" on \
MSQL "With MSQL Driver" off \
- PGSQL "With PostgreSQL Driver" on \
- SQLITE3 "With SQLite 3 Driver" on \
+ PGSQL "With PostgreSQL Driver" on \
SQLITE2 "With SQLite 2 Driver" off \
- FIREBIRD "With Firebird Driver" off
+ SQLITE3 "With SQLite 3 Driver" on \
+ FIREBIRD "With Firebird Driver" off \
+ FREETDS "With FreeTDS Driver" off
.include <bsd.port.pre.mk>
.if defined(WITHOUT_MYSQL) && defined(WITHOUT_MSQL) && defined(WITHOUT_PGSQL) \
- && defined(WITHOUT_SQLITE2) && defined(WITHOUT_SQLITE3) && defined(WITHOUT_FIREBIRD)
+ && defined(WITHOUT_SQLITE2) && defined(WITHOUT_SQLITE3) \
+ && defined(WITHOUT_FIREBIRD) && defined(WITHOUT_FREETDS)
IGNORE= You must choose at least one driver
.endif
-.if defined(WITH_MYSQL)
+.if !defined(WITHOUT_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql
PLIST_SUB+= MYSQL=""
@@ -54,7 +55,7 @@ PLIST_SUB+= MSQL=""
PLIST_SUB+= MSQL="@comment "
.endif
-.if defined(WITH_PGSQL)
+.if !defined(WITHOUT_PGSQL)
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-pgsql
PLIST_SUB+= PGSQL=""
@@ -70,7 +71,7 @@ PLIST_SUB+= SQLITE2=""
PLIST_SUB+= SQLITE2="@comment "
.endif
-.if defined(WITH_SQLITE3)
+.if !defined(WITHOUT_SQLITE3)
LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
CONFIGURE_ARGS+= --with-sqlite3
PLIST_SUB+= SQLITE3=""
@@ -86,6 +87,14 @@ PLIST_SUB+= FIREBIRD=""
PLIST_SUB+= FIREBIRD="@comment "
.endif
+.if defined(WITH_FREETDS)
+LIB_DEPENDS+= tds.4:${PORTSDIR}/databases/freetds
+CONFIGURE_ARGS+= --with-freetds
+PLIST_SUB+= FREETDS=""
+.else
+PLIST_SUB+= FREETDS="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O20|${CFLAGS}|g' ${WRKSRC}/configure