aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libgda3-postgresql
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-03-24 12:22:10 +0800
committermarcus <marcus@FreeBSD.org>2008-03-24 12:22:10 +0800
commitf0b4aa980c25521d15227b009cfbb3dc07c84756 (patch)
tree98bdb579143aa76fbf3813390ce7d197a5836ea5 /databases/libgda3-postgresql
parentaf73a3076d60d735901e19a2fe0751dfe4f7100b (diff)
downloadfreebsd-ports-gnome-f0b4aa980c25521d15227b009cfbb3dc07c84756.tar.gz
freebsd-ports-gnome-f0b4aa980c25521d15227b009cfbb3dc07c84756.tar.zst
freebsd-ports-gnome-f0b4aa980c25521d15227b009cfbb3dc07c84756.zip
Update libgda3 to 3.0.2, and split out the various database backends as
slave ports. Submitted by: kwm
Diffstat (limited to 'databases/libgda3-postgresql')
-rw-r--r--databases/libgda3-postgresql/Makefile23
-rw-r--r--databases/libgda3-postgresql/pkg-plist14
2 files changed, 37 insertions, 0 deletions
diff --git a/databases/libgda3-postgresql/Makefile b/databases/libgda3-postgresql/Makefile
new file mode 100644
index 000000000000..4fae3399ae44
--- /dev/null
+++ b/databases/libgda3-postgresql/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libgda2
+# Date created: 02 June 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/databases/libgda3-postgresql/Makefile,v 1.2 2008/02/26 21:23:35 kwm Exp $
+#
+
+PORTREVISION?= 0
+CATEGORIES= databases gnome
+PKGNAMESUFFIX?= -postgresql
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Provides postgresql access for the libgda3 library
+
+MASTERDIR= ${.CURDIR}/../libgda3
+BUILD_WRKSRC= ${WRKSRC}/providers/postgres/
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+PLIST= ${.CURDIR}/pkg-plist
+
+LIBGDA3_SLAVE= postgresql
+
+.include "${MASTERDIR}/Makefile"
diff --git a/databases/libgda3-postgresql/pkg-plist b/databases/libgda3-postgresql/pkg-plist
new file mode 100644
index 000000000000..8c0d2adbcb72
--- /dev/null
+++ b/databases/libgda3-postgresql/pkg-plist
@@ -0,0 +1,14 @@
+lib/libgda-%%VERSION%%/providers/libgda-postgres.a
+lib/libgda-%%VERSION%%/providers/libgda-postgres.la
+lib/libgda-%%VERSION%%/providers/libgda-postgres.so
+libdata/pkgconfig/libgda-postgres-%%VERSION%%.pc
+share/libgda-%%VERSION%%/postgres_specs_add_column.xml
+share/libgda-%%VERSION%%/postgres_specs_create_db.xml
+share/libgda-%%VERSION%%/postgres_specs_create_index.xml
+share/libgda-%%VERSION%%/postgres_specs_create_table.xml
+share/libgda-%%VERSION%%/postgres_specs_drop_column.xml
+share/libgda-%%VERSION%%/postgres_specs_drop_db.xml
+share/libgda-%%VERSION%%/postgres_specs_drop_index.xml
+share/libgda-%%VERSION%%/postgres_specs_drop_table.xml
+share/libgda-%%VERSION%%/postgres_specs_dsn.xml
+share/libgda-%%VERSION%%/postgres_specs_rename_table.xml