aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libgda3
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-12 02:08:52 +0800
committerbapt <bapt@FreeBSD.org>2013-12-12 02:08:52 +0800
commit9e5cb1459a01fd8c1c634cfa701605e9f3c26969 (patch)
treeac2afa8997fbb76350bd6fad85df12e98e0b3da5 /databases/libgda3
parent9809a0e2d7f5a501e93d80ac9ed19d9522dc5b4d (diff)
downloadfreebsd-ports-gnome-9e5cb1459a01fd8c1c634cfa701605e9f3c26969.tar.gz
freebsd-ports-gnome-9e5cb1459a01fd8c1c634cfa701605e9f3c26969.tar.zst
freebsd-ports-gnome-9e5cb1459a01fd8c1c634cfa701605e9f3c26969.zip
In preparation for making libtool generate libraries with a sane name, fix all
LIB_DEPENDS in databases
Diffstat (limited to 'databases/libgda3')
-rw-r--r--databases/libgda3/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/databases/libgda3/Makefile b/databases/libgda3/Makefile
index 1467d4ab86ed..e1b315de26fc 100644
--- a/databases/libgda3/Makefile
+++ b/databases/libgda3/Makefile
@@ -19,7 +19,7 @@ LIBGDA3_SLAVE?= no
.if !defined(REFERENCE_PORT)
-LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt
USE_AUTOTOOLS= libtool
USE_GCC= any
@@ -66,7 +66,7 @@ CONFIGURE_ARGS+= --without-ldap
.endif
.if ${LIBGDA3_SLAVE}=="firebird"
-LIB_DEPENDS+= gds.2:${PORTSDIR}/databases/firebird20-client
+LIB_DEPENDS+= libgds.so:${PORTSDIR}/databases/firebird20-client
CONFIGURE_ARGS+= --with-firebird=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-firebird
@@ -77,7 +77,7 @@ CONFIGURE_ARGS+= --without-firebird
BROKEN= Does not compile on sparc64
.endif
-LIB_DEPENDS+= tds.5:${PORTSDIR}/databases/freetds
+LIB_DEPENDS+= libtds.so:${PORTSDIR}/databases/freetds
CONFIGURE_ARGS+= --with-tds=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-tds
@@ -91,7 +91,7 @@ CONFIGURE_ARGS+= --without-mdb
.endif
.if ${LIBGDA3_SLAVE}=="odbc"
-LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
CONFIGURE_ARGS+= --with-odbc=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-odbc