aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libgdamm/Makefile
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2003-10-01 22:57:16 +0800
committerbland <bland@FreeBSD.org>2003-10-01 22:57:16 +0800
commitc6d39970abfa3275701833349af3b63e0e98c274 (patch)
tree8040b0c0a5f5fea70111d57f3571d220e968baa9 /databases/libgdamm/Makefile
parent605af90b116ef97910a78925c866d490bd203ea7 (diff)
downloadfreebsd-ports-gnome-c6d39970abfa3275701833349af3b63e0e98c274.tar.gz
freebsd-ports-gnome-c6d39970abfa3275701833349af3b63e0e98c274.tar.zst
freebsd-ports-gnome-c6d39970abfa3275701833349af3b63e0e98c274.zip
Add libgdamm 1.3.0, C++ wrapper for libgda2 library.
Diffstat (limited to 'databases/libgdamm/Makefile')
-rw-r--r--databases/libgdamm/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/databases/libgdamm/Makefile b/databases/libgdamm/Makefile
new file mode 100644
index 000000000000..179f9ce4d145
--- /dev/null
+++ b/databases/libgdamm/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libglademm
+# Date created: 1 Oct 2003
+# Whom: Alexander Nedotsukov <bland@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libgdamm
+PORTVERSION= 1.3.0
+CATEGORIES= databases gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.3
+DIST_SUBDIR= gnome2
+
+MAINTAINER= bland@FreeBSD.org
+COMMENT= C++ wrapper for libgda2 library
+
+LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack libgda2
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-static
+
+.include <bsd.port.mk>