aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libgdamm/Makefile
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2005-03-17 21:50:07 +0800
committerbland <bland@FreeBSD.org>2005-03-17 21:50:07 +0800
commitd01c856f2bef3927e594f5419442f61f2a202d65 (patch)
treebbc3579975ea6b84961a1fbfc6d1b2bfad5b8650 /databases/libgdamm/Makefile
parent66d302b06d081651e2a728fe3a6fff380721380f (diff)
downloadfreebsd-ports-gnome-d01c856f2bef3927e594f5419442f61f2a202d65.tar.gz
freebsd-ports-gnome-d01c856f2bef3927e594f5419442f61f2a202d65.tar.zst
freebsd-ports-gnome-d01c856f2bef3927e594f5419442f61f2a202d65.zip
Update to 1.3.6
Diffstat (limited to 'databases/libgdamm/Makefile')
-rw-r--r--databases/libgdamm/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/databases/libgdamm/Makefile b/databases/libgdamm/Makefile
index ade13cae5e8c..756f6fae7c2a 100644
--- a/databases/libgdamm/Makefile
+++ b/databases/libgdamm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libgdamm
-PORTVERSION= 1.3.0
-PORTREVISION= 6
+PORTVERSION= 1.3.6
CATEGORIES= databases gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/1.3
@@ -16,15 +15,25 @@ DIST_SUBDIR= gnome2
MAINTAINER= bland@FreeBSD.org
COMMENT= C++ wrapper for libgda2 library
-LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2
+LIB_DEPENDS= glibmm-2.4:${PORTSDIR}/devel/glibmm
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
USE_X_PREFIX= yes
+USE_GCC= 3.4
USE_GMAKE= yes
USE_GNOME= gnomehack libgda2
-USE_INC_LIBTOOL_VER= 13
+USE_INC_LIBTOOL_VER= 15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
.include <bsd.port.mk>