aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libiodbc/Makefile
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2012-04-12 22:26:27 +0800
committerrakuco <rakuco@FreeBSD.org>2012-04-12 22:26:27 +0800
commit9ecc1e987ba238e2f9d840d5c71815402ec3839a (patch)
tree1aef63caa609ac5c050116e7aa0799aa5293fe3a /databases/libiodbc/Makefile
parent15f91da0f7bdcfa314d68a104561c8671dacd1f5 (diff)
downloadfreebsd-ports-gnome-9ecc1e987ba238e2f9d840d5c71815402ec3839a.tar.gz
freebsd-ports-gnome-9ecc1e987ba238e2f9d840d5c71815402ec3839a.tar.zst
freebsd-ports-gnome-9ecc1e987ba238e2f9d840d5c71815402ec3839a.zip
Update to 3.52.8.
This commit also tries to clean up the infrastructure a little bit. It compiled fine on 7.4, 8.2, 9.0 and 10 on redports: - Remove iodbc.org from the MASTER_SITES list, it doesn't seem to exist anymore. - Set LICENSE. - Remove USE_GMAKE, it seems to build fine with make(1). - Remove the pthreads-related hacks and seds, as they do not seem to be needed anymore, especially now that only pthreads exists. - Remove the -D_BSD_WCHAR_T_DEFINED and the patch in files/, as libiodbc itself has accounted for _BSD_WCHAR_T_DECLARED since 2003. - Act on the example code based on NOPORTEXAMPLES instead of NOPORTDOCS.
Diffstat (limited to 'databases/libiodbc/Makefile')
-rw-r--r--databases/libiodbc/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/databases/libiodbc/Makefile b/databases/libiodbc/Makefile
index 6ccaa29fc6a6..8227e10c00dd 100644
--- a/databases/libiodbc/Makefile
+++ b/databases/libiodbc/Makefile
@@ -6,27 +6,27 @@
#
PORTNAME= libiodbc
-PORTVERSION= 3.52.7
+PORTVERSION= 3.52.8
CATEGORIES= databases
-MASTER_SITES= http://www.iodbc.org/downloads/iODBC/ \
- SF/iodbc/iodbc/${PORTVERSION}
+MASTER_SITES= SF/iodbc/iodbc/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= An ODBC 3.x driver manager, for universal data source access
+LICENSE= BSD LGPL20
+LICENSE_COMB= dual
+LICENSE_FILE_BSD= ${WRKSRC}/LICENSE.BSD
+LICENSE_FILE_LGPL20= ${WRKSRC}/LICENSE.LGPL
+
CONFLICTS= unixODBC-[0-9]*
USE_GNOME= gnomehack pkgconfig
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --with-iodbc-inidir=${ETCDIR}
USE_LDCONFIG= yes
MAN1= iodbc-config.1 iodbctest.1 iodbctestw.1
-CPPFLAGS+= ${PTHREAD_CFLAGS} -D_BSD_WCHAR_T_DEFINED_
-LDFLAGS+= ${PTHREAD_LIBS}
-
.if defined(WITH_GUI)
USE_GNOME+= gtk20
MAN1+= iodbcadm-gtk.1
@@ -38,8 +38,6 @@ PLIST_SUB+= GUI="@comment "
post-patch:
@${REINPLACE_CMD} -e \
- 's|$$CFLAGS -pthread|$$CFLAGS|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
'/^SUBDIRS/s|samples||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
's|-ldl||g' ${WRKSRC}/admin/libiodbc.pc.in
@@ -52,8 +50,10 @@ post-install:
.for f in AUTHORS ChangeLog NEWS README
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
-.for f in Makefile iodbctest.c
+.for f in Makefile.sample iodbctest.c
${INSTALL_DATA} ${WRKSRC}/samples/${f} ${EXAMPLESDIR}
.endfor
.endif