aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libsdb
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-07-02 21:23:51 +0800
committerijliao <ijliao@FreeBSD.org>2001-07-02 21:23:51 +0800
commitb3765efccd4276f9e137c078facae221ab77864c (patch)
treedc3a701162721c7f6505e2ede1898c68eb1ae5c4 /databases/libsdb
parent46b8432e1c4aea4b5d85f0e003072d5cd3d17e3a (diff)
downloadfreebsd-ports-gnome-b3765efccd4276f9e137c078facae221ab77864c.tar.gz
freebsd-ports-gnome-b3765efccd4276f9e137c078facae221ab77864c.tar.zst
freebsd-ports-gnome-b3765efccd4276f9e137c078facae221ab77864c.zip
add libsdb
Simple database library
Diffstat (limited to 'databases/libsdb')
-rw-r--r--databases/libsdb/Makefile21
-rw-r--r--databases/libsdb/distinfo1
-rw-r--r--databases/libsdb/pkg-comment1
-rw-r--r--databases/libsdb/pkg-descr14
-rw-r--r--databases/libsdb/pkg-plist9
5 files changed, 46 insertions, 0 deletions
diff --git a/databases/libsdb/Makefile b/databases/libsdb/Makefile
new file mode 100644
index 000000000000..7f481663e8e0
--- /dev/null
+++ b/databases/libsdb/Makefile
@@ -0,0 +1,21 @@
+# ex:ts=8
+# New ports collection makefile for: libsdb
+# Date created: Jul 2, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libsdb
+PORTVERSION= 0.2.1
+CATEGORIES= databases
+MASTER_SITES= ftp://siag.nu/pub/libsdb/ \
+ http://siag.nu/pub/libsdb/
+DISTNAME= sdb-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/databases/libsdb/distinfo b/databases/libsdb/distinfo
new file mode 100644
index 000000000000..fc110a3291b7
--- /dev/null
+++ b/databases/libsdb/distinfo
@@ -0,0 +1 @@
+MD5 (sdb-0.2.1.tar.gz) = 2baa7d6c79c1545b46c4c610b429cd19
diff --git a/databases/libsdb/pkg-comment b/databases/libsdb/pkg-comment
new file mode 100644
index 000000000000..31e9094ecd3d
--- /dev/null
+++ b/databases/libsdb/pkg-comment
@@ -0,0 +1 @@
+Simple database library
diff --git a/databases/libsdb/pkg-descr b/databases/libsdb/pkg-descr
new file mode 100644
index 000000000000..e8092ec1b6f4
--- /dev/null
+++ b/databases/libsdb/pkg-descr
@@ -0,0 +1,14 @@
+This is libsdb, the simple database library, which provides a way to support
+multiple database management systems in an application with negligeable
+overhead, in terms of code as well as system resources.
+
+Supported databases:
+ - Lago
+ - Mysql
+ - Sqlite
+ - Mimer
+ - Postgresql
+ - Oracle
+ - Gdbm
+
+WWW: http://siag.nu/libsdb/
diff --git a/databases/libsdb/pkg-plist b/databases/libsdb/pkg-plist
new file mode 100644
index 000000000000..80b1d302009c
--- /dev/null
+++ b/databases/libsdb/pkg-plist
@@ -0,0 +1,9 @@
+bin/sdb-config
+bin/sdb_client
+bin/sdbd
+bin/sdbd_client
+include/sdb.h
+lib/libsdb.a
+lib/libsdb.la
+lib/libsdb.so
+lib/libsdb.so.0