aboutsummaryrefslogtreecommitdiffstats
path: root/databases/libzbxpgsql
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2016-08-16 15:57:21 +0800
committermatthew <matthew@FreeBSD.org>2016-08-16 15:57:21 +0800
commit0ddf0a0851708116229a36e7fcc2cf62103d2a48 (patch)
tree7138b38cc9992db741c1971204c30d97bb80a072 /databases/libzbxpgsql
parent19e9e79b188c13a29cd65e989a50e31f19f177d7 (diff)
downloadfreebsd-ports-gnome-0ddf0a0851708116229a36e7fcc2cf62103d2a48.tar.gz
freebsd-ports-gnome-0ddf0a0851708116229a36e7fcc2cf62103d2a48.tar.zst
freebsd-ports-gnome-0ddf0a0851708116229a36e7fcc2cf62103d2a48.zip
This project provides comprehensive monitoring of PostgreSQL servers using a
natively compiled Zabbix agent module, written in C. The module enables discovery and monitoring of tablespaces, databases, namespaces, tables, indexes, etc. A preconfigured Zabbix Template is also included for your convenience. WWW: http://cavaliercoder.com/libzbxpgsql/ PR: 211844 Submitted by: Martin Waschbuesch <martin@waschbuesch.de>
Diffstat (limited to 'databases/libzbxpgsql')
-rw-r--r--databases/libzbxpgsql/Makefile32
-rw-r--r--databases/libzbxpgsql/distinfo3
-rw-r--r--databases/libzbxpgsql/files/patch-src_libzbxpgsql.c12
-rw-r--r--databases/libzbxpgsql/pkg-descr9
-rw-r--r--databases/libzbxpgsql/pkg-message5
-rw-r--r--databases/libzbxpgsql/pkg-plist3
6 files changed, 64 insertions, 0 deletions
diff --git a/databases/libzbxpgsql/Makefile b/databases/libzbxpgsql/Makefile
new file mode 100644
index 000000000000..adca647e839a
--- /dev/null
+++ b/databases/libzbxpgsql/Makefile
@@ -0,0 +1,32 @@
+# Created by: Martin Waschbuesch <martin@waschbuesch.de>
+# $FreeBSD$
+
+PORTNAME= libzbxpgsql
+PORTVERSION= 1.0.0
+DISTVERSIONPREFIX= v
+CATEGORIES= databases
+
+MAINTAINER= martin@waschbuesch.de
+COMMENT= Zabbix agent module for comprehensive monitoring of PostgreSQL servers
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${NONEXISTENT}:net-mgmt/zabbix3-agent:patch
+RUN_DEPENDS= ${LOCALBASE}/sbin/zabbix_agentd:net-mgmt/zabbix3-agent
+
+USE_GITHUB= yes
+GH_ACCOUNT= cavaliercoder
+
+USES= autoreconf gmake libtool pgsql
+GNU_CONFIGURE= yes
+GET_ZBX_WRKSRC= cd ${.CURDIR:H:H}/net-mgmt/zabbix3-agent && make -V WRKSRC
+CONFIGURE_ARGS= --with-zabbix=$$(${GET_ZBX_WRKSRC})
+
+USE_LDCONFIG= yes
+
+do-install:
+ ${INSTALL_LIB} ${WRKSRC}/src/.libs/libzbxpgsql.so ${STAGEDIR}${PREFIX}/lib/libzbxpgsql.so
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_MAN} ${WRKSRC}/template_postgresql_server.xml ${STAGEDIR}${EXAMPLESDIR}/template_postgresql_server.xml
+
+.include <bsd.port.mk>
diff --git a/databases/libzbxpgsql/distinfo b/databases/libzbxpgsql/distinfo
new file mode 100644
index 000000000000..04a5711e9593
--- /dev/null
+++ b/databases/libzbxpgsql/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1471038836
+SHA256 (cavaliercoder-libzbxpgsql-v1.0.0_GH0.tar.gz) = 0a9e64297c16ffff8374352d8edde6e6fc04b197be440623dcb3c1568fbbfe03
+SIZE (cavaliercoder-libzbxpgsql-v1.0.0_GH0.tar.gz) = 36032
diff --git a/databases/libzbxpgsql/files/patch-src_libzbxpgsql.c b/databases/libzbxpgsql/files/patch-src_libzbxpgsql.c
new file mode 100644
index 000000000000..e1ae90077e39
--- /dev/null
+++ b/databases/libzbxpgsql/files/patch-src_libzbxpgsql.c
@@ -0,0 +1,12 @@
+--- src/libzbxpgsql.c.orig 2016-06-25 14:18:03 UTC
++++ src/libzbxpgsql.c
+@@ -24,6 +24,9 @@
+ */
+
+ #include "libzbxpgsql.h"
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+
+ // Define custom keys
+ static ZBX_METRIC keys[] =
diff --git a/databases/libzbxpgsql/pkg-descr b/databases/libzbxpgsql/pkg-descr
new file mode 100644
index 000000000000..9df2997c40c5
--- /dev/null
+++ b/databases/libzbxpgsql/pkg-descr
@@ -0,0 +1,9 @@
+This project provides comprehensive monitoring of PostgreSQL servers using a
+natively compiled Zabbix agent module, written in C.
+
+The module enables discovery and monitoring of tablespaces, databases,
+namespaces, tables, indexes, etc.
+
+A preconfigured Zabbix Template is also included for your convenience.
+
+WWW: http://cavaliercoder.com/libzbxpgsql/
diff --git a/databases/libzbxpgsql/pkg-message b/databases/libzbxpgsql/pkg-message
new file mode 100644
index 000000000000..d906dcaf5853
--- /dev/null
+++ b/databases/libzbxpgsql/pkg-message
@@ -0,0 +1,5 @@
+In order to enable the module, add libzbxpgsql.so to the LoadModule=
+line in zabbix_agentd.conf and restart the agent with
+service zabbix_agentd restart
+A sample template has been placed in %%EXAMPLESDIR%%
+It can be imported into zabbix and assigned to a host.
diff --git a/databases/libzbxpgsql/pkg-plist b/databases/libzbxpgsql/pkg-plist
new file mode 100644
index 000000000000..c5ffe0496f31
--- /dev/null
+++ b/databases/libzbxpgsql/pkg-plist
@@ -0,0 +1,3 @@
+lib/libzbxpgsql.so
+@dir share/examples/libzbxpgsql
+@sample share/examples/libzbxpgsql/template_postgresql_server.xml