aboutsummaryrefslogtreecommitdiffstats
path: root/databases/memcached
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-03-07 18:56:32 +0800
committerbapt <bapt@FreeBSD.org>2014-03-07 18:56:32 +0800
commit1f6ddb5ce6ebb213eb419d4f608a3f992797d0ad (patch)
tree26f9b3655e20bb83f8a447b190c544fd5ff2e4a3 /databases/memcached
parentd0393b98a997615ed5e747ea9b09d9c2e31917fa (diff)
downloadfreebsd-ports-gnome-1f6ddb5ce6ebb213eb419d4f608a3f992797d0ad.tar.gz
freebsd-ports-gnome-1f6ddb5ce6ebb213eb419d4f608a3f992797d0ad.tar.zst
freebsd-ports-gnome-1f6ddb5ce6ebb213eb419d4f608a3f992797d0ad.zip
Fix installing manpage
Fix build with and without docs Fix memcached eating 100% of memory when built with both libevent2 and libevent 1.4 installed at the same time by making sure to always find the event.h from libevent2 first PR: ports/187337 ports/187340 ports/187309 Reported by: Lawrence "The Dreamer" Chen <beastie@tardisi.com>, Volodymyr Kostyrko <arcade@b1t.name>, Ross <basarevych@gmail.com>
Diffstat (limited to 'databases/memcached')
-rw-r--r--databases/memcached/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/databases/memcached/Makefile b/databases/memcached/Makefile
index 625cc6587e0d..377f881b06d6 100644
--- a/databases/memcached/Makefile
+++ b/databases/memcached/Makefile
@@ -3,7 +3,7 @@
PORTNAME= memcached
PORTVERSION= 1.4.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
${MASTER_SITE_GENTOO}
@@ -41,8 +41,8 @@ PLIST_DIRS= include/memcached
PORTDOCS= protocol.txt readme.txt
CFLAGS+= -fstack-protector \
- -I${LOCALBASE}/include \
- -I${LOCALBASE}/include/event2/compat
+ -I${LOCALBASE}/include/event2/compat \
+ -I${LOCALBASE}/include
DTRACE_COFNIGURE_ENABLE= dtrace
@@ -65,17 +65,14 @@ BROKEN= DTRACE broken with gcc/clang - reported upstream
post-patch:
@${REINPLACE_CMD} -e "s,-levent,-levent-2.0,g" ${WRKSRC}/configure
-post-configure:
- @${REINPLACE_CMD} -e 's#doc/memcached.1##' ${WRKSRC}/Makefile
-
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/memcached-tool ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${STAGEDIR}${MAN1PREFIX}/man/man1
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/doc/${i} ${STAGEDIR}${DOCSDIR}
.endfor
+
regression-test: test
test: build
${MAKE} -C ${WRKSRC} test