aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mongodb32/Makefile
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-04-13 22:06:24 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-04-13 22:06:24 +0800
commit9f4df15867a25946703f3398dfbf945618474fb1 (patch)
treedefd938b7ec03b8f0ff4a2b3e584629e6451d869 /databases/mongodb32/Makefile
parent9193a9268090867736d8a9787d2cf0f00eb3414c (diff)
downloadfreebsd-ports-gnome-9f4df15867a25946703f3398dfbf945618474fb1.tar.gz
freebsd-ports-gnome-9f4df15867a25946703f3398dfbf945618474fb1.tar.zst
freebsd-ports-gnome-9f4df15867a25946703f3398dfbf945618474fb1.zip
- Extend IGNORE condition from "< 10.0" to "< 10.2": this doesn't build on 10.1 either:
/usr/include/c++/v1/type_traits:433:76: error: no matching function for call to '__source' : public integral_constant<bool, sizeof(__is_function_imp::__test<_Tp>(__is_function_imp::__source<_Tp>())) == 1> ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ... src/mongo/db/catalog/database.cpp:618:32: note: while substituting deduced template arguments into function template 'function' [with _Fp = std::__1::__bind<mongo::Status (mongo::StorageEngine::Factory::*)(const mongo::BSONObj &) const, std::__1::placeholders::__ph<1> &, std::__1::placeholders::__ph<2> &>] stdx::bind(&StorageEngine::Factory::validateCollectionStorageOptions, ^ /usr/include/c++/v1/type_traits:424:28: note: candidate template ignored: substitution failure [with _Tp = mongo::Status (const mongo::BSONObj &) const]: reference to function type 'mongo::Status (const mongo::BSONObj &) const' cannot have 'const' qualifier template <class _Tp> _Tp& __source(); ~~~ ^ src/mongo/db/catalog/database.cpp:617:9: error: no matching function for call to 'validateStorageOptions' validateStorageOptions(collectionOptions.storageEngine, ^~~~~~~~~~~~~~~~~~~~~~ - While here, check OPSYS along with OSVERSION Reported by: pkg-fallout Approved by: portmgr blanket
Diffstat (limited to 'databases/mongodb32/Makefile')
-rw-r--r--databases/mongodb32/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/databases/mongodb32/Makefile b/databases/mongodb32/Makefile
index 9952f1480a09..13c06db34fb0 100644
--- a/databases/mongodb32/Makefile
+++ b/databases/mongodb32/Makefile
@@ -60,9 +60,9 @@ TEST_TARGET= unittests
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1000000
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1002000
# Cannot be built
-IGNORE= unsupported on FreeBSD 9 or older
+IGNORE= unsupported on FreeBSD 10.1 or older
.endif
post-install: