aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mongodb32/Makefile
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2018-05-20 17:24:10 +0800
committerriggs <riggs@FreeBSD.org>2018-05-20 17:24:10 +0800
commitf1a82f39e7af37598e3078e82bb40fab2c83f914 (patch)
tree66e8ac483681b1ef7f03744276e9f14eba946bc6 /databases/mongodb32/Makefile
parent46e03a42a209a2051fdeb0378cb611280d990502 (diff)
downloadfreebsd-ports-gnome-f1a82f39e7af37598e3078e82bb40fab2c83f914.tar.gz
freebsd-ports-gnome-f1a82f39e7af37598e3078e82bb40fab2c83f914.tar.zst
freebsd-ports-gnome-f1a82f39e7af37598e3078e82bb40fab2c83f914.zip
Adapt ${name}_limits to the new resource limiting mechanics for services
PR: 227218 Submitted by: 0mp
Diffstat (limited to 'databases/mongodb32/Makefile')
-rw-r--r--databases/mongodb32/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/databases/mongodb32/Makefile b/databases/mongodb32/Makefile
index 1e567b867b87..f31d54af40eb 100644
--- a/databases/mongodb32/Makefile
+++ b/databases/mongodb32/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mongodb32
PORTVERSION= 3.2.11
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= r
CATEGORIES= databases net
MASTER_SITES= https://fastdl.mongodb.org/src/ \
@@ -51,6 +51,14 @@ GROUPS= mongodb
USE_RC_SUBR= mongod
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1200057
+SUB_LIST+= LEGACY_LIMITS="@comment " MODERN_LIMITS=""
+.else
+SUB_LIST+= LEGACY_LIMITS="" MODERN_LIMITS="@comment "
+.endif
+
ALL_TARGET= core
TEST_TARGET= unittests