aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mongodb32/Makefile
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-02-27 22:18:16 +0800
committerkoobs <koobs@FreeBSD.org>2016-02-27 22:18:16 +0800
commit3c9cd92c76f5b00efe5a98dfd2c1de93867cb8a4 (patch)
tree18c73e062b72db27a4411ad74af9274fbed27730 /databases/mongodb32/Makefile
parentaeeb45269c847f00cc11d9dc51eef3fa82c066db (diff)
downloadfreebsd-ports-gnome-3c9cd92c76f5b00efe5a98dfd2c1de93867cb8a4.tar.gz
freebsd-ports-gnome-3c9cd92c76f5b00efe5a98dfd2c1de93867cb8a4.tar.zst
freebsd-ports-gnome-3c9cd92c76f5b00efe5a98dfd2c1de93867cb8a4.zip
databases/mongodb32: Update to 3.2.3
- Update PORTVERSION and distinfo checksum (3.2.3) [1] - Depend explicitly on Clang 3.7 - Update ONLY_FOR_ARCHS{_REASON} to exclude i386 Removes i386 support entirely, as even now I get pkg-fallout due to mozjs failing to build in some circumstances, and the maintenance burden isn't worth it given 32bit is deprecated. A future revision may conditionally check the existence of a global clang that meets the requirements of this port, but right now that requires fixing some issues in compiler.mk and I don't feel it appropriate to replicate its entire functionality to fix this port for now. PR: 207417 Reported by: <numisemis yahoo.com> [1] Submitted by: Brendan Molloy <brendan+freebsd bbqsrc net> (maintainer)
Diffstat (limited to 'databases/mongodb32/Makefile')
-rw-r--r--databases/mongodb32/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/databases/mongodb32/Makefile b/databases/mongodb32/Makefile
index b3e28a9c07f5..29fc265eab43 100644
--- a/databases/mongodb32/Makefile
+++ b/databases/mongodb32/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= mongodb32
-PORTVERSION= 3.2.1
+PORTVERSION= 3.2.3
DISTVERSIONPREFIX= r
-PORTREVISION= 1
CATEGORIES= databases net
MASTER_SITES= https://fastdl.mongodb.org/src/ \
http://fastdl.mongodb.org/src/ \
@@ -18,19 +17,25 @@ COMMENT= Distributed document-oriented "NoSQL" database
LICENSE= AGPLv3 APACHE20
LICENSE_COMB= multi
+# Bugs when compiled with < Clang 3.7
+# - https://jira.mongodb.org/browse/SERVER-21217
+# - https://jira.mongodb.org/browse/SERVER-22740
+BUILD_DEPENDS= ${LOCALBASE}/bin/clang37:${PORTSDIR}/lang/clang37
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
libsnappy.so:${PORTSDIR}/archivers/snappy
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:${PORTSDIR}/devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}pymongo>=3.0:${PORTSDIR}/databases/pymongo
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= "not yet ported to anything other than i386 and amd64"
+CPP= ${LOCALBASE}/bin/clang-cpp37
+CC= ${LOCALBASE}/bin/clang37
+CXX= ${LOCALBASE}/bin/clang++37
+CHOSEN_COMPILER_TYPE= clang
-OPTIONS_DEFINE= SASL SSL WIREDTIGER
-OPTIONS_DEFAULT= SSL WIREDTIGER
+ONLY_FOR_ARCHS= amd64
+ONLY_FOR_ARCHS_REASON= "Only supported on amd64 (i386 deprecated in v3)"
-# Only supported on 64-bit
-OPTIONS_EXCLUDE_i386= WIREDTIGER
+OPTIONS_DEFINE= SASL SSL
+OPTIONS_DEFAULT= SASL SSL
SASL_LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
SASL_MAKE_ARGS= --use-sasl-client
@@ -38,14 +43,9 @@ SASL_MAKE_ARGS= --use-sasl-client
SSL_USE= openssl=yes
SSL_MAKE_ARGS= --ssl
-WIREDTIGER_DESC= WiredTiger database engine support
-WIREDTIGER_VARS= wiredtiger_build=on
-WIREDTIGER_VARS_OFF= wiredtiger_build=off
-
USES= cpe execinfo python:build scons
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
- --wiredtiger=${WIREDTIGER_BUILD} \
--use-system-pcre --use-system-snappy \
--release
@@ -59,10 +59,6 @@ TEST_TARGET= unittests
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
-WIREDTIGER_BUILD= off
-.endif
-
.if ${OSVERSION} < 1000000
# Cannot be built
IGNORE= unsupported on FreeBSD 9 or older