aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mtop
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-12-17 11:27:46 +0800
committerijliao <ijliao@FreeBSD.org>2003-12-17 11:27:46 +0800
commitd7bb052dc20cbf76ad6978a180ee3af1206222f8 (patch)
treec6c7f35e446137d412d5bc29c11f488ed06056c6 /databases/mtop
parent1b145e7aa29d7a34c5ff8cac4d70a1e7e5756725 (diff)
downloadfreebsd-ports-gnome-d7bb052dc20cbf76ad6978a180ee3af1206222f8.tar.gz
freebsd-ports-gnome-d7bb052dc20cbf76ad6978a180ee3af1206222f8.tar.zst
freebsd-ports-gnome-d7bb052dc20cbf76ad6978a180ee3af1206222f8.zip
add mtop 0.6.4
MySQL Monitoring Tool
Diffstat (limited to 'databases/mtop')
-rw-r--r--databases/mtop/Makefile27
-rw-r--r--databases/mtop/distinfo1
-rw-r--r--databases/mtop/pkg-descr11
-rw-r--r--databases/mtop/pkg-plist3
4 files changed, 42 insertions, 0 deletions
diff --git a/databases/mtop/Makefile b/databases/mtop/Makefile
new file mode 100644
index 000000000000..1b86a956e05b
--- /dev/null
+++ b/databases/mtop/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: mtop
+# Date created: Dec 17, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mtop
+PORTVERSION= 0.6.4
+CATEGORIES= databases
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= MySQL Monitoring Tool
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Curses.pm:${PORTSDIR}/devel/p5-Curses \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql \
+ ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
+
+PERL_CONFIGURE= yes
+
+MAN1= mkill.1 mtop.1
+
+.include <bsd.port.mk>
diff --git a/databases/mtop/distinfo b/databases/mtop/distinfo
new file mode 100644
index 000000000000..1d383d907915
--- /dev/null
+++ b/databases/mtop/distinfo
@@ -0,0 +1 @@
+MD5 (mtop-0.6.4.tar.gz) = 3a7b400982e9dba8243a1424b9fdd244
diff --git a/databases/mtop/pkg-descr b/databases/mtop/pkg-descr
new file mode 100644
index 000000000000..b43262d70127
--- /dev/null
+++ b/databases/mtop/pkg-descr
@@ -0,0 +1,11 @@
+mtop (MySQL top) monitors a MySQL server showing the queries which are taking
+the most amount of time to complete. Features include 'zooming' in on a process
+to show the complete query, 'explaining' the query optimizer information for a
+query and 'killing' queries. In addition, server performance statistics,
+configuration information, and tuning tips are provided.
+
+mkill (MySQL kill) monitors a MySQL server for long running queries and kills
+them after a specified time interval. Queries can be selected based on regexes
+on the user, host, command, database, state and query.
+
+WWW: http://mtop.sourceforge.net/
diff --git a/databases/mtop/pkg-plist b/databases/mtop/pkg-plist
new file mode 100644
index 000000000000..c25124d2aa90
--- /dev/null
+++ b/databases/mtop/pkg-plist
@@ -0,0 +1,3 @@
+bin/mkill
+bin/mtop
+lib/cpan2spec.pl