aboutsummaryrefslogtreecommitdiffstats
path: root/databases/mysql++
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2003-02-13 20:48:48 +0800
committernork <nork@FreeBSD.org>2003-02-13 20:48:48 +0800
commit21fc689b8f20d2feac160de890eecfb4e951f429 (patch)
treeb5b7affcc39acac7cf430baffafa907f415f10ea /databases/mysql++
parent50fd459caf3b463f311b706095b45778c282b777 (diff)
downloadfreebsd-ports-gnome-21fc689b8f20d2feac160de890eecfb4e951f429.tar.gz
freebsd-ports-gnome-21fc689b8f20d2feac160de890eecfb4e951f429.tar.zst
freebsd-ports-gnome-21fc689b8f20d2feac160de890eecfb4e951f429.zip
Fix build on -CURRENT and reduce compiler warning on 3.x.
PR: ports/47467 Submitted by: Sergey Matveychuk <sem@ciam.ru> Approved by: Miklos Niedermayer <mico@vnet.hu>
Diffstat (limited to 'databases/mysql++')
-rw-r--r--databases/mysql++/Makefile18
-rw-r--r--databases/mysql++/distinfo2
2 files changed, 15 insertions, 5 deletions
diff --git a/databases/mysql++/Makefile b/databases/mysql++/Makefile
index e3d11111e600..63ba6aad9fff 100644
--- a/databases/mysql++/Makefile
+++ b/databases/mysql++/Makefile
@@ -18,13 +18,21 @@ LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
USE_GMAKE= yes
HAS_CONFIGURE= yes
-CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -D_FIX_FOR_BSD_ "
+CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -D_FIX_FOR_BSD_ -Wno-deprecated"
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500035
+PATCHFILES= mysql++-gcc-3.0.patch.gz \
+ mysql++-gcc-3.2.patch.gz
+PATCH_SITES= ${MASTER_SITES}
+PATCH_DIST_STRIP=-p1
+.endif
+
pre-configure:
- ${RM} ${WRKSRC}/examples/Makefile.in
- ${ECHO} "all:" >${WRKSRC}/examples/Makefile.in
- ${ECHO} "install:" >>${WRKSRC}/examples/Makefile.in
+ @${RM} ${WRKSRC}/examples/Makefile.in
+ @${ECHO} "all:" >${WRKSRC}/examples/Makefile.in
+ @${ECHO} "install:" >>${WRKSRC}/examples/Makefile.in
do-install:
@${INSTALL_PROGRAM} ${WRKDIR}/${DISTNAME}/sqlplusint/.libs/libsqlplus.so.1 ${PREFIX}/lib
@@ -40,4 +48,4 @@ do-install:
${INSTALL_DATA} mysql++ defs undef_short define_short *.hh ${PREFIX}/include/mysql)
@${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/mysql++
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/databases/mysql++/distinfo b/databases/mysql++/distinfo
index f07fe4cff1c7..26e168e43942 100644
--- a/databases/mysql++/distinfo
+++ b/databases/mysql++/distinfo
@@ -1 +1,3 @@
MD5 (mysql++-1.7.9.tar.gz) = 1312fb4e33dcce07fac5fa9c2ac801f7
+MD5 (mysql++-gcc-3.0.patch.gz) = 00958326410b942d352e6c7ceaafeeb9
+MD5 (mysql++-gcc-3.2.patch.gz) = fe3ef5852e96951a8eb5a172f2f19498